Question about Pool & Spa

1 Answer

Have an Old Circa 1990 Versa in-ground pool heater. Worked fine until this weekend. Haeter wouldn't start so I replaced pressure switch. After replacement still wouldn't start so I shook unit and it started shut down tried again 10 minutes later and it started. Today tried everything and won't start. What else can I check?

Posted by Anonymous on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 366 Answers

Check all the electrical connections for corrosion. The older millivolt heater run on less than one volt and it's critical that all connections are making good contact. Clean as many of them as you can. You can also try replacing the pilot generator/assy as they lose power over time. Test to make sure output is more than 500mv.

Posted on Jul 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rapak above ground pool heater is leaking from the bottom


leak is prolly from pressure switch connection or heat exchanger...... if from heat exchanger buy a new heater

Aug 20, 2010 | Raypak Versa 130,000 Btu Above Ground...

1 Answer

Heater not coming on


if voltage to unit then check transformer if voltage see if voltage to gas valve when igniting also check pressure switch

May 22, 2010 | Raypak Versa 130,000 Btu Above Ground...

1 Answer

Pool heater works intermittently. have replaced thermostat kit


Depending on model you will need to ck ethier millavoltes (1/2 to 3/4 of a volt)or 24 volts. but this sounds like a pressure problem. Start by cleaning your basketsand your filter. If this dosn't help you should pull the presure switch from the manifold on the heater and see if their is any corrosen or rust on the sw or in the manifold. One of these should fix your problem. Good luck.

Nov 24, 2009 | Raypak Versa 130,000 Btu Above Ground...

1 Answer

Heater is new, installed at grade on above ground pool that is 48" deep so pressure switch is 3' below the water line. With pressure switch adjustment turned fully clockwise the heater will run without the...


Adjust the switch fully in the opposite direction. If you are at 1.5 you are at the light end of the adjustment range of that switch, which can be adjusted up to 5psi. Then let it back off until it works reliably. Rarely do you need to adjust a pressure switch on an above ground pool so it should end up about in the middle of the adjustment scale.

Jul 09, 2009 | Hayward H250FDN Low NOx Natural Gas Pool...

2 Answers

Pool heater will not ignite


check pressure switch,if it is faulty or out of adjustment it wont allow it to go tomain burner

Jun 17, 2009 | Hayward 100,000 BTU Pool Heater H100ID1 -...

1 Answer

Have a Triton Millivolt pool heater pilot is lit and nothing!!


Low out put voltage from the pilot generator and/or an open circuit in the control circuit...the most common is a bad pressure switch (dirty filters can hamper pressure switch operation).

Jun 08, 2009 | Pentair PUREX MINIMAX HEATER; THERMOSTAT,...

1 Answer

Low pressure reading on Pool Heater


I had this problem with ours last year. I replaced the water pressure switch and it began working fine. We later had a symptom that the blower would start but it would not ignite. The ignitor rod was corroded so I took it out and sanded it with some sandpaper---worked fine...until I dropped it trying to reinstall and it broke. Bought a new one and it works fine now.

Today's problem is related to the blower now.... it is always something, isn't it?!?

May 10, 2009 | Jandy Laars LX Pool Heater / 400,000 BTU /...

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1368 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

6889 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...