Question about Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Green light comes on for a couple of seconds and then it turns red what could be the problem, i was cruizing pumping bass and it just cut out?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Is there a reset button on this unit somewhere it just stopped working one day while hot out side. I believe that all connections are good and steroe worrks w/out the amp....what could it be amp is not that old
b

Posted on Aug 11, 2010

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 70 Answers

Settings on amp could be wrong or you don't have enough voltage or you could have a short somewhere in the power wire

Posted on Jul 28, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red light comes on for a few seconds


Check the feed fets or the audio amplifier IC´s are damaged

Aug 16, 2009 | Rockford Fosgate Punch 401S Car Audio...

1 Answer

I have a digistat scr with a flashing red light and no heating there is nothing wrong with the batteries, this only occured after a poweer cut.


Try this first before condeming the unit.

1. Turn off the power supply to the Digistat SCR (receiver unit)
and leave for 5 seconds.
2. Turn on power to SCR unit and check red light is on.
3. Press override button No.2 and check the green light comes
on and boiler fires.
4. Press & hold down button No.1 (Keep depressed), then
press No.2 and keep depressed. {The Red LED light will flash
a couple of times and then it will go out}
5. Now release both the buttons – {the two LED lights should
come back on}
6. Get the Digistat+2RF/+3RF unit and stand two metres away
from the SCR unit with the Digistat+2RF/+3RF unit in your hand.
7. Remove the battery cover and fit the batteries.
8. The Red LED light on the SCR will now flash for approx. 7
seconds.
9. This confirms that the radio signal is being sent and
received.
10. The Digistat+2RF/+3RF and the SCR are now successfully
linked by a dedicated RF address.

Mar 21, 2009 | Water Heaters

1 Answer

2005 Hyundai Santa Fe ...cruize not working... the green cruize light comes on when i press the button, but does not control the speed at all..


be sure the brake lights are working this may be a problem with the brake light switch, also be sure to check all fuses in car and under hood please rate -jeff

Sep 13, 2008 | Hyundai Santa Fe Cars & Trucks

1 Answer

Tv cuts off and green light flashes


If your set was manufactured around July 2005, you may need a firmware upgrade to solve this issue. On the Sony website you can enter your model # and serial # to see if you TV is affected. If so, it is easy to have done and may be free from Sony. It sounds like the issue they described in the writeup on the required formware update. I had mine done within few months of when i bought it (purchased in Dec 2005) and it has been working flawlessly since.

Good luck!

Donnieboy999

Jul 19, 2008 | Sony KDF-E42A10 42 in. LCD Television

1 Answer

Speakers cut off when bass goes up...


sounds like you hava a load problem.if your'e running your woofers at 1ohm,make shure your amp is 1ohm stable.....

Jul 03, 2008 | Car Audio & Video

Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4874 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...