Question about Honeywell Air Conditioners

Open Question

My thermostat T8400c 1024 Won't turn on the screen is just blank

Posted by on

3 Suggested Answers

koolbreezes
  • 540 Answers

SOURCE: digital thermostat not working

Can you saY, Batteries!

Posted on Sep 15, 2008


mpcheeseman1
  • 1400 Answers

SOURCE: I have a Honeywell T8400C

Hello
Try taking the batteries out for 5 min,or disconnect power for 5min.
To clear it out.
Then re input all your times days and temps,

Is t stat in a cold location near a door or window?this could also override your settings,most progrmamble stats will go into override at 58.f im guessing this is not your problem.

If it continues after you reset,i would consider a new thermostat.

Hope this helps.

Posted on Jan 28, 2010

heatman101
  • 43501 Answers

SOURCE: changed honeywell T8400C 1024 to

Hi,
On the t-stat and the furnace make sure the wires are hooked like this...

Red to R
White to W
Green to G
Yellow to Y
Blue to C

then it should work..

Thermostat Wiring and Terminal Designations

heatman101

Posted on Jun 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The display on my thermostat T8400C 1024 isn't working. Everything else works but the heat and the flame is not igniting either. Please help.


Sounds like a manual limit needs to be reset (thermal disc). Generally the manual limits are around the exhaust - backdraft, or burner assembly - flame rollout.

Feb 15, 2014 | Honeywell Air Conditioners

1 Answer

Honeywell thermostat t8400c


Probably no power (24 volt) to the unit. Check 3amp fuse in the air handler. Also check that it's wired properly.

Sep 19, 2013 | Air Conditioners

1 Answer

I HAVE A HONEYWELL MANUAL THERMOSTAT NO BATTERIES ALL IT HAS ON THE BACK IS T8400C 1099 (2) 0710 1B HELP, IT DOES NOT SHOW ANY THING THE SCREEN IS BLANK


This model of Honeywell thermostat uses the 24v from the unit to power it. One of three things must have happened.

1. You have lost power to the furnace, therefore no power to thermostat.
2. You only have 4 wires hooked up on the thermostat and not 5. A lot of older homes had just 4 wire running to the thermostat, which will not work for this thermostat. You should have a wire connected to the (C) or (B) terminal on the thermostat, which ever one they have, I can't remember off hand. These are the Common terminals. They have to have the common from the furnace 24v power to operate.
3. Faulty thermostat, which will obviously have to be replaced.

Hope this helps and gets you to cooler days!

Jun 28, 2012 | Honeywell Air Conditioners

1 Answer

Changed honeywell T8400C 1024 to Hunter 44760, I have five wires white, red, yelliow, green, blue. Hunter Thermostat reads "NO A/C Power.


Hi,
On the t-stat and the furnace make sure the wires are hooked like this...

Red to R
White to W
Green to G
Yellow to Y
Blue to C

then it should work..

Thermostat Wiring and Terminal Designations

heatman101

Jun 12, 2011 | Air Conditioners

1 Answer

Totalline thermostat P4740130. Keep getting blank screen


mcdevito75 here Sounds like a faulty thermosat, un --plug a.c unit for a few mintes maybe it"ll recycle, plug back in wall and try again, if not see your local a/c repair shop.

Jun 21, 2010 | Air Conditioners

1 Answer

I have a Honeywell T8400C 1024 thermostat. the last two nights, our heat continues to run without shutting off at the pre-set temperature. We have woken up to 81 degrees in our house. What is the...


Hello
Try taking the batteries out for 5 min,or disconnect power for 5min.
To clear it out.
Then re input all your times days and temps,

Is t stat in a cold location near a door or window?this could also override your settings,most progrmamble stats will go into override at 58.f im guessing this is not your problem.

If it continues after you reset,i would consider a new thermostat.

Hope this helps.

Jan 28, 2010 | Air Conditioners

1 Answer

Carrier thermidistat screen went blank


Check the battery in the thermostat it is dead!! Should be 2 AA batterys!

Sep 11, 2009 | Carrier Air Conditioners

1 Answer

Honeywell thermostat T8400c started flashing, heat/cool was off. Display flashes all icons (heat and cooling icons, temperatures, everything) and on the oppposite flash, the setpoint is displayed. The fan...


Based on the simplicity of this particular t-stat, I really think that it is bad and needs to be replaced. They do not make this particular model anymore. I have included a link to the operators manual for the stat. Good luck!

http://customer.honeywell.com/techlit/pdf/PackedLit/69-1491.pdf

Apr 05, 2009 | Air Conditioners

Not finding what you are looking for?
Air Conditioners Logo

Related Topics:

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Honeywell Air Conditioners Experts

MightyMikeJr

Level 3 Expert

347 Answers

cheapdiesel

Level 1 Expert

5 Answers

Steve Kjr

Level 1 Expert

41 Answers

Are you a Honeywell Air Conditioner Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...