Question about Miele S558 Red Velvet Bagged Canister Vacuum

1 Answer

NO Power I just finished vaccuming, then I turned it off and moved it, and all of the sudden it will not go on at all. Is there a fuse in the vaccum that may have blown?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

There is a fuse, you have to take the top off to get to it.

NO Power - 6495b0f.gif
#225 is the fuse. You could have a problem with the reel cord asm also.

Posted on Apr 15, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Suddenly the vaccum cleaner stopped working


If you are in the UK check the fuse in the plug.

Oct 17, 2014 | Vacuums

1 Answer

My rain vaccum


Need more information...Are you having problem with Main unit or the power nozzle? You can also call and speak to a Rainbow Specialist.
RainVac
www.rainvac.com
800-523-0510

Oct 07, 2012 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Vacuum cleaner does not work


most upright vaccums have a reset button at lower rear area of the vaccum. operates similar to gfi plug reset, push button back in usually with small screwdriver. is your debris bag to full? power brush jammed with debris? hose plugged? this will cause motor to over heat and in turn kick out reset button. always unplug power cord before putting fingers in areas where moving parts are!!

Jan 01, 2012 | Bissell Vacuums

1 Answer

Turn on the power and nothing happened. I checked the power plug. It was ok. what caused the Vaccum didn't work? Thanks, Peter


Same, I have the same issue with this model. Brush motor is working but not the vaccum motor. Any ideas?

Jul 26, 2010 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

Was vaccuming and vaccum quit. Tried unplugging and turning back on. Getting absolutely no power. unscrewed screw under handle and tried to make sure connection was being made. Don't really know what to...


ok..If you have a multimeter you can check plug fuse then switch and motor, if you put leads across the plug you will get some reading if its working.could be thermal cut out on the motor.

Apr 18, 2010 | Kenmore Magic Blue 24195 Bagged Canister...

1 Answer

Vaccum problem


No sound at all? or the motor runs but no vaccuum?
did it stop while using it? might have overheated due to dirty filters... strange that the light comes on but no motor at all... that would suggest to me that the motor is shot...

Here is a link the the manual.. there is no reference to any user accessable fuse or breaker...


Peace,

Mar 07, 2010 | Bissell 6594 PowerForce Bagless Upright...

1 Answer

Bissell vaccum cleaner just turned off why


Ive had this problem before. I have never figured out what caused it. I let it be for a few minutes and it started working again.. weird.. I'd just let it sit for a few then try it again.

Mar 02, 2010 | Bissell 6594 PowerForce Bagless Upright...

1 Answer

Part terminology and replacement help


call tti floorcare 1800-321-1134. have your model number and the plant number ready you will need it

Apr 18, 2009 | Hoover U8171-900 / U8172-900 / U8173-900 /...

1 Answer

Steam Vaccum won't switch on


it sounds like your thermal fuse went out and u have to open it up ant test the fuse with a multimeter...I had the same problem and had to replace the thermal fuse...I ordered a fuse(sf188e) from ebay...cut the old one out and soldered in the new one...hope this helps.

Dec 30, 2008 | Euro-Pro Shark Steam Mop - Gray/ Purple...

2 Answers

Bissell vaccum problem


Could be plugged, check the hose and at the bottom by the brush roll, the inlet maybe clogged. Also check the filter under neath the dirt tank. There are filters above the dirt container, clean those out. If after that it is still loud, then maybe the motor fan or bearins are bad and will have to be replaced, part #2031214 sells for around $55.

Jan 16, 2008 | Bissell 3594 CleanView PowerTrak Bagless...

Not finding what you are looking for?
Miele S558 Red Velvet Bagged Canister Vacuum Logo

Related Topics:

398 people viewed this question

Ask a Question

Usually answered in minutes!

Top Miele Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18333 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you a Miele Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...