Question about Car Audio & Video

1 Answer

Kenwood KDC-MP632U display not working can I pull a dispay from another model? Any sugestions on how to fix? Thanks, Phil

Posted by on

  • Anonymous Aug 20, 2008

    I had the same problem with the display going out. I contact both Kenwood and Crutchfield and they wanted me to send it back to them so that they could look at it, but I didn't want to go through the whole process of taking it out and shipping it off. I'll probably scrap it and buy a better deck.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,550 Answers

Are a face detachable or the conector to the main board are a flat connector,because if are connected with a flat connector thats the problem

Posted on Apr 13, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hello I have the KDC MP632U and I need help on how to turn the aux on since my display faceplate does not work


well you can actually get your display working again in under 15 minutes with a soldering iron.(i know not exactly what you asked, but a more effective solution if you still have this stereo). take the deck out, remove the three screws holding the metal casing on. carefully move the cd player back an inch or two (make sure you don't pull out the ribbon cable for the cd by accident or unclip it if you know how) on the right side of the board you will see a 'chain' of resistors/ little black rectangles with R27 on them. resolder the ends of each one, either just remelt the solder that is there, or get the very fine electronics solder and add a bit on each spot. i am a lady and i did this today in about 15 minutes, and now my display works, so it is not too hard. i did get my hubby to remove the deck from the truck for me though :-)

Jul 18, 2012 | Kenwood KDC-MP632U

1 Answer

Kenwood kdc-mp632u display is blank


Possible that the display is faulty or there is a fault in the power line. Also check if the strip that connects to the display is faulty. If the unit works perfectly except for the display then the fault is only with the panel and a voltage check on the panel will confirm the loss .Use a multimeter to test the voltage and also check on the tracks for continuity.

Sep 28, 2011 | Car Audio & Video

1 Answer

My faceplate does not show display on my Kenwood kdc-mp632u. The lights work and the head unit in general plays the radio and cd's ect. now I have read somewhere that there are resistors inside so that...


I had the same problem and I resoldered the resistors on the board inside the stereo and it worked. Unscrew and remove the top cover and the CD slot. There are 10 of them located on the lower right side of the board. Good luck.

Jun 12, 2010 | Kenwood KDC-MP632U

1 Answer

My display is out. unit works otherwise


you probably have bad solder connections on some surface mount resistors inside the radio itself.

Aug 19, 2009 | Kenwood KDC-MP632U

1 Answer

I have a kdc mp632u and i cant get any sound out of my subwoofers. The amp comes on and there is power to the amp but still no sound. can someone tell step by step what i have to do to get it to work with...


Hello,

First, make sure that the RCA's from the HU to your amp are properly connected, and fully seated on both ends. There are 2 sets of outputs. You should be using the ones on the left as you face the rear of the HU. Here is a link to the manual. Page 40 shows the connections on the back:

http://inform3.kenwoodusa.com/manuals/KDCX590.pdf

After making sure that everything is connected OK, check to see if you have the subwoofer output turned on your MP632U.

To do this, push the control knob on the right toward AM (toward the bottom). Subwoofer output switches off/on each time you push it. When it is on, the display reads "SW ON".

If this does not solve the problem, you most likely have a defect in either the HU or the amp.

Hope this helps! If it does, please rate as "FixYa." Thanks!


Mar 28, 2009 | Kenwood KDC-MP632U

1 Answer

Can anyone help.... my stereo faceplate doesnt work the buttons light up but the display doesnt any solutions???? a friend have the same as me and I put the faceplate on his and it work so i dont know what...


Does the stereo have a lock? Maybe its locked or something.

What kind of stereo? Car stereo?

Try turning off completely and turning back on.

-Ryan


-please rate

Feb 18, 2009 | Kenwood KDC-MP632U

1 Answer

Display is OUT but everything functions....... what to do?


I just followed tech48's solution by resoldering the resistors on the main board.

Dec 29, 2008 | Kenwood KDC-MP632U

1 Answer

Face plate will not light up


my problem as i think was same..
..problem actually not plate...it something inside...
repair guy just fixed something inside...as i understand some condinsators heats and after some pereod of time its broked by himself..so he first was thinking that it was plate but after it he foung the problem in this condensators....actually problem in tape and not in plate...

Sep 18, 2008 | Kenwood KDC-MP632U

1 Answer

IPOD hookup for kdc-mp632u not working


Make sure your aux is turned on, and that should be the "source" that you use when playing your ipod.

Feb 08, 2008 | Kenwood KDC-MP632U

1 Answer

KCD-X590 is looking for a code that i never put in, and i bought the deck brand new


Method of clearing the programmable security
code (KDC-MP632U/X590)
1. While "– – – –" is being displayed, press [->> ] key for at
least 3 seconds while pressing [AUTO] or [TI] key.
This makes "– – – –" display disappear.
2. Using the remote controller, input "KCAR".
Press remote controller [5] key 2 times (Input for "K") and
then press [->> ] key.
Press remote controller [2] key 3 times (Input for "C") and
then press [ ->>] key.
Press remote controller [2] key once (Input for "A") and then
press [->> ] key.
Press remote controller [7] key 2 times (Input for "R") and
then press [->> ] key.
3. The security is released and the unit enters the STANDBY
mode.
4. If a wrong code is input, the unit goes into the Code Re-quest
mode.

Oct 14, 2007 | Kenwood KDC-X590 CD Player

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

234 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70365 Answers

The Knight
The Knight

Level 3 Expert

72640 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...