Question about Washing Machines

2 Answers

It´s a wd420. We

We have a hotpoint wd420. We had the module replaced a few months ago and now there is another problem. Not sure if it is the same, but it doesn´t wash properly, there is a slight burning smell, and of the 5 decending lights, from the top the 1st 2nd and 5th remain lit.
Any ideas? Is it worth paying another 90 pounds or should we just buy a new machine?
Thanks

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 32 Answers

Maybe a small item is stuck between the drum and casing or is jaming the outlet pump.

I would not leave burning smells without some resolution first

Posted on Apr 13, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Did who ever install this machine make sure that it was installed correctly and draining properly. The burning smell will go away with time.

Posted on Apr 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hotpoint wd420 shows error code f13 after replacing heater element for dryer.


Change electronic board it is what will cause this problem if you checked all ducts an fan and still heats board is bad

Oct 28, 2014 | Hotpoint Ariston Aquarius WD420 Front Load...

1 Answer

Where is the filter on a Hotpoint Aquarius wd420 washer dryer?


it is located at the back of the machine...are you encountering problems with this machine? check this link i will give you, this a forum/comments which the owners encountered different problems with this machine..

http://www.unbeatable.co.uk/p_rupr/Hotpoint-Aquarius-WD420-Front-Load-All-in-One-Washer--Dryer-Reviews/22394331.html

Nov 13, 2010 | Hotpoint Ariston Aquarius WD420 Front Load...

1 Answer

I have a HotPoint Aquarius washing machine WD420. When I switch it on,all the lights on the panel jst flash on and off continiously and nothing else happens.


If you have not already done so press the start/ cancel button for 3 seconds.
Switch off, wait 3 seconds, then switch on again, and try a programme
If it still will not work, then it is likely to be the display module, or the main power module. Also make sure the dryer knob is turned to off.
Please rate my solution.
Thankyou.

Feb 03, 2010 | Hotpoint Washing Machines

1 Answer

Broken machine door handle :(


Unplug at the mains, remove lid and door catch can be released from inside the machine.

Sep 16, 2009 | Hotpoint Ariston Aquarius WD420 Front Load...

1 Answer

HOTPOINT WD420 TRIPS ALL THE SOCKETS IN MY HOUSE


You have a fault on the machine which is a dead short or an earth leakage.

Neither can be sorted out without a set of testers and some knowledge

Unless you can get hold of a resistance checker and know how to use it call a in a repair person

Jun 14, 2009 | Hotpoint Ariston Aquarius WD420 Front Load...

1 Answer

Hotpoint wd420 not pumping


Hi,I have just been on a service call to the same model,the pump windings had shorted turns and after replacing the pump i have found that it has also damaged the module(pcb assembley) not good considering the module is 120 uk sterling!!

Feb 18, 2009 | Hotpoint Ariston Aquarius WD420 Front Load...

Not finding what you are looking for?
Washing Machines Logo

Related Topics:

88 people viewed this question

Ask a Question

Usually answered in minutes!

Top Washing Machines Experts

Dan Webster
Dan Webster

Level 3 Expert

8147 Answers

Richard Roth
Richard Roth

Level 3 Expert

9472 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Washing Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...