Question about Rockford Fosgate P3001 Car Audio Amplifier

1 Answer

No power My amp worked last year with no problem. I let it sit all through the the winter then I tried to hook it up in my car again and there was no power at all. I checked all the wires and fuses and still nothing. I even bought a new power wire and still nothing. What could be wrong with my amp?

Posted by on

  • dukey17 Jun 13, 2008

    i disconnected my amp for about 6 months and then stored it then tryed to reconect it but i just cant get the thermal light to go off and it to run power through ? ive rewiered it put a jump starter on my battery tryed differnt speekers cheked if power was running through the b+ cheked grounds fuses ?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

You need to confirm that you have voltage on the B+ and remote terminals and that you have a good ground. Do you have a multimeter?

Posted on Apr 22, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwoood kac-7202 redlight/no output


you blew the output Ic's (amps one or more ) you can fix this by replacing the output IC's

Jan 29, 2014 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Zx750.1 kicker amp cutting out


Also check your fuses. there may be a fuse for the in-tank fuse.

Jan 05, 2014 | Kicker (ZX750.1) Car Audio Amplifier

1 Answer

Lanzar Car Amplifiers


try a different amp and see how long it last. try an amp that is a different amp and double check your wiring.

Nov 26, 2013 | Lanzar Car Audio & Video

1 Answer

I have an AudioBahn A4004T Amp. It was working fine and then I had it sitting in my house for a few months. My cousin wants to use it in his car so he hooked the power cables up to his battery to see if it...


If you only hooked up the power and ground the amp will not turn on. You must also hook up the remote wire. This either can come from your radio, your fuses, or your power wire itself. If you hook it up to your radio then it will turn on when the radio is turned on. If your radio doesn't have a remote wire to amp then you can read your owners manual and hook it up to the radio fuse and when the radio turns on the amp will turn on. An lastly you can run a wore from your power wire to your remote plug in. But if you do this the nano will constantly be on if it is hooked up to the battery.

Dec 25, 2010 | AudioBahn A4004T Car Audio Amplifier

1 Answer

My amp protection will not turn off i tryed almost everything?


i wish i can chat to you live so i can ask you qestions about your amp but to figure out what section of the amp might be fried it could be the power supply section could be the out put section or the in put section but i would try process of elimulation try unplugging your rca jacks and your subs unhook to your amp just the power hook up and try powering it but if the protection light steel comes on then try to remeber the last time your amp was working good and playing your subs was your amp getting hot if so you probaly fried your out put chips and not telling what else next question was you just hooking your amp up in your car and acually touch one of the power wire to the ground on your amp this happen to my friend and fried the power circuit relay chip on the power supply thats all the advice i can give but usually when the protection light comes on and you got every thing hook up right something fried

Oct 29, 2009 | Power Acoustik LT-980/2 Car Audio...

1 Answer

I have a power acoustik ps2-2600 it went out this morning the red light was on i checked the ground it was fine when i unhook the remote or the audio cables it turns off if i hook up the audio alone it...


unhook all the cables including power let sit for 15 minutes and than hook up the ground rca cables remote and than power in that order with the car off and the battery unhooked that hook the battery up the amp went to protect mode to keep it from blowing i hope your amp isnt like some that only the factory can reset most amps arent and reset themselves

Apr 20, 2009 | Car Audio & Video

1 Answer

MA Audio HK4002


Well if the Repair shop comes highly recommended, they should not have charged you if the repair did not last. I run a repair shop and everything I repair comes with a 90 day warranty. No way will MA take your amp back now that a repair shop has busted into it. I can feel for you about wanting it to work. I am very surprised you still are trying. I do not have a remedy that will be free. Get yourselof on track with a new amp for Christmas, keep the receipt this time and try the manufacturer first before going to a repair shop. I know I might get a bad vote on this comment. Sorry

Nov 30, 2007 | Car Audio & Video

1 Answer

Legaxy LA2098 2400 watt 2 channel amp


Humm.. Have you check your remote wire? If you know the amp is getting power for sure, diconnect your subs from the amp leave only the + - and remote hooked up. Check again if still same thing nothing, try taking a jumper wire to the batt terminal over to the remote terminal. This should let your amp kick on, IF SO your remote wire has a short some where. IF NO i would check your ground wire again and make sure its good and along with all your fuses. IF NO still might have internal damage. BUT if it did work dont leave it hooked up like that, it WILL stay on untill u remove the jumper wire. I just use this lil trick to help save time with trouble shooting. Hope this was helpful i had the same prob with my amp remote wire was bad

Nov 17, 2006 | Legacy LA2098 Car Audio Amplifier

1 Answer

Amp overheating


You could just have a simple idling bias or dc balance alighnment thats needs attention. Always take care of the smaller problems before they grow as this problem could grow to where it pops your outputs , your speakers or the drivers. Try this before sending it in. 480-967-3565 Good Luck

Jun 09, 2006 | Rockford Fosgate Power 1000BD Car Audio...

Not finding what you are looking for?
Rockford Fosgate P3001 Car Audio Amplifier Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Professor_V
Professor_V

Level 2 Expert

89 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...