Question about Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP AND CORD -

1 Answer

My new ec50 is clogging frequently. Is at 18 psi

I am opening my pool for the season and my new ec50 1.5 hp is clogging frequently. Is at 18 psi after de is added. When pressure reaches around 23 which is after about two hours the filter stops working effeciently.I then bump the filter and it starts working properly only to clogg again in an hour or two. I don't believe the system is taking in enough material to clog so quickly. Am I doing something wrong? What psi is the filter intended to be running at.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Hayward Master
  • 1,338 Answers

Lower the better (psi) this means the water is flowing fast through the filter, high pressures means it's time to clean filter again. keep cleaning until the pool is squeaky clean, then you can go back to cleaning once a week
Jay the pool pump motor repair guy Longwood Florida

Posted on Jun 23, 2017

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 653 Answers

SOURCE: Pool Sand Filter

The volume of a 24x4 pool is 1809.6 cubic feet [Volume=pi x radius squared x height, or V=3.14159 x(12x12)x4], and the 18 foot pool is 1017.9 cubic feet [V=3.14159 x (9x9)x4]. When you multiply the number of cubic feet by the conversion factor of 7.48 gallons per cubic foot, you come out with 13,536 gallons versus 7614 gallons. Since the volume is nearly double, I don't think the other filter will cut it for very long. Is the top that is cracked in the valve body or the top part of the tank? It might be cheaper and easier to just replace the defective part in the long run than to use an undersized filter that will die prematurely.

Posted on Apr 16, 2009

SOURCE: my pump pressure is 10psi i cleaned the de filters they seem fine i have good floe out of my jets but when i hook the pool cleaner up pressure drops to almost nothing. could my impeller be the problem

The pressure you are reading is the pressure in the filter tank as water is pumped though it. When the filter is freshly charged, 9 PSI is a good pressure.

As the filter removes particles from the water the filter gets "dirty" -- it takes more pressure to push the water through it thus raising the PSI.

I think you are viewing this in reverse. Low filter pressure is "good" (as long as it stays above 8 PSI) -- as the filter cleans the water the PSI will increase -- when it gets to 15-20 PSI it needs to be back-washed and recharged.

The pressure drops when the pool cleaner is connected because pool cleaners always pull in air (in varying amounts) because of all the hose connections. This causes your filter/tank pressure to drop.

Posted on May 31, 2009

  • 8 Answers

SOURCE: my hayward de filter will not filter over 1 hour

How much DE are you putting in it??? If it is a EC40 then no more than 4 small coffee cans of DE.
If it is an EC65, then no more than 6 - small coffee cans of DE. ( you can even shy back by a 1/2 of can of DE, without any problems.
Is the pool green??? If so, the filter will continue to plug up until clean.
Keep your Chlorine abit on the high side...DE filters run best with a chl reading of 3.0

Posted on Jun 21, 2009

mattofilms
  • 110 Answers

SOURCE: loses suction after 2 hours

Filters are getting blocked.

Clean more offten - use filter socks (if have skimmer box).

OR get better pump/filter system.

Posted on Jul 07, 2009

lemmingleejn
  • 173 Answers

SOURCE: My Aqua Critter seems to get clogged up pretty

It most certainly is.
The simplest solution, is to sort of half the work for it, by collecting as much leaf litter, as you can with a net, before sending in the critter.
Also, a cover, will drastically minimize the amount of litter entering the water.
Have fun fishing:)

Posted on Jul 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Pump loses power


if impeller is not clogged check on recirculate if ok change sand

Jun 05, 2013 | Sta Rite StaRite Duraglas Pump 1 12 HP...

1 Answer

Low preusre


If the pump basket is clean and there are no suction leaks, the problem may be that debris has gotten past the pump basket and is clogging the impeller.
A quick way to check is to fill the pump pot (where the basket goes) with water. Leave the lid off and start the pump. The water should be sucked out immediately.
If the water takes more than about half a second to go down you have a clogged impeller and the pump needs to be opened to clear it.

Mar 07, 2013 | Waterway Champion 1 1/2 Hp 230v Energy...

1 Answer

Pump stops suction when I try to vacum pool


1. Something is stopping the seal at the basket
2. The hose going to the filter housing is partially clogged or not sealed
3. If you have a 2nd filter basket before filter housing, clogged/not sealed
4. Filter is clogged and needs to be cleaned, not just dirt, but degreased
5. Leaking pressure valve if one is used

I had a large filter and regular pressure was well above 5 psi, (8 to 10psi) with everything cleaned and running, once vacuum hose was connected it jumped to 14 to 18 psi.

May 05, 2012 | Hayward 1 12 Hp Super Swimming Pool Pump...

1 Answer

I have hayward 1 h.p. pump cant get it to prime it will pump at a trickle it has to pull 3-4' rise to the pump is this to much height? or is my intake line clogged? or?


The rise is more than ok. You could have a plugged line or a plugged impeller or an air leak. I would look to the suction pipe coming into the pump and the lid and "O" ring on it.

Sep 29, 2010 | Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP...

1 Answer

High psi, low intake and output. That possible?


Thank you for posting your question here on Fixya.com.

High pressure at the filter means the water is held up and not able to freely flow thru, hence the rise in pressure. If repeated bumps and refills are not working your filter fabric is clogged. You can try to wash them (again I assume) and if necessary even try acid washing as well. If none of these works you'll need to replace the fabric or the entire assemblies which is usually near the price of just replacing the filter.

If this answer does not fix your problem, please comment with additional details prior to rating the answer. Positive feedback is appreciated once your problem is solved!

John

Jul 13, 2010 | Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP...

1 Answer

Pump loses presssure when automatic pool cleaner is installed


If you have outtake valves post filter (versus intake pre-filter and motor) you could try choking those down to reduce flow back to the pool but maintain pressure through your pump and filter...

Aug 26, 2009 | Hayward 1HP Super Pump II Inground Pool...

1 Answer

WE have a EC50 system w/1HP matrix. Pump runs


Hayward Matrixs' have a one year warranty.

If it is tripping the circuit that is usually an electrical problem, and has nothing to do with the motor. Open up that back with the motor off and try to turn that shaft with a flat head, if it turns than it is an electrical problem; if it doesn't then contact Hayward directly for warranty information. Hayward is a pain to get ahold of but they are great about honoring their warranties.

The Matrixs' are fairly new and I have yet to see a shaft freeze up.

Jul 17, 2009 | Hayward EC50C Perflex Filter w/ 1 HP Pump...

1 Answer

My pump is running however it's pressure is less than 10 psi and the heater on the pool will not run.


With the Jacuzzi Magnum pool pumps, low pressure is going to likely be cause by one of the issues below. Try these troubleshooting tips.

1.Pump not primed

2.Leakage of air into suction system

3.Impeller clogged

4.Valve in suction or discharge line partly closed or suction or discharge line partly plugged or too small. 5.Plugged basket in skimmer or hair in lint strainer.

6.Dirty filter.

Jun 06, 2009 | Jacuzzi MAGNUM POOL PUMP 1-1/2 HP MAGNUM...

Not finding what you are looking for?
Hayward EC50 SYSTEM W/ 1 HP MATRIX PUMP AND CORD - Logo

Related Topics:

1,161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hayward Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Bill Jordan

Level 2 Expert

372 Answers

john h

Level 3 Expert

12104 Answers

Are you a Hayward Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...