Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My kenwood kac-929 amp is melting my ground cable help

I need advice on how to fix

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Teacher:

    An expert who has written 2 tips or uploaded 1 video tip.

  • Contributor
  • 35 Answers

That amp needs 4 gauge power and ground wire minimum. Too small of wire is just like using too small of a water main to a house....it's just not gonna work out

Posted on Jun 07, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have one 10in. Kicker L7. and a Kenwood KAC-929 1000 watt amp. What are all the wires i should buy that can make this setup run?


Need an amp kit up to 1000 watts, speaker wire. Amp kits have most of the wires needed such as, power, ground, and remote wire. As well as all the connectors needed.

Sep 22, 2010 | Kicker Solo-Baric L7 S15L72 Car Subwoofer

1 Answer

Kenwood KAC-729S keeps blowing fuses. Checked all cables, re-ran power, remote, and ground. All good, still blows them at power-up.


Hello opey_69a,

Here are the troubleshooting steps for fuses blowing.
1) Remove all wiring except ground, power and remote and see if the amp powers up without blowing the fuses. If it does, the problem is in the input cables or speaker wiring.
2) The use of loudspeaker impedances below the recommended minimums will cause the amp to draw excessive current - check.
3) A shorted or grounded RCA cable may cause the fuses to blow - check.
4) If an amplifier fuse blows continually, with only +12 volt, ground and remote leads connected, the amplifier is probably defective, most likely shorted output MOSFET's. In this case the amp needs professional repair or replacement.

Hope this helps.

Sep 19, 2009 | Kenwood KAC-729S Car Audio Amplifier

1 Answer

My Kenwood KAC-929 gets power but DOES NOT put any sound out. Whats My Possible problem(s).


Hello Spicer_kyle6,

Possible problems: 1) No output from the head unit. Try a different set of preamp outs. 2) No input to the amp. Check the RCA's and make sure that they are good and coming from a functioning preamp or subwoofer output on the head unit. 3) Input gain turned off or down too low. 4) Speaker wiring shorted, grounded, or open. Check all wires. 5) Speakers defective. Connect to a known good output to test. 6) The amp itself could be defective and still show a power-on indication.

Hope this helps.

Apr 28, 2009 | Kenwood KAC-929 Car Audio Amplifier

1 Answer

No sound from my woofer


Check your speaker connections... try using a multimeter set to "OHMS" and see if the speaker is reading around 4-8 ohms... if it shows no reading there is no continuity in the coil of the speaker

Mar 24, 2009 | Kenwood KAC-929 Car Audio Amplifier

2 Answers

Kac - 929 kenwood 1000 watt amp


Cold solder or lose connection in the amplfiier, or a poor connection with the wiring. The vibration of the movement of the car is causing the intermittants.

Jerry G.

Apr 19, 2008 | Kenwood KAC-9152D Car Audio Amplifier

3 Answers

Kenwood kac 9152D


Usually, protection mode is caused by one of these conditions:
  • Shorted speaker outputs.
  • Speaker output shorted to ground.
  • There is an internal issue, causing DC voltage to be present on the speaker outputs.
  • Amp overheats.
  • Ground connection is insufficient for amp or HU.
I'm not sure of the history or symptoms of your amp, but those are the reasons why the amp could go into protection mode.

Mar 13, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My kenwood amp


you need to check your wiring and check your rca wires to see if they are giving your amp a signal to put out

Mar 11, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Kenwood KAC-929


From the Input of amp, just connect cheap speaker with wires to input of amp.

If you have sound from speaker, most likely the amp is bad or loose connection.

Dec 25, 2007 | Kenwood KAC-929 Car Audio Amplifier

2 Answers

Kenwood kac-9152d


by jump do you mean all it does is thump and no sound besides thumping noise? if so put a better ground on your amp, double grounds work the best. please reply

Oct 06, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4862 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...