Question about Electrolux Centralux Vacuum

2 Answers

Centralux - unit will operate for 10-15 minutes then shut down. We hit the reset button, unit operates for 20 minutes then shut down again. Had customer svc stop by, they checked the hose, filter, no clogs, etc. ANy ideas

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 26 Answers

Check the screen. It's located underneath the motor. You can see if it's clogged by removing the filter and with a flashlight look up at the bottom of the motor. If it is clogged, the easiest way to clean it is unplug the vacuum, disconnect the two motor wires and remove the three nuts to get the motor out. Keep track of the washers (2 metal and 2 rubber on each post). Remove and clean screen. If you don't already have the new BLUE filters, get two new filters, because if there is stuff on the screen the filters aren't doing there job. I recommend you check the screen once a year from underneath the filter. Clean if necessary.

Posted on Jul 06, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 952 Answers

Hello,

Thanks for using FixYa.

The machine shuts down for safety measures. The machine is overheating, if it doesn't shut down, it may cause fire or the unit might totally break down. You need to have the unit opened up and have the motor checked. Overheating means that the motor is not running efficiently.

I hope this helps. Thanks and good day.
HotRatchet

Posted on Jun 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Hoover U6458-900 shuts off after a few minutes of vacuuming. I let it set a few minutes and it will start up again.


It sounds as if the motor has overheated at some point, and damaged the thermal protector fuse in the motor compartment. Clean the filters thoroughly, change the bag, and try to operate it. If it still shuts down, the thermal protector will need replacement. ( Part # 47534032 )

Mar 02, 2011 | Vacuums

1 Answer

After using the unit for a few minutes it cuts off.


The electric motor inside your Dyson has a built in over-current trip to protect itself (and you if it seriously overheated and caught fire). This normally automatically resets itself, however if the motor has just about had it, next time it is switched on it just trips again.

The primary cause of motors overheating is that the filters are not cleaned or replaced frequently enough. Dont be fooled by Dyson's "lifetime filters". They need to be regularly cleaned and replaced when necessary.

Replacement motors are available on eBay for about £25, however replacing one requires good DIY skills and tools.

Have a look at www.dysonmedic.com and see if you feel you can tackle it yourself. If not, take it to a repair shop or call the Dyson helpline.

Apr 17, 2010 | Dyson DC07 Bagless Upright Cyclonic Vacuum

2 Answers

Unit will not shut


give the reset on the main unit a tap with a small hammer relay is stuck

Apr 10, 2010 | Electrolux Centralux Vacuum

3 Answers

Bosch vacuum Motor turns off after a few minutes


It sounds like you have a motor protection fuse that resets after an overheat/cooling cycle.These work the same as a circuit breaker in your house with the difference being they can reset themselves.The Bosch will also shut down if there is insufficient airflow and I would check your filters first.1) Pull the filter and let the machine run.Do not pick up debris when you operate without a filter-it will be drawn straight into the motor.If it runs fine without shutting down, all you need to do is change your filter.If it shuts down again check the external hose for any blockages.Also check the throat from the powerhead for any blockages.If you continue to have the same problem then you will need to replace the fuse because at this point you have eliminated all the other likely problems.Good Luck-Scott

Oct 08, 2008 | Bosch BUC11700UC Cyclone Jet Bagless...

1 Answer

Electrolux Centralux Vacuum


If the light came on when you plugged it in, then you have power to the unit. You can take a coin and short across the two pins where the small, low voltage wires connect to the unit. Just remove the two wires, they should just pull off, and touch the two pins together with the coin. The unit should come on. If it doesn't, and the light is on, you may have a bad motor or a bad relay on the board inside the unit. Another thing to check is the filter. It has to be installed properly or the unit will not run. The top of the filter depresses a switch so that the unit cannot be operated without a filter in place. Good Luck!

Jul 20, 2008 | Electrolux Centralux Vacuum

2 Answers

Electrolux Centralux


http://geeksquad.fixya.com/ThreadView.aspx?prdid=113669&thid=657359
Electrolux Centralux
Posted by Brucebob on Jun 09, 2008
I have an Electrolux Centralux. When I plug the hose in at one of the wall outlets the motor will not start. If I go to the motor and slap the unit it will start.....then...it will not stop unless I unplug the power cord to the motor.
If I plug the power cord back in, the unit will not restart until I slap the motor unit again. The unit has only been used 20 - 30 times.
Any suggestions? Thanks, Bruce


Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. You may have a bad inlet or household outlet; try all the inlets in the house too. But it sounds to me that your carbon brushes are dirty and need cleaning or replacing would be my 1st suggestion. Take a good wire brushes or pipe cleaner to clean the inside of the carbon brushes if they stick then replace them. So if the unit has only been used 20 to 30 times I would suggest some one to come and look @ it who did the install because it is still under a factory warranty and if you start messing with things you will void the factory warranty on the motor. And then if it is the motor for some reason then the factory or vendor will eat the cost of the repair. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://electrolux.com/ Customer Service 1-800-896-9756
Electrolux Home Care Products – North America
P.O. Box 3900 Peoria, IL 61612
Thanks, Don the Vac Man
Go Ahead. Use Us.

Jun 09, 2008 | Electrolux Centralux Vacuum

Not finding what you are looking for?
Electrolux Centralux Vacuum Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...