Question about BOSS AUDIO SYSTEMS D1200M Car Amp

1 Answer

On a Boss D1200M mono-block amplifier what would be causing it to constantly switch between working and turning on the protection indicator?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 222 Answers

Check your positive supplies, are they properly installed? and your ground is is properly grounded?

Posted on Jun 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix my boss blade amp wen it stock in protection mode


You have to troubleshoot to find what caused it to enter protect mode. This can be caused by overdriving the output or failure of related components.

Aug 10, 2016 | Boss Car Audio & Video

1 Answer

How do i get my X1200M - Kenwood Excelon Monoblock 1200 Watt Class D Amplifier out of safe mode


protect mode is often due to faultiy speaker wiring, or too many spoeakers .tool little resistance- leading to amplifier overheat

Aug 30, 2014 | Kenwood Excelon X1200m 2400w Gouriki Class...

1 Answer

NAD M3 power light turns red immediately and PROTECT message displays. Amp keeps functioning but volume control doesn't work up or down.


Hello
Check the connection to speaker with this amp, for any short or any other fault. disconnect the outputs, ie, speakers from the amp, and switch it On, and see the protect display comes or not. If it comes, the fault is internal and the set need service.
Your M3 dual Mono integrated amp, is of high output power and its outputs are protected against any overload or short circuit. If the system detect any among this condition specified above, it will show protect mode display.
Never load this amp, as protection display is there, as it may damage the speaker or its internal power amplifier section circuits, may cause more money to get it repaired. OK.

Jan 23, 2012 | NAD M3 Master Series Integrated...

1 Answer

Bridging a f15d mono block from solid audio witch outputs do i use


Normally right positive and left neg. Your amp should have indicators on the terminals. Of the four you should have a separate + and - for each channel. This tells you which channel is for pos, and which is for neg. If no markings switch for each one left pos/right neg or right pos/left neg. It will only work on one way.

Sep 13, 2009 | Solid Audio F15D 1-Channel Amplifier Car...

1 Answer

800 watt pioneer mono block blue light comes on then goes off


sounds as if u have a short going on somewheres maybe a loose gound wiredo u have the gain set to hi.check all connetions..check sub connections a sub short will put your amp in protect mode

Sep 01, 2009 | Pioneer 800W Class-D Mono Amplifier With...

2 Answers

Protection light goes on on Power up


same thing happened to me a while back it is one of the reistors inside the amp, when you took the turn it anything bumped it or it fell it might have broken off, shake it and see if anything inside rattles, if so then you need to take it to a repair shop or some who can solder

Dec 14, 2008 | Earthquake Sound PH-D2 Car Audio Amplifier

1 Answer

The proper way of setting up a foot board to my amp and guitar


Run a jack from your guitar to Input R Mono on the pedal.
Run a jack from Output R Mono on the pedal to the input of your amplifier.
There is a switch for guitar or Bass. Put the swich on guitar
You do not need a preamp to use this pedal.
Hope this helps,
Maxx.

Aug 27, 2008 | Boss Music

2 Answers

500.1 amp power lights blinks on and off


Protection mode; follow this link to get a manual for the amplifier: http://mobile.jlaudio.com/products_amps.php?amp_id=439

Below information is from the manual:

Status Indicator Lights / Protection Circuitry
There are three status indicator lights on the top of the amplifier. These are as follows:1) "Power" (Green): lights to indicate that the amplifier is turned on and operating normally.
2) "Thermal" (Red): lights to indicate that the amplifier has exceeded its safe operating temperature, putting the amplifier into a self-protection mode, which reduces the power output of the amplifier. The red light will shut off and the amplifier will return to normal, full-power operating mode if the heat sink temperature drops back to a safe level.
3) "Low ω" (Amber): lights to indicate that the impedance of the speaker load connected to the amplifier is lower than the optimum impedance load range for the amplifier. When this light is on, a protection circuit engages and reduces the power output of the amplifier. The amber indicator will also light when a short-circuit is detected in the speaker wiring (this can be a short between the positive and negative speaker wires or between either speaker wire and the vehicle chassis).
There is only one condition that will shut down an undamaged 500/1v2 completely… If battery voltage drops below 10 volts, the entire amplifier will shut itself off. The green "Power" indicator on the top of the amplifier will turn off when this occurs. The amplifier will turn back on when voltage climbs back above 10 volts. This may happen in a rapid cycle when bass-heavy program material causes a weak charging system to dip below 10 volts momentarily. If this is happening in your system, have your charging system inspected to make sure it is working properly.
For information on troubleshooting this amplifier, refer to Appendix E (page 21).

Jun 25, 2008 | Jl Audio E1200 Car Audio Amplifier

1 Answer

I have problem with my mono amplifier


Amplifiers have thermal protection. They will typically shut down at ~180F. If your amp is shutting down after running it hard for 20-30 minutes, you may not have the correct load impedance (speakers wired incorrectly).

If it overheats as soon as it's switched on (no audio), the amp may be in need of repair.

Jun 21, 2008 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

QSC 2450 Power amplifier


i have a pyle pro 1000 watt max 2 channel mono and 2 channel stereo and when i get that thing loud the little red light cums on basically what i mean is that the amp on channel one is cooked i myself i wouldn't even use it y cause more damage

Apr 03, 2008 | QSC RMX-2450 Car Audio Amplifier

Not finding what you are looking for?
BOSS AUDIO SYSTEMS D1200M Car Amp Logo

Related Topics:

103 people viewed this question

Ask a Question

Usually answered in minutes!

Top BOSS AUDIO SYSTEMS Car Audio & Video Experts

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Jerry Umali

Level 3 Expert

979 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Are you a BOSS AUDIO SYSTEMS Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...