Question about Logitech X-530 Computer Speakers

Open Question

Different speakers working on different connectors

Hi, i have the X-530 speakers and they have been working fine. Recently I plugged them into my computer after they had been in storage for a while and only the front 2 speakers and they subwoofer are working when i plug the green connector in. The other speakers do work however, as when i plug in the orange connector the front centre and subwoofer work, and then when i plug in the black one the 2 back speakers and the subwoofer work. How can I get them to all play from one connector? Please help!! I haven't changed any of the settings! I love my music and I don't know how much longer i can take this!! Thank you

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 8 Answers

SOURCE: logitech X-530 speakers

go to start -> control panel -> sound and audio devices. in the volume tab, speaker settings area click advance. make sure the speaker setup is 5.1 .if not, select 5.1 and click ok. now cilck advance in device volume area. u should c a volume slider for rear and front speakers. if u dont c the volube slider, click options->properties.in the show the volume controls section put tick on the rear and front boxes. clik ok. and check weather they are not mute and increase the rear and fron volume to a decent lavel. there may be also sound card specifi settings that might need to be re-configured if this does not work let me know the name and model of ur sound card. Good Luck Julian Leonardo

Posted on Jun 16, 2007

Ad
  • 15 Answers

SOURCE: hooking up logitech surround sound to tv.

you need a "y" cable to bridge the output of the tv to the speakers.

Godd Luck

Posted on Jan 25, 2009

pogiboi
  • 85 Answers

SOURCE: Connecting an X-530 to Plasma?

if your area near to a electronics parts store .. bring the cable there . and they know how to convert it .. .. .. dont forget to bring a list of your unit model and serial code... where you from anyway?

Posted on Apr 05, 2009

  • 1 Answer

SOURCE: Center/subwoofer speaker out...mixed

Hi all, I also purchased a logitech x-540 a few days ago and also have the center speaker outputting sound when i test or play the subwoofer. I didn't think this is normal and am now confused. Maybe its a problem with the audio drivers? MB is a ASUS P6T Deluxe V2 with Soundmax drivers. Hopefully someone can help to diagnose/ find a soluytion.

Posted on Jan 25, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound from my yamaha rx-530 receiver


Try plugging in a set of headphones and selecting different inputs. If you have a short piece of wire, you could rig up an AM antenna and check if you're getting any sound from that input. There is a set of A & B speakers, so make sure you are cabled up to the set that is turned on. Also try different input sources, and make sure your not monitoring the tape loop....

Feb 13, 2015 | Yamaha Audio Players & Recorders

1 Answer

My logitech z-640 speakers arent working and i have no clue why first id like to know where to plug in the plugs in my laptop theres a geen,orange,black cord i have a microphone,headphone and some other...


The different connectors are for 5.1 surround audio, and are for different speakers with your system.
  • The green connector is for your front-right/front-left speakers
  • The black connector is for your rear-left and rear-right speakers
  • The orange plug is for your center speaker.
Most laptops do not have support for 5-speaker audio, so if you want to test each individually, you will need to plug them in one at a time and test playing sounds through them.
Hope this helps,

Dec 17, 2010 | Logitech Z-640 Computer Speakers

1 Answer

Trying to find out why my desk speakers buzz when my monitor is on?


If the computer and the powered speakers are connected to different power outlets then you could have an earth loop. This causes a hum in the speakers, this also apply to hi-fi sound systems.
To fix this problem, connect all the computer components to a power board and plug it into a power outlet.

Nov 26, 2009 | Logitech X-530 Computer Speakers

1 Answer

Computer can't find the damn speakers


I didn't find the x-530 but I did find the install guide for the x-540 which I assume is similar to yours. Most speakers (including yours) do NOT require software to work. If anything it's the sound card on your PC that requires drivers to work but if that is working fine then your speakers should plug and play and work w/o any software.


http://logitech-en-amr.custhelp.com/cgi-bin/logitech_en_amr.cfg/php/enduser/fattach_get.php?p_sid=5FDKVTAj&p_li=&p_accessibility=0&p_redirect=&p_tbl=9&p_id=5524&p_created=1160578991&p_olh=0


Copy and paste the entire contents above into your address bar to go to installation guide. If you have it connected correctly and it is receiving power then perhaps your Sound Card is not working correctly.

Jun 21, 2009 | Logitech X-530 Computer Speakers

1 Answer

Speakers not recognised in Vista


hi!!!!

try to check the audio driver
maybe it is not compatible with vista??
or download the latest driver for your audio

Nov 04, 2008 | Logitech X-530 Computer Speakers

1 Answer

No sound from Creative Labs Speakers- Please help


to localised your problem, try to plug your speakers to other sound source like mp3 player ,stereo system. if still no sound coming from it,your problem is within the speaker system. perhaps the audio power amplifier ic inside, need to be replaced.

Oct 12, 2008 | Logitech X-530 Computer Speakers

1 Answer

Speakers won't turn on


Have you checked the fuse in your plug. If the fuse has blown it won't work in any wall socket. Change the fuse for a new one anyway, then try again.

Sep 21, 2008 | Logitech X-530 Computer Speakers

1 Answer

Logitech x-530 speakers connected to Highlander DVD recorder


YOu need to install the right drivers, for your sound and video card, latest. and Direct X9c.

Jan 13, 2008 | Logitech X-530 Computer Speakers

Not finding what you are looking for?
Logitech X-530 Computer Speakers Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

JP Services
JP Services

Level 2 Expert

310 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...