Question about Boss REV-3000D Car Audio Amplifier

1 Answer

Not working proper

Not giving output

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 94 Answers

Internal issue have seen it with all of this brand amp, was not able to repair, sent in to the manufacture and they sent it back, still had same problem, recommend a different brand, kicker, rockford fosgate, pioneer, alpine, kenwood, audio bahn, I've installed some dual amps and they seem to work quite nicely

Posted on Jun 07, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Printer has no power. Power light does not work


Add some details.. Make sure your AC adapter is working fine.. Normally it has a LED which shows it's giving output...... If that is working you have Dead Printer Motherboard issue.. Which can be fixed if you have proper gadgets.

Mar 26, 2013 | Office Equipment & Supplies

1 Answer

Heater makes the three attempts with 30 sec. intervals. Ignites for 10 seconds on each attempt, but will not kick in and run after the initial ignition.


Firstly make sure that the igniter is properly earthed. The ignitor itself detects the flame and if not properly earthed will not give the proper signal to the control unit. Next the burners need to be checked. They need to be properly cleaned of carbon deposits and oxidisation. If this does not cure the problem then do the following
Turn the gas output up to 2.5" wc(water column) Here's how :
To do this remove the slotted brass cap on the right of the gas valve. Adjust the output valve underneath one turn clockwise. Dont go more than this unless you're familiar with working with gas or have a manometer handy to measure output.

Aug 21, 2010 | Hayward 100,000 BTU Pool Heater H100ID1 -...

1 Answer

Computer won't turn on says no signal but router and modem are working


1. check for proper power connection.
2. if it is ok, then check that your smps is giving proper output- it cannot be checked by yourself. go to near by hardware repair center.

Feb 27, 2010 | E-Machines eMachines Desktop PC

2 Answers

At a time only two speaker works out of 4


1. Open Control Panel > Sounds and Audio Devices. 2. Click 'Advanced' Button near the bottom. 9d7466a.jpg
3. Select proper sound system (Quadrophonic or surround sound) according to your speaker system.fc6ac4d.jpg 4. Click 'OK'. 5. Also check volume. 6. Double-click Volume icon in taskbar. 7. Click Options > Properties (From menu) and select 'Playback'. 8. Select all Audio components. 9. Click 'OK' 10. Increase all the volumes.
Now try playing a sound. Good Luck!

Jul 30, 2009 | Computers & Internet

1 Answer

Labtec speakers want play


check whether the output plug is connected properly or not.... if it is then check out whether the adapter is giving the power output.... if it is then the speakers are spoilt otherwise u can just replace the adapter...

Feb 07, 2009 | Labtec Spin 70 Computer Speakers

1 Answer

Sound card


check whether u installed sound driver....

Sep 24, 2008 | Intel Computers & Internet

1 Answer

Velodyne subwoofer


First make sure that the cables are properly connected up. Make sure that the output of the amplifier feeding the sub is working properly and has no faults.

If the above is okay, it is possible that the power supply in the sub, and or the output stage has a failure. In this case the sub will require shop service to have it working again.

Jerry G.

Jun 12, 2008 | Velodyne DPS-12 Subwoofer

1 Answer

Proper connection from amp to pre amp.


Hi Jimmy

The output of the preamp connects to the input of the power-amp, left and right channels respectively. Some preamps (like NAD) can have more than one set of outputs, is this what you are dealing with? If you can give me the make and models of the gear then I can help you more... :)

regards
Graeme

Feb 13, 2008 | Audio Players & Recorders

2 Answers

Sorround Back Speakers not giving proper output


for surround put zone 2 on. if zone 2 is not on the speakers which you hooked in the surround back left and right wont work

Dec 24, 2007 | Denon AVR-1507 Receiver

Not finding what you are looking for?
Boss REV-3000D Car Audio Amplifier Logo

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Boss Car Audio & Video Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

xxxxxx xxx

Level 3 Expert

4875 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Boss Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...