Question about Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED 2 HP 115/230V

1 Answer

My Jacuzzi magnum 1000 is not filling with water, there is an air leak somewhere and I cannot seem to find it. I have replaced the O-ring on the top of the machine, as well as the 2 plugs on the bottom left side. What can I do to fix this problem?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The coupling between the pump and motor may not be tight and therefore may be sucking air and not allowing the strainer basket to fill with water.

Posted on Jun 15, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Leaky Motor


This sounds like it could be the shaft seals, which is a cheap fix.
The Jacuzzi Magnum calls for seal 35-423-1021
You might consider replacing the seal plate O-Ring as well. - 35-105-1120

Aug 06, 2012 | Jacuzzi Pool & Spa

1 Answer

Jacuzzi pool pump leaking


Where is it leaking? if it is still leaking between the wet end which is the black plastic water housing and the motor then the seal is not properly set.

Rod
US Parts Center

Aug 04, 2012 | Jacuzzi Magnum Force Series Pool Pump 1...

1 Answer

Pump is leaking from the cap


If the water is leaking from the trap lid then the o-ring is not properly set or the lid is cracked.
Try using some silicone based lube on the o-ring and then reset the lid making sure the o-ring is properly resting on the outer lip of the pump pot.

Rod
US Parts Center

Jul 30, 2012 | Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED...

1 Answer

I have an above ground pool with a jacuzzi pump. (1.5 hp). I just replaced the sand in the sand filter. I also put on a new o-ring on the jacuzzi pump cover. When I turn on the filter, the pump fills up...


I think you have a air leak. A 1.5 hp motor is very strong and should vacuum well. Be careful to not over tighten the top of your pump housing.

Is your impeller in good shape? It may be worth your while to remove the pump motor from the pump. While you have it apart, replace all the seals (there is a kit for this). Inspect the impeller and all parts of the housing - any junk inside? Remove it. After you complete the rebuild, reinstall the motor, fill the pump housing with water, secure the top and start the pump.

Let me know what happens ...

thanks for your interest in FixYa.com

Jul 03, 2011 | Jacuzzi Pool & Spa

1 Answer

Installed new impeller, seal, o ring and square o ring in Jacuzzi Magnum 2 hp. After putting it all back together it leaks alot from around the housing. The o ring is new, and I have tightened as tight as...


the o ring usually would not fit if it were the wrong size. What seals is a ceramic seal, did you change that? If run without water, the ceramic seal will be damaged....

Nov 15, 2010 | Jacuzzi MAGNUM FORCE POOL PUMP 2 HP...

1 Answer

I see air bubbles in the motor window


Make sure you water level is adequate so as not to draw air through the skimmers. Also, the o-ring on the pump strainer might be bad or debris on it. While the pump is running, shut it off and see if water squirts out of the pump lid or fittings right when it shuts off.

Jun 18, 2010 | Jacuzzi MAGNUM FORCE POOL PUMP 2 HP...

1 Answer

Hi I have a magnum 1000 Jacuzzi pump for my


alot of companies use to have a damper ring on pump shaft which would knock down some of the noise a pump motor made pumps make noise and the bigger the pump the louder the noise if its not vibrating or clunking then its running as it should

Apr 21, 2010 | Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED...

1 Answer

I have a jacuzzi magnum 1.5 HP pump. It turns on, moves some water well towards getting primed, then cuts off. Pump gets quite hot to the touch. Circuit breakers do not trip however. Had the capacitor...


Your motor is going bad if it get's that hot. It is kicking off when it get's hot enough to the heat switch in the back of the motor. This resets it self and the motor probally comes on again after a few minutes. The wireing in the motor has a small short that will get worse soon enough and may even catch fire if the conditions are right. So you should get a new one and replace your seal kit and "O" rings at the same time. Odds are a small water leak got this started. Good luck

Nov 29, 2009 | Jacuzzi MAGNUM POOL PUMP 1-1/2 HP MAGNUM...

1 Answer

I have a Jacuzzi Magnum force pump


Good luck...Jacuzzi went out of business. The best source I have had for their parts is CCO:

http://www.jbparts.com/jbc0001.html

Jun 01, 2009 | Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED...

Not finding what you are looking for?
Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED 2 HP 115/230V Logo

Related Topics:

325 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jacuzzi Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Mike

Level 3 Expert

4336 Answers

john h

Level 3 Expert

11133 Answers

Are you a Jacuzzi Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...