Question about MTX Thunder 81000D Car Audio Amplifier

1 Answer

MTX 81000D amp doesnt work

I have my amplifier hooked up and the light turns on and it should be working, but when the volumes up, i cant see the subs moving, i feel it and there is a slight vibration, hardley noticable, but no immediate power. i dont know whats wrong with it.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Contributor
  • 84 Answers

Have you checked to make sure your sub is wired correctly to the amplifier?

Posted on May 31, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

MTX Thunder series 7402 Amp cutting out at Hard pound.


Most likely the ohm load is too low, if you have the subs wired in parallel rewire them in series and see if that resolves the problem. if not then you do not have enough battery power to support the draw that the amplifier pulls. if the vehicles voltage drops below 11.5 volts the amplifier will momentarily shut off, similar to how the lights in your house dim when the a/c cuts on due to the sudden power draw. hope this helps. p.s. if you cant afford another battery right away, lowering the crossover frequency to around 65hz will greatly reduce the amount of current necessary to keep the amp pumping. (in my opinion it sound better that way anyhow.)

Apr 28, 2010 | MTX Thunder 81000D Car Audio Amplifier

1 Answer

MTX Thunder 81001 wont push subs


first of all you should check the minimal impedance your amp handles , if is class d it should handle between 1-2 ohms total impedance in a mono conection , meaning whatever quantity of subs you have hooked to your amplifier,their total impedance should the minimum the amp handles that way all the power from your amplifier will be used.

Jan 23, 2010 | MTX Thunder 81000D Car Audio Amplifier

1 Answer

Sub not working and red light on amp stays on?


the amp is under to much pressure get a bigger 1

Nov 18, 2009 | MTX Thunder 421D Car Audio Amplifier

2 Answers

I have a mtx thunder 81000d amp i need to know if i can bridge it


Hello frank_sadach,

"Bridging" connects 2 amp channels to one output. The MTX 81000d is a single channel amp so it cannot be bridged.

Hope this helps.

Oct 23, 2009 | Car Audio & Video

1 Answer

Hi, I have a MTX Thunder 81000D and there's something burned, it is the component with next to it the number d198, does anyone knows which one it is? THANX


D198 is a diode. It burns when the amp loses the chassis ground connection and the amp tries to ground through the RCA shield. If the amp is still working, it's better to leave that diode out of the circuit. That's what MTX did on later models.

Jun 04, 2009 | MTX Thunder 81000D Car Audio Amplifier

1 Answer

Not working


disconnect the subs from the amp and check to see if the amp will turn on and stay on-check the subs to see if they are blown with a different source try a pair or a single sub that you know works fine on the amp and see if it plays-this should tell you whether your amp is fried or your subs are roasted

May 19, 2009 | MTX 4002 Car Audio Amplifier

2 Answers

Mtx 1501d no sound


There are a number of things that can cause it to act as you described. Have you pulled the covers off of it yet to see if you can see any problems?

If you do, disconnect power from it and don't touch ANYTHING on the board when ANY of the 3 LEDs (2 are not visible from the outside) are lit.

Aug 19, 2008 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

Carlos


i have a 81000d for sale for 250 dollars car money still in perfect condition i am pushing 3 12 inch alpine type r subs

Apr 25, 2008 | MTX Thunder 81000D Car Audio Amplifier

1 Answer

Car audio


hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

Not finding what you are looking for?
MTX Thunder 81000D Car Audio Amplifier Logo

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...