Question about Miele Red Star Bagged Canister Vacuum

1 Answer

Miele Red Star powerbrush makes loud noise

I have a Miele Red Star (Model: S314i). Today, when I turned on the powerbrush (Model: SEB213), it started to make a very loud screeching noise. The brush roller still spins and there is nothing blocking it. I have checked the connections and the canister seems to be working fine.

Please help! Thank you.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,566 Answers

There could be two reasons:

1. This is most likely that the belt was already stretched out to the fullest. How old is your vacuum cleaner? You can have that belt replaced as they come in cheap prices.

2. The motor's bearings with permanent lubrication finally failed due to over time. The motor might be spinning but no longer being supported all the way. This is most likely the case if you can smell something like burning plastic. In this case, you need to take a look inside.

Posted on May 30, 2010

  • loxygurl May 31, 2010

    Thanks for your response. I didn't notice a burning plastic smell, so if it's the belt that needs to be replaced, should I try this on my own or bring it to a technician? I've had this vacuum for 3 years.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Our miele red star(s314i) vacuum was running great and quit suddenly. It had not been running for a very long time and just quit. Newish bag, no clogs in hose and doesn't seem overly hot. the over heated...


Ok, so if the cord test didn't fix the problem, then it sounds like either the plug has gone bad, or the switch. The plug is a very common problem to go bad, and can be caused by just simply yanking the plug out of the wall, or putting too much tension on the cord while you're vacuuming. Here's a link showing how to replace a plug on your Miele. You may purchase a plug at a Home Depot for very cheap. If this doesn't fix your problem, then it is either going to be the entire cord reel assembly that's gone bad, or the switch. The plug is the easiest, cheapest next best option, so hopefully this is your problem. Here's a link on how to change the plug out;
http://electrical.about.com/od/diyprojectsmadeeasy/ss/replacecordplug.htm

Please just use the comment field again if this doesn't fix it, and I'll walk you through step by step the more detailed process of replacing the cord reel.

Jan 17, 2011 | Miele Red Star Bagged Canister Vacuum

1 Answer

Miele Red Star, small spark at outlet, no power to vacuum


The vacuum has a standard tube internal fuse. If you are lucky that is all it is. See the site http://www.sannerud.com/house/miele.html for instructions on how to open it up.

hope that helps

Jun 05, 2010 | Miele Red Star Bagged Canister Vacuum

2 Answers

Meile red star


Hi,

Yes, this very well could be a problem with the cord reel, especially if it happened all of a sudden. There's a few ways that you can diagnosis this problem yourself. First make sure the cord is all the way reeled into the vacuum. Next find an outlet that's close, and only pull out enough cord as you have to, to be able to reach the wall outlet. After you've plugged the machine into the wall, use one hand to slowly pull more cord out of the vacuum, and use the other hand to continuously turn on and off the vacuum pushing the foot pedal that controls the main switch. Slowly pull the cord out, and turn the vacuum on and off, on and off, on and off.

At any point while you were doing this did the vacuum come on, even for a very short time? Did it even make a noise like it was trying to start? If you heard a noise, or the vacuum even came on for a time, then this definitely indicates that you have a bad cord reel.

If it didn't make a noise or come on, you still may have a cord reel problem, but you'll need to take the machine apart to further diagnosis it at this point. A simple continuity electrical tester will be needed to test the cord reel.

Here's a very detailed repair instruction that I left for a similar model Miele on Fixya already. The model that you posted the repair under is a Miele Red Star which is an S314i, the model I repaired the cord on was actually a S514. The cord repair on both of these models is identical however, except your Red Star actually has two screws that need to be removed from the variable speed control box, the S514 only has one. Otherwise, it's almost completely the same repair. If you need to purchase a cord reel for your Miele, here's a direct link to the Miele S300 series cord reel that goes with your Red Star:
http://www.govacuum.com/miele-cord-reel-s300-series-06777540.html

Even better, if you purchase the cord reel from GoVacuum, you have 60 days after the purchase that you may return the cord reel to us if that wasn't the problem (we do test all the returns to make sure that they weren't damaged when being installed), and as long as the cord reel is returned undamaged, we give you a full refund, we don't believe in restocking or shipping fees. Better yet, we even include a return label with every order that you may use for free to avoid return shipping charges.

If you find that the cord reel is not the problem, that can only leave one of three things; the switch, the motor, or the pc control board that's on your motor. In 10 years of fixing Miele vacuums however, I can safely bet that it's your cord reel.

Anyways, here's the link to step by step instructions on how you can remove the cord to test it, as well as replacing it. If you have any questions, please feel free to use the Clarification or comment form here on Fixya, or contact us by phone. If this was helpful to you, please be so kind and rate my repair as helpful by clicking the thumbs up icons at the top of the page. Thanks so much!

How to Test & Change a Miele Cord Reel:
http://www.fixya.com/support/t2281026-miele_s514_will_not_come

Chris J.
GoVacuum

Apr 06, 2010 | Miele Red Star Bagged Canister Vacuum

1 Answer

Need drawing to reassemble power head


Hello,

I have attached the parts drawing of the power nozzle that came with the Red Velvet model, or the SEB236. Unfortunately the way that it's posted online, it's done in a way that makes saving the picture and posting the picture here in the repair more difficult because the pictures are larger then the 150k that Fixya allows. I went ahead and uploaded this pictures to our site, and left the 2 links below in this repair.

Powerbrush Picture:
http://lib.store.yahoo.net/lib/vacuumcleanerbacgs/miele-red-velvet-power-nozzle-seb236-1.gif

Inner Casing & Light System Picture:
http://lib.store.yahoo.net/lib/vacuumcleanerbacgs/miele-red-velvet-power-nozzle-seb236-2.gif

If you need help on getting it back together, please feel free to use the Clarification Request form here on the Fixya repair page with the part that you're having problems with, and I'll be more then happy to help you.

If this information helped you, please be so kind as to rate my solution as helpful by clicking the 4 Thumbs up icons in the top corner, this is what keeps Fixya repair experts coming back and giving free repair advice.

Thank you very much,

Chris J.
GoVacuum

Apr 04, 2010 | Miele S558 Red Velvet Bagged Canister...

1 Answer

Miele Red Star Powerhead overheats and turns off


be sure at 1st there is no materials blocking the hose then it seems to me your m/c is good if normall condition around
try to test your cleaner by use less length hoses
thanks

Jul 04, 2009 | Miele Red Star Bagged Canister Vacuum

2 Answers

Miele SEB-213 powerbrush stopped working


Pull the head cover off to check the belt, if the belt is ok then it might be the power connection between the handle and the power head shaft. If the red light is on the power head, then its not the connection
because its getting power. Now some heads have a reset button on them,you could check this also.
With the cover off the power head, remove the belt, now turn it on, and be careful, but try to make the motor shaft spin,with one finger, because if it does start to spin you do not want to hurt your finger.

If the motor starts to spin,put the belt back on, if it does not spin again, the motor is too weak.
If it does not spin at all, the motor is bad.Hope this helps you,and you get it working.

Mar 24, 2009 | Miele SEB 213-2 Vacuum

1 Answer

I have a Miele Red Star vacuum, model 314i. I bought a HEPA filter for it but am not sure how to install it.


Hi,

At GoVacuum we put together a General Miele Maintenance video together for Miele Owners. Although the video showcased in the video is not specifically your Red Star machine, the filter installation is going to be the same.

Check it out here:


Sep 03, 2008 | Miele Vacuums

1 Answer

Miele Solaris height adjuster arm won't snap back in


Maybe this picture will help, put the pieces together, then it sits directly under where #230 in the pic.

2da4be9.gif

Mar 25, 2008 | Miele S514 Solaris Turbo Plus Vacuum

1 Answer

New Miele Red Star - Powerbrush not working


Wish you had listed the model number of the vac and of the powerhead. The plug going into the cannister, is it pushed all of the way in, also same for the plug going into the hose end? You can hook up the powerhead plug to a/c and see if it runs, if it does, then it is ok. Unhook the hose and plug and hook up a/c to that plug end and see if the powerhead will run, if not maybe the switch on the hose handle has a problem. Otherwise you have a problem in the cannister. If this is brand new, then it has a warranty, take in for repair.

Feb 21, 2008 | Miele Red Star Bagged Canister Vacuum

Not finding what you are looking for?
Miele Red Star Bagged Canister Vacuum Logo

Related Topics:

249 people viewed this question

Ask a Question

Usually answered in minutes!

Top Miele Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

Mack Baxter

Level 3 Expert

381 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Miele Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...