Question about Mastercool 67680 Evaporative Cooler Air Conditioner

1 Answer

High speed does not work but low speed does. Is there an easy fix, or will this require a motor replacement to get both speeds working again? The cooler is a Mastercool model MC64C

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 587 Answers

If your motor only works on low speed and not on high speed first check to see if you have the proper voltage to high speed. Check with a voltmeter or multimeter, check from common on the motor to high speed on the motor at the switch. If you have the proper voltage then you have an open winding on high speed and the motor needs replaced. If you don’t have the proper voltage or any volts, then the switch is bad and needs replaced. This also will be the same if, medium speed won’t work and low speed does.

Posted on May 30, 2010

Testimonial: "great answer - I'll check it today"

  • 3 more comments 
  • Monica Gutierrez
    Monica Gutierrez Apr 20, 2014

    where is the switch?

  • Bill Long Apr 20, 2014

    The motor wires go to the switch or a control board with a switch on it. Check the voltage at the motor wires where high and low speed wires are connected to a switch or board. How ever you are switching from high to low speed. set to low speed check voltage then set to high and check voltage both at the motor wire terminals.

  • Monica Gutierrez
    Monica Gutierrez Apr 20, 2014

    ok i have a multimeter, what should the voltage be?

  • Monica Gutierrez
    Monica Gutierrez Apr 20, 2014

    what should the voltage meter be set at? by the way thanks for all your help.

  • Bill Long Apr 21, 2014

    AC volts, it should auto-scale without having to pick a voltage range. A lot of times the scale will show VOLTS with an S on its side ( horizontal).

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Four winds. My pool pump will not start on the low side when I push the button. It will work on the high side. Also it will pump on the low side automatically after I have run it on the high side. ...


The motor starting switch is probably failing on the low speed side so as long as motor is running on high after starting on high it will continue to run if switched to low. You can try to replace the switch or take the motor to a local electric motor repair shop for them to quote the fix.

Sep 15, 2013 | Pool & Spa

1 Answer

Fan speed will only work on high,is the switch the problem


The switch is held on by 2 clip, on on the "high" side, one on the "low" side. If the low side came disconnected, it would only contact at "high". Fairly easy fix (tape or glue). Doubtful that the switch needs to be replaced. It is more likely the variable resistor, or rheostat, which allows less than full voltage to the fan motor. This would allow only full or no voltage to the motor with no "in-between".

Dec 20, 2010 | 1995 Geo Tracker

1 Answer

Kenmore over the stove microwave,model # 721.62629200,only low speed fan works on the keypad,no high speed fan.


The fan has a setting for high speed, low, and off. Fan only running at low speed.This indicates problem towards. 1) the fan motor. 2) The loose fan wiring. 3) The fan switch. IN the unit there is a motor for fan.If the motor gets weak or short. The fan will run but only at low speed.Because at high speed the motor will require more power to run.In this case motor needs to be checked and replaced. The other possibility is the fan wiring.There are two wires going from fan to motor and two going from motor to power board.If any of this wire is got loose or getting short then this will stop the fan to run in high speed.In this case the wires needs to be checked and reconnected properly. In the unit there is a switch internally.When you select the fan to high speed mode the switch goes up. when you select the fan to low speed mode the switch turns down.But if the switch is faulty or got worn out.Then it will not move properly up/down.In this case switch needs to be replaced.IN some brand models the High speed and low speed are directly controlled from front control panel.There is no switch in that models.In that case the control panel needs to be checked and replaced. Thanks. keep updated for any more query.you can rate this solution and show your appreciation.

Jun 10, 2010 | Kitchen Ranges

1 Answer

High speed setting of fan does not work


If your motor only works on low speed and not on high speed first check to see if you have the proper voltage to high speed. Check with a voltmeter or multimeter, check from common on the motor to high speed on the motor at the switch. If you have the proper voltage then you have an open winding on high speed and the motor needs replaced. If you don’t have the proper voltage or any volts, then the switch is bad and needs replaced. This also will be the same if, medium speed won’t work and low speed does.

May 29, 2010 | Kenmore 72115 Air Conditioner

1 Answer

Cool fan low doesn't work. Doesn't appear to be


It needs to have the blower motor resistor card replaced.
It still works on high speed because on the high setting the voltage does not go through the resistor.
The resistor is mounted beside the blower motor and is easy to replace.
There you are, thank you for using FixYa.

KL

May 01, 2010 | 2003 Saturn VUE

2 Answers

Low does not work, medium and high do


You probably cant fix it, this sounds like a multispeed blower with hi/medium/lo settings. You
can either replace the motor or connect one of the
working speeds to low/med or low/hi. or bump med to low and high to medium.

Jan 12, 2010 | Desa International Blower Glow Warm Wall...

1 Answer

My fan for a/c and heat only works on high


that sounds like the blower motor resistor. on high it bypasses the resistor for maximum speed. but on low or medium speeds, the resistor slows down the blower motor. when the resistor goes out, the blower motor will only work on high. it is an inexpensive part and easy to replace. it should be located on the black box under the dash on the passenger side. there might be a plastic cover over it, but it will have a 3 or 4 wire connector plugged into it

Oct 20, 2009 | 2006 Jeep Liberty

1 Answer

I have a challenger 2 speed spa pump. Only the low speed seems to work. I have back-tracked all switching. The correct voltage is getting to the correct motor terminals for low and high speed operation. I...


You are correct. Appaently you have a short in the winding connection and that is not a do-it-yourslef type of repair. Unfortunately, the cost to fix something like that is high since it is labor intensive and you may want to look into a new motor since the chances of additional or near future failures is likely. If you would like a quote on a new motor, contact us thru www.arrowmotor.net and be sure to include the voltage you are connecting to as a 1.5 HP is available in both 115 and 230VAC.

Sep 25, 2009 | AO Smith 1.5hp Pool Pump Motor 2 Speed Ao...

1 Answer

I have a 2 speed spa motor (K48m2a4) that stopped working at low speed. going to high speed only has circulating power.


Either the low speed circuit is defective or a relay is inoperative. If you feel confident , you could switch the low and high speed leads on terminal plate. The high speed jet button would activate low speed on pump if motor is good.

Aug 01, 2009 | Pool & Spa

Not finding what you are looking for?
Mastercool 67680 Evaporative Cooler Air Conditioner Logo

Related Topics:

1,709 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mastercool Heating & Cooling Experts

Bill Long

Level 3 Expert

587 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Mastercool Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...