Question about Fender Hot Rod Deluxe Guitar Combo Amplifier

1 Answer

Like johbow I also have a frnder hotrod deluxe amp with a non functioning reverb.was wondering if tl082 would be a workable replacement for the tl072.reason I ask this is Radio Shack stocks them and they are a couple of bucks.Fredy2 problem with fender HRD just became a little less rare.THanks in advance for any help.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Fender Master
  • 5,603 Answers

The TL072 is shown having a must better distortion figure than the TL082.

DigiKey.com has them 50 cents. I would NOT substutute the 82 for the 72 in this case.

http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail&name=497-2201-5-ND

Posted on May 28, 2010

Testimonial: "fredy bless you sir,i have been searching for substitutes online w/out much luck.I respect your opinion and will just order the tl072.Guess I was just looking for a fast fix.Thank you for sharing your time,expertise and speedie response."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a '93 Fender Blues deluxe tweed and don't seem to have any reverb, am I missing something?


Check the connection to the reverb tank (rectangular box usually sitting on the bottom of the amp). There are a pair wires that connect it to the amp. If wires are connected, and the reverb is not working, you may need to replace the reverb tank.

Oct 16, 2016 | Fender Music

1 Answer

Sometimes the reverb works, then next day it dont.i have a 1999fender hot rod deluxe


Fender Amplifiers are notorious for their reliability issues.However, I'm sure that amp will sound sweet once you get everything working again!

The problem is likely your "tank". The tank contains the springs which create reverb as the guitar's signal is sent through them. A broken spring could be causing your problem.

Luckily, any of the larger music stores should have them avalible.

Good Luck!

-Sheeves

Mar 02, 2011 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

I just bought a Deluxe VM .... when I plug it in, the red delay light is on....and everything has delay on it. When I press the little white button on the amp in or out, the red light on the amp still...


i guess the switch is broken - if you are not experienced fixing those problems better bring it to a shop and tell them about the problem - i guess they will be able to fix it easily

Feb 25, 2011 | Fender Deluxe VM Tube Amplifier

2 Answers

My reverb on my Fender deluxe Hot rod amp has stopped working. What is wrong?


Your reverb spring is most likely broken. If it has electronic reverb, then the chip has gone out. For both of these problems, a qualified amplifier technician will have to look at it and replace the parts.


Hope that helps!

Feb 13, 2011 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

My Fender Hot Rod Deville reverb is not working. What should I look for in trying to fix this problem


There are two coils in the reverb unit which use delicate wires which can break off - these can easily be checked, as follows:-

i) Remove one cable plug from the reverb unit & substitute an uncapped phono plug to the socket.Then check that there is electrical resistance across the plug terminals.

ii) Reconnect original phono plug & do same test as i) to the other socket.

iii) If either is open-circuited, then look for a break in the lead-out wires from the corresponding coil inside the reverb unit.
This break may be repaired (contact me for details) or buy a new reverb unit!

iv) If there is electrical resistance at both sockets of reverb unit, then clean both original phono plugs & try the system again.

Sep 15, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

How do i connect the boss gt 10 to a fender blues deluxe amp and bypass the amps preamp


You can plug the output of the gt10 into the "power amp in" jack of the Fender. This bypasses the preamps in the Fender but uses a buffer amps in the Fender to drive the power amp. Please note that the reverb is STILL in the circuit when you do this. You can turn the reverb to zero if you wish to disable it.

Jun 09, 2010 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

Amp is little used and now the reverb is not working. It is never moved from the room where I play.


There are only TWO op-amps and the tank involved with the reverb. Both of those are in one IC chip labeled "U2". It is a TL072.

Pin 1 of that chip is the output to the tank and pin 7 is the inout of the reverb control pot that then goes into the power amp.

They resistively mix the delayed reverb signal with the straight signal at the input of the power amp.

I assume you have turned up the reverb control which is just a volume control for the signal going through the tank.

There are so few parts involved with this that a failure is really rare.

May 13, 2010 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

Fix Reverb unit on Fender Hot-Rod Deluxe Amp


Could have broken a spring in the reverb tank, or a wire connecting it to the amp, or the reverb driver tube, or a few other things, but those are the most likely in this situation. Thats what I'd check first. Give it a little slap and if it vibrates like normal, your spring is probably ok, you can still open it up and double check though. Check your wires. Then pull your reverb driver tube and replace it. If that doesn't work, it is probably in the circuit somewhere, and you should not work on your amp unless you know what you are doing. They store large amounts of electicity in the caps and they can kill you.

Apr 24, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

HRD Issues...


Try this article first for some ideas. http://www.guitarplayer.com/article/reverb-troubleshooting/jun-09/97165.

Aug 02, 2009 | Fender Hot Rod Deluxe Guitar Combo...

Not finding what you are looking for?
Fender Hot Rod Deluxe Guitar Combo Amplifier  Logo

Related Topics:

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fender Music Experts

Michial Gueffroy

Level 3 Expert

1138 Answers

dave nyman

Level 1 Expert

17 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Fender Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...