Question about Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum

2 Answers

NOT DISPENSING THE RED THING ON TOP IS NOT GOING ROUND AND ROUND. NOT DISPENSING WATER AND SOLUTION.

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Does water squirt out of the hose nozzle, if it does, then check the heater inside the handle asm. Make sure that where the tubes hook up to it are not clogged. If water doesn't squirt, check for the seal at the bottom of the tank, it needs to be on the tank, not in the hole. The flow indictor cap is leaking air or maybe is too tight. If you had the top cover off, make sure that the tubes are routed right so as not to get pinched when the cover is put back on, the smart mix knob should be in the water setting and that the piston is on the bottom of the smart mix knob. Pump is bad. Try running a mix of vinegar and water to see if that unclogs the lines.

Posted on Apr 28, 2008

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 25 Answers

I had exactly the same problem with my five-year old my Bissell 7920, and it's probably a broken pump belt.  See page 19 of your instruction manual for how to replace.  The Bissel ProHeat belt accessory pack costs $3.99 and you get a pump belt and a brush belt.  Since you have to first remove the brush belt to get to the pump belt, you might as well replace both. The first time I did this it took me 15 minutes, but now that I know the drill, doing a belt replacement would take about 3 minutes.

Posted on Apr 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

DC18 won't stan up


here is dc18 foot repair video

Nov 22, 2012 | Dyson DC14 All Floors Upright Vacuum...

1 Answer

Water not dispensing


Check the release valve on bottom of clean water reservoir unscrew if needed, once again if your not sure run hot water in the solution tank through the system to help remove old soap residue and always run hot water through to prevent future problems after cleaning carpet and storing.steve

Jun 06, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

2 Answers

Machine will not dispense water even though reservoir is full. Soap is not dispensing either.


check the spray nozzles on top of the brushroll. these often clog. If those are clear could most likely be the pump as they fail frequently.

Jan 29, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

No Suction


It sounds like the lint filter is clogged. It is located on the top clear plastic piece (the one with the dial to switch from floor to tool use) and is on the underside. It is a small (1 inch square) red plastic piece with a little door on it. Flip open the door and it is probably clogged with hair, carpet fibre, etc.. Clean it out and hopefully you will have suction again.

Apr 21, 2009 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Bissell Proheat wont spray soap with uniformity


Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101
jhkl

Sep 10, 2008 | Bissell 7901-1 ProHeat Scotchgard Upright...

2 Answers

NOT DISPENSING


Does water squirt out of the hose nozzle, if it does, then check the heater inside the handle asm. Make sure that where the tubes hook up to it are not clogged. If water doesn't squirt, check for the seal at the bottom of the tank, it needs to be on the tank, not in the hole. The flow indictor cap is leaking air or maybe is too tight. If you had the top cover off, make sure that the tubes are routed right so as not to get pinched when the cover is put back on, the smart mix knob should be in the water setting and that the piston is on the bottom of the smart mix knob. Pump is bad. Try running a mix of vinegar and water to see if that unclogs the lines.

Apr 28, 2008 | Bissell 1699 ProHeat Clear View Upright...

1 Answer

Flow Indicator Not Moving, Not Dispensing Anything


Does water squiret out of the hose, if it does, then check the heater inside the handle to see if it is clogged where the 2 water lines hook to it. The other reason, you may ghave a bad pump. But check the back edge to make sure the top isn't coming loose from the base. Check the bottom of the tank to be sure round seal is on the tank on the cap and valve. Sometimes they come off and wind up in the hole.

Mar 15, 2008 | Bissell 1699 ProHeat Clear View Upright...

3 Answers

Not dispensing water and no suction


I'm assuming the belts are OK.... Your heater is clogged. Unplug the machine and let it sit for 30 minutes. Take the handle apart, there will be a 4 inch by 8 inch metal box inside. This is the heater. Remember I said to let the machine sit for 30 minutes? If you didn't, the heater may be EXTREMELY hot!! Disconnect the two hoses going into it, and clean the metal pieces out (that the hoses connected to) with a needle or very small drill bit. You may want to remove the 6 or 8 screws holeding the heater together and remove the cover to clean it out. Reassemble and fill both tanks with VERY hot water ONLY and run the machine to rinse the entire system.

To prevent future reoccurences... use only Bissell extraction shampoos. Never put anything in the detergent tank except shampoo. (And only water in the water tank) Mixing chemicals with anything else turns the water/detergent mix to sludge. Also, when finished shampooing, put ONLY water in both tanks, and run the machine until one of the tanks run out of solution. Doing this rinses the hose lines out and prevents hardening of the solution in the heater ports.

I've fixed these machine for years. No dispensing is almost always the heater clogged.

Sep 29, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

Not finding what you are looking for?
Bissell 7920 ProHeat Pro-Tech Upright Wet/Dry Vacuum Logo

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13536 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...