Question about Solid Audio F15D 1-Channel Amplifier Car Audio Amplifier

1 Answer

Amplifier shuts down after 30 secs of loud playing

My f15D mono amplifier shuts down after i use it for 30 secs of not so full blast...but whenever i use it under normal volume level, it doesnt shut down. its driving a size 12" Adire Brahma MK-IV subs. thanks for your help guys

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 111 Answers

Could be a couple of different things. It's more than likely the wiring between woofer and amp is the problem. Check the Ohm load on the woofer to make sure it's compatiable with the amp. If your woofer is wired at 1 Ohm, and the amp can only take a 2 Ohm load, it would cause this problem. Also, are you having any issues with the voltage of your car? If your car's current electrical system can't keep up with your higher power demands, then it might also casuse this problem. I would check the wires first.

Posted on May 27, 2010

Testimonial: "thank you very much Bobinger79 :) il have my electrical system checked:) "

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a dyson DC 3.5 model 11-6300 d1 it will run about 30 sec then shut down the green light will keep flashing whenever I tried to run it then shut down


the flashing light is to tell u that there is something blocking the suction of machine , most times its a full dust cup or hepa filter blocked this if allowed to continue will over heat the motor so it shuts off to prevent motor damage

Nov 30, 2016 | Dyson Vacuums

1 Answer

Amplifier shuts off or goes full blast


That a new one for me, it just goes full blast huh? I don't have an answer for that, but your amp can shut off because of a lot of reasons.
One you might not have enough power running to this amp. Check to make sure your amp gain is not turned all the way up, this is NOT the volume for the amp. It's to get your amp and the head unit on the same page (i.e. if the radios at 50% volume and so is the amp) if you turn it down too low that will make the amp very sensitive to volume adjustments, and your amp will be at 100% while the raidos at like 50 or 75%. And once you go past the 50 or 75 on the radio the amp, it's going to keep trying to play higher even though its already maxing out which is going to cause it to clip and cause distortion untill it goes into protect mode. Common mistake with a lot of people.

Two you might check all your wire connection to the amp. Three internal damage. The list can go on and on as you can see. RCAs might be damage or even your remote wire. Upgrading your alternater and battery can help.
Some people would even say to check your car factory amp (some times in the trunk or in between body panels) to see if it is bypassed. If it is not bypassed it could be a posability to shut down the other amp caused by to much power causing it to shut down. hope this was helpful

May 12, 2010 | AudioBahn A1500HCT Car Audio Amplifier

1 Answer

Stereo makes a thump sound after a installed a mono amplifier, the noise comes from the subs it drives, its also present when i turn it off, just a single loud thump noise.


Are you turning of the amplifier first or the source of audio? Amps should be powered down first and then the source. If both are powered down at the same time make sure the volume is down or otherwise you will always get a thump. The opposite when you power up. The source and then the amp. Hope this helps.

Oct 13, 2009 | Rockford Fosgate Punch 1000W Class BD Mono...

1 Answer

MY AMP TURNS TURNS ON THE PROTECTIVE MODE


The amp is being overworked and is overheating so it is shutting down to protect itself. You could try to add a fan and point it at the amp to help keep it cool. Also make sure the amp is not located where it will get heat from an exhaust pipe under the car for example. They may have external fans that you can attatch to the amp to help cool it. The constant overheating could eventually damage the amplifier.

Oct 09, 2009 | Legacy 2CH 1000W AMP Car Audio Amplifier

1 Answer

Bridging a f15d mono block from solid audio witch outputs do i use


Normally right positive and left neg. Your amp should have indicators on the terminals. Of the four you should have a separate + and - for each channel. This tells you which channel is for pos, and which is for neg. If no markings switch for each one left pos/right neg or right pos/left neg. It will only work on one way.

Sep 13, 2009 | Solid Audio F15D 1-Channel Amplifier Car...

1 Answer

Amp Turns off after 30 seconds of song play


Since the unit recovers once it has powered down. I suspect that the internal protection circuit is kicking in. Check the wiring and be sure that there are no crossed wires anywhere. These amps are designed to work with 2 ohm loads and can take a direct short for a short period of time. If the wires appear ok, measure the speakers with an ohm meter. If the speakers are 4 ohm rated, they should measure just under 3 ohms with the meter, If they measure less than 2 ohms, there is a problem with the speakers.

Also, does the amp shutdown regardless of the volume level or just when played loud?

Thanks,
Dan

Apr 15, 2009 | Kenwood 1000W Class D Bridgeable Mono...

1 Answer

I have problem with my mono amplifier


Amplifiers have thermal protection. They will typically shut down at ~180F. If your amp is shutting down after running it hard for 20-30 minutes, you may not have the correct load impedance (speakers wired incorrectly).

If it overheats as soon as it's switched on (no audio), the amp may be in need of repair.

Jun 21, 2008 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

Volume up then pic gone


Good Day;

The TV's front panel may be bad, manual buttons. TEMPT FIX; remove speaker, cloth covered, cover, disconnect cables. TV will work but only with remote.

Good Luck!

Jun 12, 2008 | Mitsubishi WD-52525 52" Rear Projection...

1 Answer

Volume up then pic gone


Sounds like you have a jammed / shorted out button on the control panel... Try un-plugging the tv, and then unplug the "button panel" on the front of the tv...see if you can turn the tv on with the remote. Sometimes if one of the buttons gets shorted, it will "lock" the processor from doing ANYTHING else, as it thinks you are holding down the defective button. If this works, simply have the defective switch or control panel replaced, or just leave it unplugged and use the remote only! Hope this helps!

Jan 03, 2008 | Mitsubishi WT-46807 46" Rear Projection...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Solid Audio Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4885 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77169 Answers

Are you a Solid Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...