Question about Kenwood KAC-9104D Car Audio Amplifier

Open Question

My amp was working great took it out of my car got a new car hooked it up and couldnt get power i cheaked the power the ground the remote everything u name it i cheaked but it still wont turn on plez help.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
Duncan
  • 218 Answers

SOURCE: amp won't turn on don't know if amp is fried

Very possible that you have a blown power supply in the amp. If you are running a mono amp then there is a very good chance that you have loaded your amp with too low of a speaker impedence and fried the power supply and maybe the output section of the audio area. Hope this helps.

Posted on Apr 02, 2007

Ad
imseth85
  • 30 Answers

SOURCE: amp not turning on

wouldn't be the first JL amp I saw fried...but there are some tests you can do. First of all, double check your fuses, they may appear to be fine, but sometimes they are blown even if you can't see it. Either blindly change them or test them for continuity with a digital multimeter. Also, disconnect the remote turnon and jump power directly over from the power wire to the remote terminal on the amp, if the amp powers on then you have to go double check your remote wire. Hope this helps.

Posted on Aug 06, 2007

  • 113 Answers

SOURCE: Amp will not turn off and the Remote wire is correct.

check pwm chip ,may need replacing

Posted on Aug 22, 2007

jerryg50
  • 1689 Answers

SOURCE: Won't turn on

The output devices (IC's), and their respective drivers are damaged. It is very likley that some of their support components may also be damaged.

When there are intermittants and or shorts on the output of these amplifiers, they are very easily damaged.

The amp will require proper shop service done by an experienced tech.

Jerry G.

Posted on May 01, 2008

  • 11 Answers

SOURCE: Alpine amp wont turn on..

your power wire is sufficating yor amp probably

Posted on Jul 30, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

I have an xterminator xt2000d amplifier which is stuck on protection mode. It keeps on trying to switch over to full power but stays in protection mode. I unplugged speakers same thing replace fusses same...


sometimes the problem isn't noticeable. it could be a problem in the circuitry itself. how old/new is the amp? is the ground solid? what gauge is the wire? try hooking it up to the battery directly and instead of hooking up the remote wire from the head unit to the amp use a "jumper" (short wire) to connect it from the amp power wire terminal to the amp remote terminal. if its still in protect after that then the amp is bad and needs repair...

May 31, 2011 | DHD US Amps Xterminator XT-2000D

1 Answer

I hooked up a dual mosfet 4 channel amp and i am not getting power to it. the way it is setup is from battery to 100 amp fuse, from fuse to inside cab of truck then to 500 K farad, Split from + to power on...


Bad ground sounds like you may have paint or undercoating stopping the ground from making good contact or unhook the remote wire and run a small wire from the main power to the remote hook up and see if it works ...... May have a faulty remote

Apr 25, 2011 | Dual 2-Channel Bridgeable MOSFET Amplifier...

1 Answer

I have an Dual brand 300 watt amplifier that I just bought and I hooked everything up right (battery---power, ground----sanded metal, bypassed remote with toggle switch remote-----+terminal on switch...


Is your toggle hooked to ground? Hook your toggle switch to the battery and then the other end of that toggle the remote input on the amp.

Aug 15, 2010 | Car Audio & Video

2 Answers

Amp keeps blowin the two 30amp fuses on the amp.


Make sure that the speaker wires are wired correct at both the amp and the speakers......otherwise it sounds like the typical death of a power acoustik amp (great amps, but prone to a premature death)

Mar 29, 2009 | Power Acoustik GOTHIC OV2-1200 Car Audio...

2 Answers

Amp light is neither green or red


have u connectted the remote wire from head unit to turn amp on? have u got + and - the rite way round.hope this of use.

Mar 05, 2009 | Power Acoustik PS2-1250 Car Audio...

2 Answers

Power good no green light no subs


Make sure you got a good ground. do not ground on painted surfaces! If you got power from battery, check the remote wire running to cd player. Hook up remote blue wire with the one for cd player. If you still have a problem and the fuse is good, then the amp is fried

Jan 30, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Crunch amplifier


there is a bad ground or some other wiring issue in your car you will have to re wire all new to find it unfortunately

Dec 12, 2008 | Kicker KX600.1 Car Audio Amplifier

2 Answers

Amp wont turn on


New amp sounds messed up... grounds are bad and sometimes the amp tries to draw power but cant... So it immediately goes to protect... All jacked up... Audio specialist could help... Repair shop if local ..

Nov 04, 2008 | Kenwood KAC-9102D Car Audio Amplifier

2 Answers

Visonik 350watt Amp Doesnt Come On....


With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Let me know if you have any other questions.


Oct 06, 2008 | Visonik V117SX Car Audio Amplifier

10 Answers

AMP turns ON then turns off


The power antenna wire only supplies 12vdc when the radio is on. When CD or other sources are selected, the power antenna wire goes to 0vdc. The remote turn-on wire provides 12vdc whenever the head-unit is on. If your amps are powered on only when the radio is turned on, I would bet that you have the power antenna wire connected and not the remote turnon wire.

Sep 11, 2006 | Ultra Linear UL-2200D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9104D Car Audio Amplifier Logo

Related Topics:

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4889 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77499 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...