Question about Labtec Pulse 420 Computer Speakers

Open Question

My labtec speakers pulse 420 isnt working, what should I do?

I plugged all the wires correctly... I tried to plug the power wire into all of the plugs i have in my room but still it wont work..can you please give me some addvice please..

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

cTech1
  • 66 Answers

SOURCE: labtec 1070 speaker wire is shot

It looks like this wire is not replaceable. The good news is you can get another pair of these exact speakers for 8.99 us. here is a link for that :
http://www.mypcbee.com/cat1186.html

Posted on May 15, 2008

  • 4 Answers

SOURCE: labtec speakers want play

check whether the output plug is connected properly or not.... if it is then check out whether the adapter is giving the power output.... if it is then the speakers are spoilt otherwise u can just replace the adapter...

Posted on Feb 08, 2009

2dcapcom
  • 51 Answers

SOURCE: installing Labtec LCS 800 speakers

1 wire goes between the 2 speakers
1 wire goes from the speaker with 2 jacks in it to the computer, the back of the computer should have a green port to plug in the cable to
1 wire is the power

this is a guess without seeing your setup

Posted on Feb 17, 2009

  • 1 Answer

SOURCE: no wires for labtec lcs-3210

1500mA @ 15VDC. I've got a set of these speakers and I just looked at the adapter.

Posted on Aug 23, 2009

  • 241 Answers

SOURCE: wiring internal board of labtec computer speakers

The shielded wires are for ground, so they get connected together. Plug the wire into the PC and run some music. Then touch each wire to the others. You only have a couple of combinations to try...red-to-green and white-to-yellow, or red-to-yellow and white-to-green, . You can do this while the PC is one and music playing until you get sound thru the speakers. There virtually no current running thru the wires and you can't hurt the PC by doing this.
If the speakers use an external power supply, have it plugged in and working when trying these connection options.

Posted on Sep 07, 2009

Testimonial: "Totally what I needed. Thank you very much for your help! It's my first day on a website like this and I'm a believer already.. "

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Trying to get my Labtec to work. Computer does not see it.


If you are taking the sound output from the green output socket on the back of your tower, then your speakers must be powered by a mains adapter.
You will have a black main adapter similar to a mobile phone charger, and the output from that on a thin wire will plug into one of your speakers, normally the one with the volume control on it.
To test if the speakers are powered up and working, plug an MP3 player into the green plug that goes to the speakers, does that play ok?

Apr 24, 2014 | Labtec AM-242 Microphone

1 Answer

Speakers won't power on when plugged in


firstly check your power cable by moving the wire in various directions while it is plugged in ac outlet and powered on, if it lit up the standby power LED then the prob lies on the power cable. If not, try opening the speaker system box itself (be sure to unplugged the power cable before opening the box), then visually check inside for the little cylindrical glass type tube(if the circuitry still uses this kind of fuse) if it is burnt-out.
Hope this help pal...

Feb 23, 2013 | Labtec Pulse 285 Computer Speakers

1 Answer

REAR door speakers dont work in 98 gmc c1500 suburan


Hi, generally when you a buy a car, the steroe and speakers are all stock fitted, if bought second hand, they may have been upgraded.
Down to your speakers, check connectors behind the steroe unit, should be 2 plugs, one for power with red, black, yellow and blue wires, and the other plug is your speakers. Check there is 8 wires into the plug.
If all is correct then check the rear of your speakers, check the connection and that the wire isnt loose.
If all is fine there must be a wire break somewhere, your stereo presets are only set to the front speakers (fade setting).

Hope this helps

Mar 08, 2012 | Car Audio & Video

1 Answer

No sound


just remove the speaker wire from computer and check some other speakers with it like headphones if sound is there or not???if yes then might be problem with your speakers if not then you have to update your sound drivers...for that you can use softwares like driver genius it is really a good software...

Jan 06, 2012 | Labtec Pulse 485 Computer Speakers

1 Answer

I have a labtec surround sound system and need help with installation


Hi , whats the problem bud?..
1st: make sure it is plugged into a wall socket correctly , to gain sufficient amount of power.
Then correctly , plug the green color coded wire , into the Green input jack on your PC at the back , into the motherboard unless you have a sound card...
It should work perfect then :)
Happy new year :)

Dec 06, 2009 | Labtec Pulse 420 Computer Speakers

2 Answers

Wiring internal board of labtec computer speakers


The shielded wires are for ground, so they get connected together. Plug the wire into the PC and run some music. Then touch each wire to the others. You only have a couple of combinations to try...red-to-green and white-to-yellow, or red-to-yellow and white-to-green, . You can do this while the PC is one and music playing until you get sound thru the speakers. There virtually no current running thru the wires and you can't hurt the PC by doing this.
If the speakers use an external power supply, have it plugged in and working when trying these connection options.

Sep 07, 2009 | Labtec LCS 1040 Computer Speakers

1 Answer

Reinstalling speakers onto my computer


there is one calbe that goes to the computer its plug is green plug it in the green port on the back of the computer.

Apr 23, 2009 | Labtec Pulse 285 Computer Speakers

1 Answer

Installing Labtec LCS 800 speakers


1 wire goes between the 2 speakers
1 wire goes from the speaker with 2 jacks in it to the computer, the back of the computer should have a green port to plug in the cable to
1 wire is the power

this is a guess without seeing your setup

Feb 17, 2009 | Labtec Audio Players & Recorders

1 Answer

Labte pulse 285 speakers!


You won't find drivers for these Labtec speakers because they don't exist.They are plug-and-play speakers so they should work as soon as you plug them into your computer. But I have the same problem as you do (I had to format my comp as well and now I'm screwed because the speakers aren't recognized by the computer).

Nov 02, 2008 | Labtec Pulse 285 Computer Speakers

Not finding what you are looking for?
Labtec Pulse 420 Computer Speakers Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Labtec Audio Players & Recorders Experts

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

618 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Kazim ERGUNEY
Kazim ERGUNEY

Level 3 Expert

577 Answers

Are you a Labtec Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...