Question about Sony Xplod XM-1652Z Car Audio Amplifier

Open Question

Protection light on 1600 watt class d amp

I have am sony xplod 1600 watt class d amp but the protection light is on now

Posted by on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: brutus 1600 watt hi fonics amp

i have had the same problem with one of my amps that was given to me by a friend and one of the channels were blown. Blowing a channel can cause the protect light to stay on.

Posted on May 08, 2008

  • 631 Answers

SOURCE: Sony Xplod 2-Channel 1000 Watt Amplifier trouble shooting

What's the model number of the amp?

What speakers do you have on the amp?

Are the speakers moving significantly at high volume?

Posted on Sep 14, 2008

  • 18 Answers

SOURCE: sony xplod amp(XM-1652Z ) power/protect light

if your amp is overheating your sub is needing to much power that the amp doesnt have.
if its cutting out and the red light comes on you need to check the wiring. nothing not even the tinyest speaker wires can be touching.
proper wiring would be your best bet.
but i would upgrade amps.
cheap bang isnt reliable.

Posted on May 27, 2009

  • 65 Answers

SOURCE: sony xplod 1000 watt amp not working

you need a amp kit your battery or alltinator isn't powerful enough to handle the wattage you need a juice can it gives yur battery more power

Posted on Jul 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Audio & Video

1 Answer

Amp going into protection


Is the amp bridged? If you only have one speaker connected to it, I sure hope so. How much power can that speaker safely handle and what is the impedance of the speaker? 2,4,8 ohm? A 1200 watt amp with only one speaker may be too much amp.

Jan 14, 2014 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Red power/protector light


The amplifier has gone into protect mode and will stay in that mode until the cause is corrected.

Nov 17, 2013 | Sony Xplod 800W Class AB Bridgeable...

1 Answer

On the sony xplod 800 watt amp what are the 2 fuzes in the back for?


The fuses should be 30Amps each and they are there as a protection system in case of a power surge. They will blow before damaging your amplifier. However it is not a 100% fail safe proof.

Feb 04, 2011 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

Will a sony xplode 100w amp bridged push a 1600w cab? if not what is the best compatible cabinet wattage reccomedation?


100watt amp and 1600 watt cab?? Your amp will run it but a lot of the dynnamics of the speakers won't be there.

Dec 21, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

I hooked this 1000 watt amp up.it turns on but it


Your amp needs to be serviced. Bad protection circuit. Take it to a local car audio shop and have them bench test it first to be sure. Hope this helps.

Sep 26, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Settings for a Sony Xplod 1200 watt amp, with two 12 inch subs


What kind of subs are you running? Meaning what brand, what are the ohm, spl and wattage? I'll look up your amp while you get that info to me. Looking forward to helping you:) Thanks!

Apr 08, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Hi i have a 600 watt sony xplod amp model xm-554zr and it recently stopped working. when i turn my car on the amp turns on but only for a sec then the protection light comes on, on the amp and it wont...


sounds like maybe a speaker short, try unhooking your speakers and then powering up your amp, if it then powers up with the speakers unhooked try hooking up each speaker one by one untill the amp goes back into protection and then you have your bad speaker.

Mar 08, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Sony xplod 1200 watt


i had the same ploblem with my amp then i found out i didnt have a good enough ground. Make sure you groung it to your weel well or some part of the frame. Or you mite be running with a fuse thats pushing to much power i use a 100a fuse 5 gage power cord to power my 1200w xplode and my 2 12" kicker comps. Or if your using two diff kind of subs then you amp is confused in why your asking for 500w on one side and 600w on the other this will also make your amp light come on.

Jan 19, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Philip Rowney
Philip Rowney

Level 2 Expert

94 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...