Question about Power Acoustik LT-980/2 Car Audio Amplifier

2 Answers

Car amp problems

My amp was working fine, but i took out my system and was putting it back in when this happened...as i was screwing down th power wire, my screwdriver touched the amp and caused a spark. Now my led light is on, my fan is on, but i got no sound coming from either of my subs. All the wiring is correct, is there some way to trouble shoot, or know what is wrong? It was all working fine until i took it out and did that. Thx

Posted by on

2 Answers

Yeah, I did that first, it turned out to be a problem somewhere else(wiring) and i have since fixed it. On the positive note after rewiring my 8 ohm speakers to be in parallel instead of series i now produce about 450w from my 4 ohm 2 channel bridged amp. Whereas before they were in series producing 16 ohms unbridged which bogged my amp down to like 25w each. It was on stereo before i bridged it and ran it in series, and now it bangs bridged in mono almost as good as did before my alpine crapped out on me. But thx for the suggestion, since its worked for me before i rate yours FIXYA!

Posted on Apr 08, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 290 Answers

Be prepared, I'm going to ask a stupid question :).....

Have you tried removing both the +12V and Remote wires from the amp for a few minutes/hours and then reconnecting? It's possible the amp just needs a little "reset time" before working.

Posted on Apr 08, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I had the car in storage for 35 days. Upon startup, battery was dead. I took the dead battery out(only 1 year old) and put in a good battery which started the car, while the car was running good I took out...


You recycle the old dead battery

Have no idea why you even put that back in

Common sense & your friend is correct

You don't disconnect anything on today's
vehicles, even with the key on

Put in a new battery,start the car, warm it up
& drive it for awhile & maybe you will get lucky
& it will complete some of the drive cycles & run some
monitors ,you know nothing about & it will be fine

If not, your mechanic friend should be about to stop
by with the bosses scan tool & help you out

Sep 23, 2011 | 1999 Acura TL

1 Answer

Car dies & wont go over 1000rpm


sound like your ABS system. you may have a lose wiring plug some where in the system when the ABS system get active it the system gets all kind of funny things make the car go slow the brakes it brakes it self there is no power in the engine. have your car for a truly electrical check up

Apr 24, 2010 | 1999 Daewoo Lanos

1 Answer

Subwoofer powers on for about 4 seconds and then shutsdown


I don't know if you were able to get the problem fixed, but I had the same sort of problem where it worked and then all of a sudden it stopped working right in the middle of a movie.
I took it to a repair shop and he found that it was the power supply... a $4.00 part.

Jun 14, 2009 | JVC TH-C30 System

1 Answer

Won't power up.


I have a TH-C30. I had the same problem where the unit just stopped working - no standby light and no recognition of power at all. After checking this forum and another, I opened the unit, found the ceramic fuse where the power comes in and went to Radio Shack. They have a T1AL250V fuse pack that is a 1 amp, 250 volt, 5 X 20 mm SLOW BLOW glass fuse which is a better fuse for this common problem. Their RS number is 270-1063 and a pack of 4 costs about $3. Put new fuse in and the problem was solved.

The repair took minutes - 3 screws on the back and two screws on each side. Lift the cover from the back (it is slip-hinged on the front) and replace the ceramic fuse. It slips out with a little help and the new one snaps in place.

Mar 29, 2008 | JVC TH-C30 System

2 Answers

Amp problem


are you handy with a volt meter, I would first check for shorts, what amperage fuse are you using? Do you know what amperage is reccomended for it? manual?

Dec 06, 2007 | Car Audio & Video

3 Answers

No power


I have a TH-C30. I had the same problem where the unit just stopped working - no standby light and no recognition of power at all. After checking this forum and another, I opened the unit, found the ceramic fuse where the power comes in and went to Radio Shack. They have a T1AL250V fuse pack that is a 1 amp, 250 volt, 5 X 20 mm SLOW BLOW glass fuse which is a better fuse for this common problem. Their RS number is 270-1063 and a pack of 4 costs about $3. Put new fuse in and the problem was solved.

The repair took minutes - 3 screws on the back and two screws on each side. Lift the cover from the back (it is slip-hinged on the front) and replace the ceramic fuse. It slips out with a little help and the new one snaps in place.

Jul 21, 2007 | JVC TH-C30 System

1 Answer

Power Problem, LED Lights up and then shuts off


Do you have the switch or activate wire on the new amp. to the right hookup? If you do, then theres a problem with the amp and if your not a tech these can be a difficult thing to trouble shoot. Take back the amp or seek out a pro to test it on a bench. Good Luck

Jul 24, 2006 | American Pro VS1405 Car Audio Amplifier

Not finding what you are looking for?
Power Acoustik LT-980/2 Car Audio Amplifier Logo

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

67800 Answers

Custom Exchange
Custom Exchange

Level 3 Expert

397 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...