Question about Kitchen Ranges

2 Answers

Light doesn't work on Kenmore Model 55022 Range hood...

I have a Kenmore Elite model 55022 range hood that is about 2 years old. Recently both lights stopped working. So I did what any one would do went and bought 2 replacement bulbs. When I put the new bulbs in the lights still wouldn't work. So I took my meter and did some troubleshooting. I found that there is 120VAC at the light socket. I know that the bulbs are good, I tried them in another light fixture. Also the fan on the range hood still works. Do you have any suggestions.

I have a Kenmore elite range hood approx two years old. one light was bad and the other good. Neither of them burned when replaced. Is there a fuse that controls the light switch. the fan works.

Posted by on

  • 4 more comments 
  • Nina James Jun 04, 2008

    Both our lights dont work. It is not the bulbs. The light button wont push in and stay.

  • arghargh Jun 08, 2008

    Also have same problem one light stopped working about a year ago.  Now they are both out.  new bulbs don't help.

  • arghargh Jun 08, 2008

    I have same problem.  One light stopped working like a year ago. Now both are out.  Changing bulbs doesn't help.

  • Anonymous Feb 26, 2009

    I have a Fasco range hood that the flourescent light will not come all the way on but the fan works fine. I have replaced the tube and also the ballast and the starter.What else should I check?

  • Anonymous Mar 12, 2014

    I am trying to replace the fan switch and I don't which wires go where.

  • Anonymous Mar 26, 2014

    How to fix it? I don't want to replace a motor control (this part cost over $500).

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a Kemore Elite range hood (same as Broan Allure QS2). Firss it would only work on one speed now the fan is not working at all. the lights work fine

Posted on Jun 21, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 247 Answers

If you're getting 120V at the lampholders, yet it's not lighting lamps that still work perfectly well in other fittings, two possibilitiesspring to mind.

One is that the cap on the bulbs isn't quite compatible with the fitting. Assuming they're some variant of Edison Screw, make sure that the centre terminal in the lampholder is sticking out far enough to touch the terminal on the bulb. Also check whether the lampholder achieves it's outer connection just with a small tab, rather than with the whole of the threaded ring. If so, make sure that this is going to touch the appropriate part of the bulb.

The other possibility is that you've got a high resistance connection somewhere - not enough of an open circuit to drop the 120 V when feeding the Megohm load presented by a meter, but more than enough to kill the supply when you have a lamp load. Only way to chase this is to use the meter on ohms range to bell out all the wiring between the lampholders and bits of the system which do work properly.

A.

Posted on Apr 05, 2008

2 Suggested Answers

  • 139 Answers

SOURCE: Light doesn't work on Kenmore Model 55022 Range hood...

If you have 120VAC on the center contact of the light socket, and a working fan, but the bulb won't light...the most likely cause would be a disconnected neutral wire (white) in the light wiring inside the hood....assuming everything else is wired correctly.

If you're comfortable with further electrical testing...let me know, and I can describe a detailed procedure to check the status of the neutral wire. Otherwise, you may need the assistance of someone familiar with electrical troubleshooting or appliance repair.

Posted on Jan 27, 2008

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenmore microwave hood combination


If you have tried to reset the microwave oven by turning the mains power off and on without success then it is likely the display is faulty.
The only way to repair is replace the control panel board. This can cost a lot of money.

See this site to give you some idea. Best to contact a repair technician and get an idea of costs.
KENMORE ELITE Microwave Range Hood Controller Parts Model 72180839500

Aug 03, 2014 | Kenmore 1.4 cu. ft. Speedcook Microwave...

1 Answer

Brian range hood model CJD130SS fan light on display flashes with fan off or on.


I believe that's the "change or clean filter" indication. Clean the aluminum filters in the dishwasher, replace the charcoal filters if non-ducted, press the fan light over 3 seconds and it should reset.

Sep 02, 2013 | Broan-NuTone Broan Elite E661...

3 Answers

Kenmore Range/oven Burners won't lite


Ours did the same, I unplugged the stove for 1 minute and afterwards the burners worked fine.

May 19, 2009 | Kenmore 75844 / 75849 Gas Kitchen Range

1 Answer

Kenmore elite ranghood (series# 550) not working


unplug the unit and unscrew the bulbs. put 2 new in if they still dont work then you may have fried the control. there are usually no fuses between the control and light/fan. well i never saw a fuse between the 2.

Dec 07, 2008 | Kitchen Ranges

1 Answer

Kenmore elite range oven problems


hi. thanks for the question . i would replace the igniter in oven .thanks the appliance doc

Sep 26, 2008 | Kenmore 79012 / 79014 / 79019 Gas Kitchen...

1 Answer

Light bulb socket replacement for a really old Air Fare kitchen hood


The chances are that your range hood light socket was fully impacted with grease from cooking. Shut the power off to the range hood or, in many applications, simply unplug the power cord. Remove the socket. Get a spray can of electrical parts cleaner and saturate the socket through the tiny pin holes you may see at back of socket. shake out all of the cleaner fluid. Somehow hang the socket up with bulb base facing up all night. Hook it up. That might solve the problem.

It worked for me very recently on a 20 year old range hood.

DON'T USE ANYTHING OTHER THAN AN OFFICIAL ELECTRICAL PARTS CLCEANER. Most hardware stores, etc., have it.

Jul 23, 2008 | Kitchen Ranges

1 Answer

Instalation instructions for kenmore range hood model 50303


You should be able to find the manual here:

http://www.managemylife.com/mmh/owner_manuals/13409/KENMORE-ELITE-Range-Hood-L1004363?brand_name_search=kenmore+50303

The file name is L1004363.pdf

Jun 07, 2008 | Kenmore Italian Design 50303 Kitchen Hood

2 Answers

Light doesn't work on Kenmore Model 55022 Range hood...


If you have 120VAC on the center contact of the light socket, and a working fan, but the bulb won't light...the most likely cause would be a disconnected neutral wire (white) in the light wiring inside the hood....assuming everything else is wired correctly.

If you're comfortable with further electrical testing...let me know, and I can describe a detailed procedure to check the status of the neutral wire. Otherwise, you may need the assistance of someone familiar with electrical troubleshooting or appliance repair.

Jan 27, 2008 | Kenmore 51840 Kitchen Hood

2 Answers

Problem with a different range...


Tom, generally a f1 code implies a control problem. The tech sheet gives 3 possible causes. 1. A shorted keypad, solution to replace electronic control. 2. Controls internal checksum has become corrupt, solution is to unplug for 30 seconds, if the code comes back, replace the electronic control. 3. Control has sensed a overheating condition, relay on the board may have shorted out. Each one recommends replacing the control board. The part I have for this model number is 316127903. Says it's grey. Catriver..post back.

Oct 24, 2006 | Kenmore 79383 Dual Fuel (Electric and Gas)...

Not finding what you are looking for?
Kitchen Ranges Logo

Related Topics:

1,434 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8205 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

paulcarew

Level 3 Expert

2364 Answers

Are you a Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...