Question about Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

No Suction My two year old Kenmore Progressive stopped working in January. The guy at the Sears service center convinced me that buying a new one would be cheaper than getting it fixed. So I bought the exact same model and now this one has given out in the exact same way! I'm so confused. When I press on, it lights up and makes the whirring noise. Everything seems to be working but there is no suction anywhere. Not in the main part or the hose and there's no "cyclone effect" in the chamber. All the dirt is just caught in the brush. I called the service center and they said it's probably a clog which is not covered under my warranty. However, I have never vacuumed anything besides ordinary dust. I don't want to go to the service center again because it means dragging this heavy thing on the subway from Manhattan to the Bronx. Please help me!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 427 Answers

Try looking within the vacuum to see where the suction is getting stuck at. You may have to do some disasselbmeing but this is a manufacturers problem. You should also try to speak to the manager at the support and make a big dispute until you get your way. (usually works with those people) If possible, return the vacuum.

Posted on Apr 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No suction motor comes on at all


It should be under warranty. Take it to a warranty repair center

Jan 17, 2014 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Ther is no suction and rolar prush is not runing in my kenmore vacume progressive


Remove the rotating brash and check it, something is blocking the suction, probably you need a new belt

Mar 24, 2013 | Kenmore 31912 Progressive Direct Drive...

1 Answer

Vacuum wont run


THE BEST SOLUTION IS TO NEVER BUY A SEARS VACUUM AGAIN. THEY DO NOT LAST AND WARRANTY AND REPAIRS ARE TOO EXSPENSIVE! I BOUGHT THREE OVER TEH YEARS, AND NOW AS YOU KNOW, THREE STRIKES AND SEARS IS OUT!!!!!

Feb 24, 2009 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Lack of suction


I use a broom handle..works very well

Nov 26, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Kenmore Cannister Vacuum Model 26312


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=109396&thid=552260
Kenmore Canister Vacuum Model 26312
Posted by Alecia Rojas on Apr 28, 2008
Kenmore 23612 Progressive PowerMate Canister Vacuum
Vacuum is not sucking. It is just over a year old.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
It sounds like you have a clogged hose or a full bag, or dirty filter. The best way to check your electric hose id to run a marble or steel ball thru the hose and if it goes thru all the way then check the bag and filter, most times it is the vacuum hose. If it id the hose you can try to pull apart the clog from both ends using another central or canister vacuum. If not and the ball stops mid way thru the hose then you can use a broom handle with a round hook on the end so that it does not puncture the hose is any place and the round hook can loosen or break up your clog and then your suction will return, if you poke a hole in the vacuum hose there are repair kits that go on the outside of the hose that will slide over the hose and then you use a heat gun and shrink the hose repair kit down to size therefore plugging the leak. (Hose repair kit). So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.sears.com/shc/s/home_10153_12605
National Customer Relations 1-800-549-4505
Home Services & Repairs 1-800-4-MY-HOME
1-800-469-4663
Parts Orders & Inquires 1-800-366-PART
1-800-366-7278
Thanks, Don – The Vac Man
Go Ahead. Use Us.

Apr 28, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Load noise at start-up goes away after a minute, but there is no suction.


If the brush roll and motor runs and sounds ok, then that is an indication of a clog, either in the hose or the dirt inlet down by the brush roll. You should have a years warranty on this, if you can't figure it out, then take it into Sears and get it repaired.

Apr 15, 2008 | Kenmore 31913 Progressive Direct Drive...

2 Answers

My Kenmore Central Vac loses suction


Do you have the same problem in all of your outlets? If you do, then there is a problem with the hose end. If it is only at one outlet, then that outlet has a problem.

Mar 13, 2008 | Vacuums

2 Answers

Kenmore Progressive 25614 vacuum


check the reset button on the brush assembly which is also called the power mate. if not then take it to your local sears repair center. if it is the pc board. sears has them in stock. I think it is about $7 for the part.

Dec 24, 2007 | Kenmore 25512/ 25513 Progressive Canister...

Not finding what you are looking for?
Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60971 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...