Question about Vacuums

1 Answer

Hoover windtunnel v2 - agitators spin but stop when in contact with carpet

Posted by on

  • jetman888 Feb 09, 2009

    my agitator stops moving when it touches the carpet. I cleaned everything and the belt looks OK. Any ideas?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Check the belt that connects the rollers to the motor shaft, also check the pulleys the belt runs over, you might need to clean the pulleys and / or replace the belt.

Posted on Apr 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My agitator roll won't roll when on a carpet. It does roll if it's on a hard surface.


Your belt is stretched. The drag from the hard floor is not enough to stop it, but the carpet is. Change the belt, and all should be well.

Feb 04, 2010 | Hoover S3755 WindTunnel Bagless Canister...

1 Answer

The Rotary brushes do not rotate/spin when the unit is turned on.


check the belt it may be stretched or broken...also carpet and hair or other debris around the bruches may have it in a bind,,..remove the 2 screws holding the bottom on to check this

Jan 03, 2010 | Hoover V2 U8140-900 WindTunnel Upright...

1 Answer

Hoover U5780-900 Windtunnel Cyclonic Bagless


You probably need to change the belts. Here are the belts you need and the manual:

Hoover 5780-900 Belts

Manual

Dec 22, 2009 | Hoover U5780-900 Windtunnel Cyclonic...

3 Answers

Auto brush on hoover windtunnel doesn't spin anymore


I have a Windtunnel S3765 with the same problem - and it has very little use so I'm confident it isn't wear. I find that the wheels do not raise the agitator brush sufficiently high to reduce the drag caused by excessive contact with the carpet. If I raise the front a bit the brush spins as it should. It also works if I take the housing apart and use it without ..... but this is tricky.

Unfortunately I haven't figured out a way to hold it up efficiently. I am toying with afixing something to the bottom of the housing to raise the front enough to give the brush a little more room.

Dec 20, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover Windtunnel


the gears inside might be worn down.

Aug 25, 2008 | Hoover U8147-900 WindTunnel V2 Bagless...

1 Answer

Hoover windtunnel


would suggest the drive belt is stretched and thus is slipping when contact is made with the carpet.

Jan 14, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover u8147-900 upright vacuum


Either the brush rolls are bad, at the ends, or the gear/motor asm. is bad.

b095bb5.jpg

Dec 29, 2007 | Hoover U8147-900 WindTunnel V2 Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...