Question about Audio Players & Recorders

1 Answer

Sa-ex900 de technics

Hi,i have an amp.sa-ex 900 and it doesn't turn on , i heard " clic" wen i push the button, the display doesn't light "on" and " help" light ,still flash on and off ?? nothings happen? no sound, no display.i bring back my amp to the repair shop,were i bought it ,and they never find the probleme.the probleme start in a party at high volume,he stop and never restart thank you very much.......sorry for my english i'm french canadian.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

These systems use a large Ic for the output amplifier section. There are 2 of them inside. These amp packs fail and are not cheap to replace. Figure about $65-$75 for the replacement pac plus a labor charge. I have repaired a number of these in the past. These sets sound good but are expensive to repair.
Dan

Posted on Apr 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, I have the Technics SA-AX530 amplifier and I was wondering if there is a way I can turn my subwoofer up through the amp? Can't find anything on the remote, please let me know if there is anyway I can...


Hello, I searched all thru the service manual of the Technics SA-AX530 Receiver, and I have to say that there is not any way to turn the volume of the subwoofer up (or down) alone. The only control of the sound that affects the subw. level is the BASS control, but it controls also the bass at the speakers too.
Good luck.

Oct 29, 2013 | Audio Players & Recorders

1 Answer

Where is fuse in Bose SA-3 Amp


If there is not an external round push and turn style fuse port then it is in the unit itself. You will have to take it apart.

Jan 27, 2013 | Bose Lifestyle SA-3 2-Channel Amplifier

1 Answer

Technics SA-GX370 amplifier


Hi
One of the amplifiers is shorted. Take to a reputable repair person or check www.micromendllc.com

May 07, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Hi, I have a Technics Sug-75 amp, and when i turn it on, all the lights flicker on and off and the fan is on but making a constant clicking noise. I would really appreciate any help since I am useless...


sounds like a dirty power switch, common fault if it is a push button type, if so unplug the unit and push that button on and off over and over again for 1/2 minute then plug back in. if the problem seems to have improved then the power swotch should be replaced or cleaned.

Apr 18, 2010 | Audio Players & Recorders

2 Answers

Describe your I have a technics sa ax910 turning


1 You may have a failing power supply regulating circuit in you amplifier and the fail safe circuit is trying to protect the rest of the circuit.
2. there may be a voltage overload at the primary side of the power supply circuit which in this case is causing it to shut down.

Jan 06, 2010 | Technics Audio Players & Recorders

1 Answer

Device code for Technics SA GX530


I would TellYa but it would require that you first sign up for the TellYa Premium Plan. Best of luck with this little scam.

Oct 01, 2009 | Technics Audio Players & Recorders

1 Answer

Amplificador panasonic modelo sa-he7, se pone en error f70


rafatecnico amigo mio el error esta en la placa de coneccion de dispositivos auxiliares por favor revisa soldaduras de los dos transistores de potencia que se encuentran juntos y de los dos transistores de acople de los de potencia, si se encuentran bien entonces alguno de ellos esta averiado en cortocircuito o abierto

Jul 29, 2009 | Technics Audio Players & Recorders

1 Answer

Cuts out


Check your speakers. your speaker may be defective

Dec 17, 2007 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98762 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69718 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...