Question about Rockford Fosgate Punch 500a2 Car Audio Amplifier

1 Answer

Something Wrong With my Fosgate 500-a2 Amp

Ive had my amp hooked up and powering my sub, Now the red light comes on but I get no sound from the sub. I have checked and re checked every wire to assure I have them Connected properly. Ive also looked for any way that any wire could have possibly peen pinched, And nothing is pinched.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 290 Answers

Is the amp being fed directly from the head unit's RCA preamp outputs or is it being fed by another amp's preamp outputs? Try temporarily wiring up a speaker you know is good in place of the sub and see if anything changes.

Posted on Apr 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Im looking at this rockford fosgate p700-1bd amp brand new for $300 it comes with a birth sheet it says 750 rms on a 1ohm load. i cant find any reviews about it 225 rms x 1 @ 4-Ohms 450 rms x 1 @ 2-Ohms...


You can't go wrong with Rockford, in my opinion. Everything they make is well built and high quality. I personally have two Rockford p500-1bd amps hooked up to four 12 inch subs in my car and those amps make those subs slam. I have them wired down to 1 ohm and the specs say that they should be pushing 500 rms a piece at 1 ohm so that p700-1bd amp really packs a punch. Depending on what you're hooking up to that amp I would defenitely recommend it to you. - Ryan in Alaska

Feb 15, 2011 | Rockford Fosgate P7001BD Car Amp

1 Answer

What is wrong with my 1000w sony xplod amp?


need repairs on the inside usually when u see that fuse melt something else probably melted on the inside. something is grounding out the amp on the inside . get it checked

Jun 05, 2010 | Car Amplifiers

2 Answers

My subs/amp are not working


when you car is running, it charges the battery somewhat. So the voltage problem is not a problem. The red light means the amp is going into ''Protect Mode". This usually happens when something is wrong with the amp. Usually the amp is getting hot. Check all of you connectiong and check the final impedance of the subs. Make sure the amp can handle the impedance of the subs. If you need anymore help, message me.

Feb 12, 2010 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

I have a rockford fosgate punch 150 and it will power a small 5 1/4" speaker, but doesn't seem to push my 15" subwoofer. I am reading 4ohms across the sub so I'm assuming that it is fine and that there is...


amp is way too small to power a 15 inch sub. But you should get some sound out of it, not silence. You can use a 9 volt battery to test your sub, if the sub pops when the 9 volt is placed across it's terminals then it's ok. If it does not pop then your sub may be bad, or the coil may be frozen. (It can still read 4 ohms if frozen). If your amp powers smaller speakers fine, you know it's not the amp. If the sub tests ok, then verify your connecting it properly to the amp's correct bridging terminals.

Jun 12, 2009 | Rockford Fosgate Punch 150S Car Audio...

1 Answer

I have a rockford fosgate 501bd amp the protect light comes on when my deck turns on even with no speakers connected


un hook the subs and let the amp sit there on if the protect light shuts off you wired your subs wrong if it doesnt go off tun it off then back on with no sub music all the way down then slowly turn the music up if the light is off then comes on you need new rcas

May 03, 2009 | Rockford Fosgate Power 501BD Car Audio...

2 Answers

Rockfordfosgate P6002 amp protect light goes on


are u sure u have them running at the right ohms, for not only the subs but the amp too...if you go lower than your amp is rated you can fry stuff...via protect mode......hopefully this helps

Mar 17, 2009 | Rockford Fosgate p-450.4 Car Audio...

1 Answer

Rockford Fosgate Punch 401s starts then smokes


Can somebody email me the schematic for the Rockford Fosgate 401S?

Feb 04, 2009 | Rockford Fosgate Punch 401S Car Audio...

1 Answer

I need help


Most of the time if the red light is on the amp is no blown but some times it does this cause the subs are hooked up in the wrong way. If the amp is only 2ohm stable and you hook the subs up to it at 1 ohm than the amp will not work so I would check this frist.

Oct 17, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Jl 500/1


Nine times out of ten if the amp smells burnt it usuallly is. Your best bet is to hook another amp to your system and see if you get sound.

Jan 30, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Rockford Fosgate P3002 Amp


what are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)

Aug 22, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate Punch 500a2 Car Audio Amplifier Logo

Related Topics:

192 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Amplifiers Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...