Question about JVC TH-S3 System

1 Answer

No sound System has been working fine for about 3 years. We switched it on the other day and there is no sound. All the lights are working ok and you get the usual 'click' from the system when it switches on. Checked all connections, even checked fuses inside.....

Posted by on

  • Anonymous Apr 07, 2008

    When playing a DVD the sound at no particular time just switches off. The movie still plays but the subwoofer just powers down, subsequently having no audio.

    I have been unable to find the product in JVC's product list. The model number I have is: SP-PMW303

  • jerdare Oct 25, 2008

    While watching a movie the sound sudddenly was no more. The sound does work thru the headphone jack.

×

1 Answer

Can i play my th-s3 dvd player without soundround sound, though tv and get sound?

Posted on Sep 14, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My interior lights were out on my explorer sport trac after appearing just fine a day ago. Battery seems totally dead.


if the battery is dead, its dead, it might take a recharge, but if its more than 3 years old, replace it. After that, check if all the lights work ok.

Sep 07, 2011 | 2005 Ford Explorer

1 Answer

RCA 5.1 surround sound system, The system was working fine until one day it decided not to power on. The light turns on when you plug it in, but when you press the power button it doesn't turn on.


power supply problem.
you mean, stand by ok.not power up right.?
ok it can be happen something wrong with its power supply ,standby circuit,system control cct problem, or loose connection on the printed board and loose connection on the connector in the pcb can happen.
some times it can be the power on off switch. anyway open the cower and clean it with compressed air or clean it with small brush then try to turn on again and please comeback with result.

Dec 26, 2009 | RCA RT2250 System

2 Answers

Speakers worked fine for a year and now no sound at all


your speakers transformer is getting problem

so change the part of your speaker

from repair shop

then try

ok bye..............

Nov 11, 2009 | Bose Companion 3 Computer Speakers

1 Answer

Vacuum will not turn on, the switch is ok. It


how do you know the switch is ok? it can go bad as fast as a light bulb. Sears sells kenmore vacuums,you con get a book from them.

Oct 18, 2009 | Kenmore Upright Vacuum Vacuum

1 Answer

Its a un branded 20.9'' flat screen TV 3/4 years old. When switching on it may work for 1 hour or more or 3 minutes or not at all. Sound is OK just no picture although pressing controls on TV set sometimes...


most trouble like that shows a protect mode, there's a problem with the system and it shuts down,if the sound remain after the screen off, the back lights circuit is only in trouble.whole system shutdown.tell me

Aug 27, 2009 | Televison & Video

2 Answers

My XBox 360 does not show up on the tv screen, but it has sound.


this happens a lot. what happend is the red white and yellow wires that you put in the back of your tv. the red one is not in the right area or
there is a switch right were you plug in that cable with the red whit and yellow cables to your xbox that says hd or normal switch that to whatever your tv is

Jul 17, 2009 | Microsoft Xbox 360 Console

1 Answer

Car shakes and is running on 2 cylinders.


cheap fix number one yake a timing light and check for missing fire does car run ok for a few seconds when cold sounds like a bad module

May 21, 2009 | 2003 Mitsubishi Galant

1 Answer

Possible electrical short, batteries drain


ok stay with me. Buy yourself a 12V test light. Disconnect negative side of the batt. You might need 2 people for this. With test light connect ground wire to disconnected batt cable. Touch pointed end of test light in battery open terminal. If it lights up, you have a 12V drain in teh system. Now, most times you remove ONE fuse at a time and reinstall till the light goes out. MAKE SURE ALL DOORS ARE CLOSED AND EVERYTHING ELSE OFF. One you determine which circuit it is, .the fun begins. What on that circuit is draining the battery ?

Mar 31, 2009 | 1991 Pontiac Firebird

2 Answers

No heat!


Ger, do you get your hot water off the same boiler and it that working alright? How many zones and are they controled by zone valves (little boxes mounted on the pipes) or circulators (small pumps)?

Boiling water sounds can indicate hard water deposits in the boiler or that your aquastat is set too high allowing the water to heat up higher than it should. Check your boiler guage and let me know what temperature you are recording. Get back to me with the answers to my questions, we'll figure it out.

Nov 27, 2007 | Honeywell Programmable Thermostat Heater

Not finding what you are looking for?
JVC TH-S3 System Logo

Related Topics:

252 people viewed this question

Ask a Question

Usually answered in minutes!

Top JVC Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4946 Answers

The Knight
The Knight

Level 3 Expert

73159 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Are you a JVC Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...