Question about Photography

1 Answer

Minolta camera Im having trouble loading a new film, I still have power to the camera but it wont take the new film any ideas?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 85 Answers

Check the film pressure plate in the back door whether it has proper pressure and in proper position.

Whether the film lead is dragged up to the required length and its perforations are correct without any damage.

Pull slightly the film and rewind it by hand to check its spool rotating freely
Then it needs service

Posted on Apr 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Put new batteries it won't power on. been sitting not used for multiple years. bought new film but it doesn't seem to load since it won't power on. minolta qt si camera


Did it sit for years with batteries in it? You may need to clean corrosion off the battery contacts. Even alkalines and rechargeables can leak.

Oct 22, 2010 | Konica Minolta Maxxum QTsi with 35-80 lens...

1 Answer

Hi, i have a minolta 5000i and the indicator on the screen keeps indicating that i have the film in wrong. I have my owners manuale and loading the film is dummy proof but the camera wont pick up the film....


Your 5000i is one of the 2nd generation auto focus SLRs Minolta released in the early 90s. They no longer supply parts or service for this model. If there is a mechanical problem with the film transport, it is likely beyond hope. You can use any lenses for it on similar Minoltas like the 300Si/450Si series which came after yours. These are available usually on sites like eBay for a very low price. I would even consider looking on sites like Craigslist.org for something local.

Jan 06, 2010 | Photography

1 Answer

Film Advance won't work on Minolta X-700


changing the batteries have no effect on film transport, just a coincidence. take the bottom cover off and check the white plastic gear on the film take up side of the camera. if it is broken your X700 may not be repairable as no new parts are available.
push the re-wind button in and try to charge the shutter again. remove film first. if it still just goes part way then a gear is stripped. try to find a camera repair shop that may have good used parts available.



Jul 18, 2009 | Minolta Photography

1 Answer

Minolta X-300s film loading problem


Hi -- yes if you cannot advance the transport mechanism ( and so cannot load the film ) this is because shutter is not working ! This a very common problem and is due to leaking capacitor ( 220 microF ) situated on the botttom of the camera. Remove bottom cover and replace the capacitor . You should be able now to release shutter and load your film.

Aug 20, 2008 | Photography

1 Answer

LOADING FILM INTO MY CAMERA


i went to the public library and got a copy of the manual

Apr 05, 2008 | Konica Minolta Maxxum 5 Date with 28-80...

1 Answer

Minolta X370 film loading problem.


Hi, check the camera set in auto /manually in auto function, check battery might drain the current , dis engage camera to lense to release the mirror by pressing button beside lense , turn lense in left or right .

Feb 04, 2008 | Photography

1 Answer

My minolta sightseen camera wont take pictures?


The blinking zero would indicate that the film has not loaded but the cartridge is in place. The camera won't do anything when this occurs. Try opening the film door and load the roll again

Jan 14, 2008 | Photography

1 Answer

Loaded film wrong??


I'm assuming you're not able to shoot pics. Its my best guess that the film just isn't getting loaded properly. Next time you attempt to load film there maybe a small red mark near the take spool (bottom edge where film goes) to indicate how far you need to pull the leader forward toward take up spool. I think the film isn't out quite far enough for the camera to do its auto load thing & when you close the back it goes thru its auto loading motions but the film just isn't getting loaded. Then close back & see what happens.

Apr 27, 2007 | Konica Minolta Maxxum QTsi with 35-80 lens...

Not finding what you are looking for?
Photography Logo

Related Topics:

145 people viewed this question

Ask a Question

Usually answered in minutes!

Top Photography Experts

kakima

Level 3 Expert

98762 Answers

Tony

Level 3 Expert

2598 Answers

Brad Brown

Level 3 Expert

13732 Answers

Are you a Photography Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...