Question about John Deere 420,1020,2010,2020,2510,2520 Tractor Float

1 Answer

Hi, I have an older (1978 + or -) JD 401C diesel . It will start up fine and run for about 5 - 10 min and starts to loose power with no acceleration and eventually die . Let it set for 10 min and it starts up and repeats the same cycle . I have back flushed the lines to the fuel tank , replaced the fuel pump and a new fuel filter. Still does the same thing. I'm beginning to think it's the fuel injector pump. Any ideas ? Thanks , BEE

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

It's a clogged check valve on the return line off the fuel injection pump. Take it apart and clean it out.

Posted on Oct 28, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Pontiac Montana that starts and runs fine for 7-12 min then looses throttle power. Sputters at 1k-2k for 10-15 min then runs fine for 7-15 min then runs even worse, wills sputter at 750+ rpm.


3.4L Engine Sensor Location Pictures and Comments

www.greatautohelp.com/sensor-location/3400-Sensor-Comments-2.html
the battery for a few minutes to see if that helped. ... If the gauge is at half way on the first start, then yes, either the ... All of a sudden I could not accelerate and the carelost power. ... But once the temperature gauge goes to normal it will run fine. ... 3-7-12. I replaced head gaskets and intake gaskets on my 2000 Pontiac 3.4L

[PDF]2000 Pontiac Montana Owners Manual - GM Extended ...


Nov 28, 2015 | 2000 Pontiac Montana

1 Answer

2006 VW GOLF TURBO DIESEL 1.9 STARTS UP GOES 5 TO 9 MILES STALLS WAIT 5 MINUTES GO AGAIN AND STALLS


Hi. It would be useful to get a code read and some live data from a decent diagnostic tool. There are quite a few possible causes including, pressure in tank - if the fuel tank can't vent pressure then a vacuum will eventually form stopping fuel getting to the engine, this will cause it to loose power and stall. Then after a few mins the pressure will drop and the process start again, easy test is when the car stalls remove filler cap - if that's the fault there will be an audible hiss and the car will start up again.

part blocked exhaust will have same problems but will more generally cause a lack of power and acceleration.
are there other symptoms? i.e only when conering or only when pulling off or stopping, engine light on/off. Jon

Dec 18, 2014 | Cars & Trucks

1 Answer

Van has been loosing power going up hill. Runs fine on level land and going downhill. lately it has been stalling when u first start it up.


try checking your crankshaft or tps throttle position sensor it could cause you to lose power at times

Apr 02, 2014 | 2005 Kia Sedona

2 Answers

We think it is the diesel injection pump but not sure


Sounds like not all the glow plugs are working.It should run fairly smooth on a cold start if all of the glow plugs are working..Also you shouldn't drive off on a cold start with a diesel,Its really hard on the motors..At least give them 10 to 15 min on a cold start..The oil in them is a really thick oil and when there drove on a cold start theres no oil lubricating the internal parts and will cause the motor to seize up..You may already no this and dont mean you drive it as soon as you start it i just wanted to let you know..When you get alot of white smoke it could be two things,Theres water in the fuel which will make it not have much power die and smoke..But if it runs fine when its warm theres some bad glow plugs...Hope this helps you and have a great day

Dec 08, 2009 | 2002 Ford F250 Super Duty SuperCab

1 Answer

Running fine on the highway, and loosing acceleration presure


What to you mean loosing acceleration pressure? Also what engine do you have?

3500 is often with the Cummins diesel so I'm going to assume that's what you've got. Diesels loose power like you are describing when the fuel fiter gets plugged. It's is often overlooked, and in many cases not changed frequently enough. As diesels become more and more popular, people that have never owned one before don't realize the extra maintenance they require. A good rule of thumb is to change the fuel filter every other oil change, or more frequently if you suspect dirt or water may have gotten into your tank.

Oct 31, 2009 | 2007 Dodge Ram 3500 Quad Cab Laramie

1 Answer

Lombardini diesel generator starts and runs fine but no elecpower


remove the covering panel and expose the internals , check for loose/disscontected push on ( lucar ) connectors , if these are fine it is most likely the excitation capacitor is deffective , replace with exactly the same value/voltage rating/duty cycle . the capacitor is usual 1 or up to 3 cylindrical tubes with 2 wires comming from them , always take a note of exactly what wires you have taken off :) hope this helps


Oct 19, 2009 | Electrical Supplies

2 Answers

1997 F-350 Ford Powerstroke4x4 Crew Cab Diesel 83k miles. Truck runs fine while cold. When it starts reaching normal operating temp it starts missing and loosing power when accelerating. Truck idles fine....


Have you changed your oil? Rotella 15W-40. These engines really don't like old oil. It becomes too thick for the injection pump to work correctly. Another possibility is a bad cam sensor on the front of the motor. Most engines call this the crank sensor but on this engine you have to look it up as a cam sensor.

Sep 29, 2009 | Ford F-350 Cars & Trucks

1 Answer

What would cause a 1978 suzuki gs750e to loose power?


check the carb and gap on the spark plugs and replace wires and coil

Mar 31, 2009 | 1978 Suzuki GS 750 E

Not finding what you are looking for?
John Deere 420,1020,2010,2020,2510,2520 Tractor Float Logo

435 people viewed this question

Ask a Question

Usually answered in minutes!

Top John Deere Garden Experts

Phil Walker
Phil Walker

Level 3 Expert

608 Answers

Tim Whalen

Level 3 Expert

3074 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

297 Answers

Are you a John Deere Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...