Question about Kenmore 25812 / 25813 Progressive Bagged Canister Vacuum

Open Question

How to fix my kenmore power-mate 12.0 amps motor

How to fix my kenmore power-mate 12.0 amps motor died for the elctric broom

Posted by on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 694 Answers

SOURCE: A piece of string /

Cut the string with a knife or scissors and pull it off. You can turn the brush manually to ensure you get it all.

Posted on Oct 04, 2010

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power mate brush motor not coming on and overload rest not doing anything


I don't believe that there's any penalty for using the proper amount of words to give us a fair idea of what's going on or not, with your machine." Power mate brush motor not coming on" only gives us a bare minimum of info. Does the vac motor run alone, does it still run when you slide the selector to vac & P.M. or does it quit, have you tried pushing the little red reset button down?

Oct 22, 2013 | Kenmore Sears electric vacuum hose models...

1 Answer

The power head of my 1165581590C Kenmore Power mate Whispertone 12 amp vacuum won't open. It is an older model and it desparately needs a clean!


I am not 100% sure of the model number but most of their powerheads come apart quite easily if you know how. There is a light lens cover on the top of your powerhead. On each side of this cover there is a little clip that holds it in place. You can usually see that spot by simply taking your thumb and pushing the light cover to one side or the other. Place a small flat head screwdriver in that slot and gently pry upward.

Once that cover is off, you will see two screws. Remove those two screws. Now simply grab each side of the cover towards the bottom and back of the nozzle and pull out. This should release it from the base. It will lift from forward from back to front..

Reassembly is pretty easy. Just reverse the instructions.

Let me know if this helps.

Dec 30, 2012 | Vacuums

1 Answer

The brush on my Pet Power Mate attachment for my Kenmore isn't spinning. can it be fixed?


In my case the brush was seized on the axle. A wad of pet hair had wrapped one end and melted the plastic roller a little, binding it to the axle. Take the powerhead apart; Pull the white ends off the axle; Push the axle out; ream out the holes in the roller ends with the proper sized drill (#12 or 3/16", I think...close is good enough); Clean any debris out of the roller and steel wool the axle if necessary; Light oil lube job; and reassemble.

Feb 02, 2012 | Kenmore Vacuums

1 Answer

I own a Kenmore vacuum cleaner model # 116. 56550990C. I have lost the instructions to replace the belt in the Power Mate. The Power Mate beater just stopped working and I need instructions on how to...


If unit beater has stopped working it is either the motor, the power connection to beater or the belt that powers the roller. Which is it?

See if you can download the manual from the mfg or google for it.

Sep 05, 2017 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

Good day, I have a EN Vision Dirt Devil upright, 12 amp, wide 15" nozzle. My vacume is blowing out insead of sucking up the dirt from the carpet. Can you help me? What should I do? Thank you...


It's probably the brush "kicking" the dirt out, rather than it being blown out. This happens if there's a clog in the airflow system somewhere. This could be anywhere from the power head above the brush to the tank where the hose connects.
1. Detach hose at both ends. Drop a coin in one end, lift that end up until coin falls out the other end. If it doesn't, there's a blockage that needs to be cleared. You may be able to do this by using a broom handle to push the clog through. Push the broom handle through the power head end.
2. With the hose detached, check the power head connection for blockages. Drop the coin in and see if it drops through. If not, use a wooden spoon handle, or similar blunt object to push the clog back toward the brush, then pull or vacuum it out.
3. Check the filter and make sure it's clean,
4. Remove the dirt catcher and check bottom of holder right above motor. There's a screen here to prevent debris from getting to the motor. Clear any dirt and debris from it.

Try the vacuum and see it this has helped.

Jan 19, 2011 | Dirt Devil Vacuums

1 Answer

A piece of string / cord has wrapped around my Kenmore spinning brush end on the 12 Amp Power - Mate. How is the best way to get the cord off?


Cut the string with a knife or scissors and pull it off. You can turn the brush manually to ensure you get it all.

Oct 03, 2010 | Kenmore 22313 Bagged Canister Vacuum

1 Answer

Canister motor not on - power to power mate is on


if its a long plastic tube with snaps on it that is where the fuse is.open it up and you will find the fuse

Apr 28, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Power head for Kenmore Canister Vac


Another potential problem for the increase in difficulty in turning the beater bar (drum) could stem from extremely dirty bearings, located at each end of the beater bar. I've seen hair knotted up to the point it chokes the bar and significantly reduces its ability tpo turn.

Mar 11, 2009 | Kenmore Whispertone 29512 Vacuum

1 Answer

Model 116 hose clog?


http://geeksquad.fixya.com/ThreadView.aspx?prdid=109459&thid=699656
Model 116 hose clog?
Posted by rfrazelle on Jun 23, 2008
My old canister model 116 followed with numbers 2839580 marked Kenmore 3.9 with power-mate, worked fine until the bag got overly full. I have changed the bag, cleaned the filter, and removed a nasty hair/fur/dust clog :-p from the lower metal tube of the power mate. It now has very weak suction and won't pick up anything. I suspect a clog in the grey plastic flexible tubing attached to the canister but cannot get it apart. Advice?
RJ


Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. Kenmore 22313 Bagged Canister Vacuum. The best way to find a clog in an electric hose is to use a steel ball or a large marble to place inside the hose and to let it so threw as far as it can to determine where the hose clog is. Once you have determined where the hose clog is then you can use a small end of a broom handle of take an old wire coat hanger and place a hook on the end and try to pull the clog out of the electric hose – the electric hose is very expensive so try not to damage the hose in any way, shape or form. Or another way is that id you have another canister vacuum you can try to pull the clog apart by using two vacuums turned on and running. If you are successful then run the round marble or steel ball thru the hose again and the clog should be cleared.

http://www.sears.com/ Customer Service 1-800-4-MY-HOME 1-800-469-4663
Thanks, Don the Vac Man
Go Ahead. Use Us.

Jun 23, 2008 | Kenmore 22313 Bagged Canister Vacuum

1 Answer

Hoover Vacuum Elite (Allergen Filtration) 12 Amp Motor


http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=646648
Generic problem for all Vacuums
Hoover Vacuum Elite (Allergen Filtration) 12 Amps...
Posted by Maya B on Jun 04, 2008
I received this vacuum (Hoover Vacuum Elite/Allergen Filtration 12 Amp Motor) from a friend. After using it in a few rooms it started giving off this burnt odor and the motor starts to sound as if it's dying. What is wrong with it and how can I fix it? If I need to change a part, which one is it and where do I get it from?
I love the suction in this vacuum even though it can be very loud when the attachments are being used. You can email me at fine_wonder@yahoo.com Thanks very much! -Maya


Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. Hoover Vacuum Elite/Allergen Filtration 12 Amp Motor. It certainly sounds like a motor that is on its way to going out or burning out – you can replace the motor and you can get the part from your local vacuum cleaner dealer in your area, either new or used to save money, or you can contact the cust serv dept @ Hoover. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don the Vac Man
Go Ahead. Use Us.

Jun 04, 2008 | Vacuums

Not finding what you are looking for?
Kenmore 25812 / 25813 Progressive Bagged Canister Vacuum Logo

Related Topics:

284 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...