Question about Weber Genesis Silver A Grill

1 Answer

Burner won't turn on

I just hooked a brand new tank to my grill and since then only the front and middle burner fire up, the rear burner doesn't..

Any ideas and no, I'm not handy.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 494 Answers

The first question I have is the flame size good on the 2 burners that did light? If the flames are smaller, then you might just need to turn off the tank and disconnect it, then reconnect it and very slowly turn the tank valve on again. You might have turned the tank valve on too fast causing the excess flow valve to close and only give a trickle of gas through. On the other hand, if the flame size was good on both burners, then your igniter may not be lighting the rear burner, but typically if the other 2 burners light, the 3rd burners lights off the others. Did you try lighting the 3rd burner manually with a lighter to see if it was getting gas? If it lights manually, then the spark igniter may be your problem. It's also possible the rear burner has clogged holes from rust or drippings and is difficult to light. Without seeing it, it's just the process of elimination til it works. Try all those things and see if that gets it going for you. Check out my tips & tricks on gas grill lighting for more detailed info. Click on my user name and scroll down til you find it listed on my profile. Good luck. Douglas

Posted on May 15, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why won't my Weber grill ignite after installing a


Disclaimer- be careful when working with gas. Starters in gas grills are just about novelty anymore. Often, they only light 1/3rd or 1/4th of the burners and they usually stop working within one grilling season. I recommend using a wand lighter. Try to light just one burner but if doesn't light in 5 to 7 seconds, turn the gas off and wait to try again. Incidentally, you are turning the gas on at the tank, right? You should hear it when you turn the burner on.

Apr 24, 2012 | Grilling

1 Answer

I had my charbroil grill for 2 yrs and I now when I turn on the propane tank and ignite, I hear hissing followed by it lighting then flames proceed to come out the front middle burners. Do I need a new...


Before buying anything, look into the burners for spider webs. The webs block gas from getting to the burner and will fire back. This is dangerous. Look carefully where the gas nozzle enters the burner tube.

Gary

Sep 04, 2011 | Char-Broil CharBroil Master Flame Gas...

1 Answer

I have a brand new Weber 670S and put it together....the ignition will fire and I get a 6 inch flame, but the burners don't light....and the flame goes out when I release the knob...


Since the main burners and the rear infrared burner (if so equipped) comes already installed, I don't think your assembling it is the problem. It's probably the grill's gas regulator that is giving you the problem. That's assuming you are following the manual's instructions on how to light the burners, the first time. For now, Ill assume you did. If you open the gas tank valve to fast, it shoots high pressure to the regulator & locks it up.

So, to solve the problem, follow the directions below:

1. Turn the gas tank valve OFF and disconnect the hose from the tank.

2. Wait 5 minutes and reconnect the hose to the tank.

3. Open the tank valve VERY, VERY SLOWLY (Slow motion, slow).

4. Once the tank valve is fully open, light the burner farthest from the tank first and set the burner
control knob on HIGH. Does the flame height look correct for being set on HIGH? If so, light
the remaining burners the same way. Do all the burner flames look correct? If so, you solved
the problem. Remember, to always open the tank valve Very, Very Slowly.

If that didn't solve the problem, you will need to replace the grill's Hose/Regulator Assembly (It's 's not under warranty). It runs about $30.00 at any home center or hardware store that sells grills & accessories. If you replace it, turn the tank valve ON Very, Very Slowly.

Hope this helped you to troubleshoot and solve the problem. Happy Grilling!! And thanks for choosing FixYa.

Aug 26, 2011 | Weber Summit S-670 Gas Grill

1 Answer

When I try to light my brand new Q300, it won't ignite. I can hear that the tank is on and gas is being sent to the grill. However, it doesn't light. When I shut the grill off and the gas tank...


What you have is delayed ignition. It's being caused by the gas regulator. It is solvable, though.

Turn the gas tank valve OFF and disconnect the hose from the tank.

Wait 5 minutes and reconnect the hose to the tank.

Open the tank valve VERY, VERY SLOWLY (Slow motion, slow).

Once the valve is fully open, light 1 burner and turn it to HIGH. Did the burner light and does th eflame height look correct? If so, light the remaining burner the identical same way. Now, to both flame heights look correct? If so, you solved the problem. Remember to always open the tank valve Very, Very Slowly. And always light the burners with the Lid/Hood Open.

If the above did not solve the problem, you will need to replace the Hose/Regulator Assembly. Since your grill is brand new, the Hose/Regulator Assembly will be covered under Warranty. Have your Proof of Purchase handy and call Weber 1-800-446-1071. Also, if you haven't done so already, register your grill before calling http://help.weber.com/register/ even if you don't need a new Hose/Regulator Assembly.

Hope this helped you troubleshoot & solve the problem.

Jul 06, 2011 | Weber Q300 Grill

1 Answer

BBQ galore Turbo 3-burner grill doe not receive gas from propane tank after working fine the day prior. Tried the "disconnect tank and open burners, then burners off and reconnect tank" approach...


Glad to hear you tried the things that have been recommended. However, if you DID NOT open the tank valve VERY, VERY, SLOWLY (Slow motion, slow), there's the problem. Try it all over again, and this time open the tank valve, as I just described. Also, allow 5 minutes before reconnecting it to the tank.

If this doesn't solve the problem, you will need to purchase a new Regulator/Hose Assembly, as yours appears to be permanently locked up. They run about $30.00 at any home center or hardware store that sells gas grills and accessories. Take you old one with you for comparison purposes. After you install the new one, remember to always turn the gas valve ON very, very, slowly.

Hope this helped you and Happy Grilling.

Jun 20, 2011 | Barbeques Galore Turbo STS 4-Burner with...

1 Answer

Brinkman gas grill won't start. Don't hear clicking sound. Hooked up new gas tank, but no success


Victor, are you sure you're getting gas to the burners after installing the new tank? You can try match lighting them to make sure. But, I suspect, that it's the installation of the new tank, that's causing the problem.

To test my theory, tune the tank valve OFF and disconnect the hose from the tank. Wait 5 minutes and reconnect the hose to the tank. Ope the tank valve VERY, VERY SLOWLY (Slow motion, slow). Once the valve is fully open, try lighting the burner that's farthest from the tank first and turn it to high. Did the burner light and does the flame height look correct? If so, light the remaining 3 main burners the same way. Did those burners light and the flame heights looks correct? If, so you solved the problem. Remember to always turn the tank valve ON VERY, VERY SLOWLY.

Hope this helped you solve the problem. Happy Grilling.

Jun 01, 2011 | Brinkmann 810-8410-S Stainless Steel...

1 Answer

Have a 15 year old Weber Genesis. Recently filled the tank, and was working fine. Today, went to fire it up and barely any flame coming out of the burners. In fact, when I turn on the middle burner, the...


You need to completely change the grill because it's been there for over 15years and alot of rust and linkages will after affected the grill from working properly well.The best bet is to get a new grill.

Nov 25, 2010 | Weber Genesis Silver B Grill

1 Answer

My grill does not exceed 300 degrees. The rear burner is barely lit, it sputters with a blue flame. The Front and middle burners run well, blue flame no yellow. I changed the regulator with one from home...


Bypass valve need reset. All grills made after 1996 have this valve.
  • Close the LP tank valve
  • Turn all burner control knobs to the OFF position
  • Open the grill lid
  • Turn the LP tank valve until it is completely open
  • Wait 90 seconds
  • Turn the front burner to the HI/Start position
  • Press the igniter until the burner is lit.
  • Turn remaining burners to High
  • Close the lid.
  • The grill should preheat to 500-550 degrees in 10-15 minutes
I called Weber and a rep walk me through it.

Jul 08, 2009 | Weber Genesis E-310 Gas Grill

1 Answer

Problem with gas getting to the front burner


Follow manufacturer's recommendation in resetting the excess flow safety device....(Turn burners and LP cylinder off...Disconnect regulator on cylinder. Turn both knobs to high for at least one minute...Then turn them to off...reconnect the regulator to the LP tank...Turn LP valve VERY slowly (30 seconds) until fully opened..then start the grill in the usual manner. ALWAYS TURN THE LP TANK OFF WHEN DONE USING THE GRILL....

Jul 04, 2009 | Weber Genesis Silver B Grill

Not finding what you are looking for?
Weber Genesis Silver A Grill Logo

295 people viewed this question

Ask a Question

Usually answered in minutes!

Top Weber Grilling Experts

paulcarew

Level 3 Expert

2464 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Treefrog15
Treefrog15

Level 2 Expert

127 Answers

Are you a Weber Grilling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...