Question about Car Audio & Video

1 Answer

My lighting audio b4.250.2 arnt turning on

So i hooked up my lighting audio b4.250.2 amplifiers to my subs and it was working for a day. Then the next day i had to jump my car because i left the battery on and now the amps arnt working. It is getting pwer to the amps but the amps arnt turning on. I also changed the fuses but its still not turning on. I dont know what wrong with it

Posted by Anonymous on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

You burnt them by jumping cables

Posted on May 14, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subs wont turn on


make sure there is correct wattage with the subwoofers and the power supply

Dec 07, 2013 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

My lighting audio b4.250.2 arnt turning on


if u r in the Tallahassee,FL area,call 850-339-1130,we repair all name brands of car audio Capital Audio & Electronics Repair

Mar 19, 2010 | Car Audio & Video

1 Answer

1000 w sony xplode works at low volume then red lights at volume5


Most likely one of your subs are blown, or the Ohm's are too low for the ampliphier. Try hooking up one speaker at a time to the amp and see if it does the same thing. If it shuts off on one of the two speakers, that speaker is most likely blown.

Apr 19, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Protect light


Does the amplifier do this when you don't have the sub hooked to it? If so, you have a pinch/short in your ground or power wire. If not, the subwoofer has a short in its voice coil or the amplifier needs to be repaired as it cannot handle a typical load.

Dec 29, 2008 | MA Audio HK401SX Car Audio Amplifier

1 Answer

Amp Not working!


If the amp goes into protect mode, it's likely due to shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

If the problems are not with the wiring, follow the link at the bottom of the page to the Amplifier Repair Primer page.

Let me know if you have any other questions.

Sep 20, 2008 | Power Acoustik TS620-2 Synchronized...

1 Answer

I plugged int he rca's but he the lowest sounding bass possibe


kicker subs arnt ment to hit the lowest bass, unless you go spend a **** load of money, im talking 3000 wat amp, ant some 15' or bigger subs. the most commen kickers are 12' subs, so im asuming you have 12' subs, if not, this (said lightly) should work. try turning the bass boost screw on the amp to the middle of its turning range. this will offer the greatest balance between high and low bass. if you want more low bass, turn it past half. if you want more high bass, turn it down. i have mine set to mid range, but i also recently purchased 2 18' kickers. with every new set of subs, you should spend at least 15 min tuning the amp to get the best performance. every sub is different. hope this helps, good luck.

Jun 27, 2008 | Kicker KX800.2 Car Audio Amplifier

1 Answer

Car audio


hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...