Question about Creative Labs I-Trigue 2.1 3300 Computer Speakers

2 Answers

Sub works, left speaker works nothing out of right speaker, switched speakers around then right plays but no left??? computer, I-pod- symptoms consistant???

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Naw, just reverse the silver connection from computer to box. works every time.

Posted on Jan 06, 2012

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had a same problem.Left speaker with no voice.Fallowing solution worked for me.
Disconnect the sub's electric first.Loosen 4 screws ant pull out the control unit slowly.Be careful, it is tight.Then you will see the big aluminium cooler.Carefully squeeze the two parallel arms between a finger and thumb to bend and get closer them about half mm.Then connect the plugs and play an mp3 to control.If it is ok, replace the control unit and tighten the secrews.

Posted on Jul 19, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Change main fuse but still not working right


First of all, nothing wrong with the fuse. A fuse is nothing but a short piece of wire with a resistance value. If the unit turns on, fuse is fine. The fact that the headphones you plugged in are working tells you that the music is finding it's way up to that point. You must realize that the speakers themselves have additional circuitry that the headphones don't use. If you could obtain a diagram for the circuitry you might find that a capacitor or a diode or a transistor got "zapped" when the high voltage was applied.
If you have this diagram and you don't know what component is defective, can you post that diagram and I would be glad to help!

Mar 02, 2014 | Bose Audio Players & Recorders

1 Answer

Fader/sub/speaker not working properly


I'm not an expert but often people connect subs to normal speaker wires in back of the radio. You need a dedicated subwoofer line so high frequency sound doesn't go to the subs. Only bass. Sounds like it wasn't wired properly.

Aug 26, 2017 | Pioneer DEH-P6000UB Car CD/ MP3 Player

1 Answer

Hi, I had some speakers and the 3.5mm audio jack wire that connects them into inputs had gone funny. You had to bend it into a sweet spot to get both speakers working otherwise only the left one would...


sounds like you bent the wire so that the wiring could actually make a contact, thus your speakers would work. Sounds like the contact is now broken which is probably a solder joint. You can remove the sleeve and you will see the issue. All you should have to do is resolder the connection and you will be done.

Apr 12, 2011 | Audio Players & Recorders

1 Answer

RIght speaker not working in speaker system. Switching the left with right speaker make the right speaker work (not speaker) Plugging the 2 RCA into a different input changes nothing. 2 rear speakers...


Let's name the product and use FM for troubleshooting. Are you saying you have the Right Front and both rear amp channels/speakers not working? What DOES work?

Jan 17, 2011 | JVC Audio Players & Recorders

1 Answer

Only one speaker plays and the sub plays , you can change the sound level left to right and only a little bit comes out , and the problem is with the right one


I fixed the same issue by turning the speakers off at the sub, then back on again. Not a permanent fix though, my left speaker has stopped completely now

Oct 23, 2010 | Sony SRS-D21 Computer Speakers

2 Answers

I have creative 2.1 channel with sub woofer and 2 speakers (left&right) all of sudden my right speaker is not working left only working then I pluggeg right speaker to left speaker jack in sub...


I have a similar reoccuring problem with the left channel on my speakers. All of a sudden, while playing music or whatever, the left channel jusr dies. Turning the system off and then on again from the conrol unit does not remedy the situation. By chance, I discovered a workaround to get the left channel working again: Push the main power switch of the subwoofer until it almost switches off and then release it so that the power is never actually switched off. Now a click is heard in the system and the left channel comes alive again. This is quite annoying and seems to have something to do with switches in the subwoofer. Low quality components may have been used. I 've been thinking of getting another 2.1 system, but it's not easy to find one... Maybe I should open the subwoofer box and go through the switches and possibly hardwire some connections...

Jun 27, 2010 | Creative Labs MegaWorks THX 250D Computer...

1 Answer

Logitech Z-5300 subwoofer from computer to i-pod problem...


The best thing to do is to contact the manufacturers. From this i understood that your speaker system is new. You surely have the manufacturer's guarantee. So its better to contact them than to get it repaired or replaced for free. Sir please do not try to open the sub as it will void the guarantee policy.

Hope your subs come into play as soon as possible.......
All the best...

Jan 05, 2010 | Logitech Z-5300e Surround Sound System...

2 Answers

Logic X530


i have the same speakers...just right click on the speaker icon on the lower right hand side of your desktop. then click on playing devices then configuration and see if the speaker is in surround mode.

Apr 07, 2009 | Logitech X-530 Computer Speakers

1 Answer

Little sound out of left satellite in Logitech S200 2.1-system.


Try plugging in some headphones to the right satellite, unplugging them and turning the speakers off and on. This worked for me, and is probably the switch getting stuck between headphones & normal speakers.

Mar 30, 2009 | Logitech Audio Players & Recorders

1 Answer

Strange problems with Z-2300's


I'm having this same problem and have sort of solved it with a really wierd technique I found at Logitech. Evidently this problem is related to the control pod rather then the RCA jack. Try this:

Unplug the control pod from the subwoofer Turn off the main switch Turn the volume knob one full turn, tap the knob Repeat again (2 times) Replug the control pod Turn on the main switch and the control pod See what happens

I found that this got the speaker working finicky after it was almost totally useless. It seems to be cutting out randomly, but fidgeting with the control pod or it's connector jack fixes it. No clue what the deal is here, but your problem is identical to mine so take some time to screw around with these components with music running so you can hear if it suddenly works.

Nov 12, 2008 | Logitech Z-2300 Computer Speakers

Not finding what you are looking for?
Creative Labs I-Trigue 2.1 3300 Computer Speakers Logo

Related Topics:

182 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

618 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Brad Brown

Level 3 Expert

15729 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...