Question about Kitchen Appliances - Others

Open Question

I have a Bionaire Steam Mop, Model SM-02. The water appears to be heating up, but no steam comes out. It was purchased at Macy's last spring for limited use in a summer cottage. So, it's less than a year old and has only been used a half dozen times. It worked with no problems last summer, but when turned on the first time this summer, it failed to make steam. When plugged in, the light comes on green. The water container is up to the fill line. You can hear and feel the water heating up, but then no steam comes out of it. Unfortunately, I cannot locate the instruction manual so that's no help. Any suggestions?

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: I have a Bionaire Steam

Solition: 1 tbsp of vinegar in the 1 cup of water added to mop reservoir

I purchased my Bionaire steam mop in Nov. 2010 but did not try it out until just recently (Mar. 2011) - and had the exact same problem as you... green light on, base feels warm, sounds like it's working, but no steam coming out.

I called Bionaire customer service and the lady there told me to try adding 1 tablespoon of vinegar to the 1 cup of water that you put in the mop. Then she said to leave the mop plugged-in (but not switched on) for about 30 minutes; so the green light is on; then to turn the switch to "on". I did this and, when I switched it on, it still did not produce steam. In frustration, I unplugged it and left the mop (with the water/vinegar mixture still in it) sitting upright for two days. After the two days, I was just about to empty the mixture out of the mop and thought I would try it one more time... and IT WORKED!!!

I hope this solution works for you, too!

Posted on Mar 28, 2011

  • 1 Answer

SOURCE: I have a Bionaire Steam Mop, Model SM-02. The

John:
My daughter has one of these and has the same problem. Does the body of the steamer (where the motor is located on yours) get really warm ? I took this one apart,and could find nothing visual wrong,but the motor itself was so hot that I couldn't touch it.The motor does make sounds even though it isn't supposed to after it has been running for a few seconds, but I don't think that it's turning.and no steam emits,so I suspect that is the problem. All the water hoses were clear,so I suspect that the motor will have to be replaced.It did work once and puffed steam out but not enough to do anything.

Posted on Oct 31, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where can i buy mop pads for star elite model sm-05 item 400041


It looks like they may be someone "generic" as I found lots of similar "triangle shaped" pads for many different brands on ebay and amazon (.com)

Jun 16, 2014 | Star Elite Bionaire Steam Mop

1 Answer

NO STEAM COMING FROM MOP MODEL SM-02


Check for power at the element that heats the water. If you have power there then the element is malfunction

Mar 13, 2012 | Vacuums

1 Answer

I have a Bionaire Steam Mop, Model SM-02. The water appears to be heating up, but no steam comes out. Green light is on


John:
My daughter has one of these and has the same problem. Does the body of the steamer (where the motor is located on yours) get really warm ? I took this one apart,and could find nothing visual wrong,but the motor itself was so hot that I couldn't touch it.The motor does make sounds even though it isn't supposed to after it has been running for a few seconds, but I don't think that it's turning.and no steam emits,so I suspect that is the problem. All the water hoses were clear,so I suspect that the motor will have to be replaced.It did work once and puffed steam out but not enough to do anything.

Oct 15, 2011 | Kitchen Appliances - Others

1 Answer

I have the Shark Steam Mop, Model number 120544 (gold case) purchased at Costco in April 2010. The water heats up to steam, but never reaches the cleaning heads; water drips out of the handle to the...




Hi,

Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it may not be getting steam to the head...

Euro-Pro Shark Steam Mop Problem

Here also is a link to get any of the
Shark Manuals that you need.

heatman101

[[]-==-

Feb 12, 2011 | Euro-Pro Shark Steam Mop - Gray/ Purple...

3 Answers

I have a Bionaire Steam Mop, Model SM-02. The water appears to be heating up, but no steam comes out. It was purchased at Macy's last spring for limited use in a summer cottage. So, it's less than...


Solition: 1 tbsp of vinegar in the 1 cup of water added to mop reservoir

I purchased my Bionaire steam mop in Nov. 2010 but did not try it out until just recently (Mar. 2011) - and had the exact same problem as you... green light on, base feels warm, sounds like it's working, but no steam coming out.

I called Bionaire customer service and the lady there told me to try adding 1 tablespoon of vinegar to the 1 cup of water that you put in the mop. Then she said to leave the mop plugged-in (but not switched on) for about 30 minutes; so the green light is on; then to turn the switch to "on". I did this and, when I switched it on, it still did not produce steam. In frustration, I unplugged it and left the mop (with the water/vinegar mixture still in it) sitting upright for two days. After the two days, I was just about to empty the mixture out of the mop and thought I would try it one more time... and IT WORKED!!!

I hope this solution works for you, too!

Nov 02, 2010 | Kitchen Ranges

2 Answers

Shark Steam Mop - Gray/ Purple Vacuum: shark steam mop has water, but there is no steam....


I tried running vinegar through as you would a coffee pot to get rid of hard water scales. This did not work. Then I noticed that the light behind the shark decal on the front of the machine was going off and on. And sure enough as I moved the cord around the light would come off and on. Looking closer I could see the the heat had melted thru some of the cord.I bought mine at Target before xmas last year, throwing away the sales slip after several months so I guess there is nothing I can do about it.

May 18, 2010 | Euro-Pro Shark Steam Mop - Gray/ Purple...

1 Answer

Shark steam mop


Hi,

Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head...

Euro-Pro Shark Steam Mop Problem

Here also is a link to get any of the Shark Manuals that you need.

heatman101

ab

May 29, 2009 | Euro-Pro Shark Steam Mop - Gray/ Purple...

Not finding what you are looking for?
Kitchen Appliances - Others Logo

Related Topics:

732 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kitchen Appliances - Others Experts

Angel Joseph Jr.
Angel Joseph Jr.

Level 2 Expert

683 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Are you a Kitchen Appliances - Other Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...