Question about Skull Candy Skullcrushers Headphones

1 Answer

The cord conecting the headphones to the bass amplifier came out how do i fix that?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Skull Candy Master
  • 5,011 Answers

See my tip on replacing dodgy/cables and plugs on headphones.

Posted on May 14, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Turn down mega bass


test the amplifier.God bless you
t is overheating due to power issues. Check your power ratings to be sure they match the amplifier's specifications. There is a problem with the amplifier. If the power ratings are correct, the amplifier needs to be sent to a service center.

Nov 04, 2013 | Sony Walkman Portable Md Minidisc Mz-r70...

1 Answer

Urban Beatz headphones


OPEN UP THE EAR PIECE OF THE HEADPHONES N MAKE SURE THE WIRES STILL HAVE A CONECTION TO THE SPEAKERS IF THATS NOT THE PROBLEM ITS PROBABLY THE WIRES INSIDE THE CORD ARE BROKEN,GOOD LUCK FINDING THAT BREAK!

Jun 16, 2013 | Audio Players & Recorders

2 Answers

I've recently bought a pair of WESC conga headphones which comes with 2 extension cables. The first is long and the second is really short and when i use it while listening to my music it makes the...


i had the exact same problem but i just removed the smallest extension cord its like only a few centimeters :P after that the sound got clear without having 2 use the button

Aug 21, 2011 | Wesc Conga Headphones

1 Answer

Hey, I have a problem with my soundsystem Logytech Z4 and I would like to know if you can help me? The following problem occurs: The black control panel, where I can adjust the volume and bass has a...


Sounds like (no pun intended) the amplifier circuit in the speaker is bad. When you use the headphone the amplifier is not used - only the preamp. It will need repair.

Nov 25, 2010 | Logitech Z4 Speakers

1 Answer

The plug at the end of the headphone is wearing out


I don't know if this might help, but see my tip on replacing dodgy cable and plugs on headphones.

May 24, 2010 | Grado RS2 Professional Headphones

1 Answer

Skullcrusher Bass not working.


You might want to check out my tip on replacing dodgy cable/plugs on headphones.

May 13, 2010 | Skull Candy Skullcrushers Headphones

1 Answer

Amp slow to kick bass in.


it sounds like you havnt got the memory live conected on your hea duit or it is conected to an ignition live this is no good it needs to be conected to a permenent live to ensure the memory has power at all ties of it coulb be that the amp needs adjusting for low volume use
to set up a sub you turn up the volume to the required level then adjust the amp acordingly hope this helps ben

Oct 11, 2009 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Bass amplifier doesn't work even when i switched the batteries.


The bass unit must be defective. Talk to the guys at Skullcandy for a replacement (they offer lifetime warranties for stuff like this).
Their website has a link directly to the warranty page as well: www.skullcandy.com/warranty

Hope this helps

Apr 14, 2009 | Skull Candy Skullcrushers Headset

1 Answer

Perfect ten bass amp, guitar


can you use headphones? if so do they sound normal. probably have bad filter caps. 2200uf caps big ones, go bad and lose their capacitance and cant process the low end notes, sounds like a motorboat or ******* out. speaker may have issues as well. get the caps from mouser.com and careful of stored voltage on the capacitors it is deadly....... those caps are less than 2 bucks each.

Jan 21, 2009 | Ashdown Perfect 10 Bass Combo Amp Car...

1 Answer

Loss of Bass


Hi there, I would think that you have blown your bass drivers in the speakers. Sometime you may have a fuse which is blown in the speaker but this is not usual. Try on another speaker if you can.

Sep 25, 2007 | NAD C370 2-Channel Amplifier

Not finding what you are looking for?
Skull Candy Skullcrushers Headphones Logo

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Skull Candy Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

Owen Barnes

Level 3 Expert

867 Answers

vimal
vimal

Level 3 Expert

340 Answers

Are you a Skull Candy Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...