Question about Lanzar (Pair) MAXP104D Max Pro Series 1200W 10" Subwoofers Car Speaker

1 Answer

Subs wont work or do anything when hooked up - Lanzar (Pair) MAXP104D Max Pro Series 1200W 10" Subwoofers Car Speaker

Posted by Anonymous on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 3 Answers

Check your safe light on your amp if it's green then the subs are **** but if you don't have a green light check your ground, just because it sparks when it touches dosen't mean it's a good ground so grind the paint off the bolt if need be. If all else fails get new subs, do your self a favor don't get lanzar products there horrible trust me on that one

Posted on Jun 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just needed some help with wiring my p8002 rockford amp to 2 fosgate 10 inch subs i just bought. there 4 ohms a piece and dual voice coil. i dont know much about car stereos but people keep telling me...


Well i tried looking up that amp, but Fosgate sight is down. So assuming that the best power out of your amp is 2ohms off the bridged hookup, and the subs are 4 ohms per coil, the best way is to only use one side of each speaker and hook it straight the the bridge. Only using one hook up wont hurt anything, its just for giving you wiring options. And when adding up ohms of speakers, it goes like this. If you had two 4 ohm subs, that'll give you a 2 ohm load. If you hooked up all your hookups, it would be like having four 4 ohm subs, and would give you a 1 ohm load.

judd0081.jpg

Jan 19, 2011 | Car Audio & Video

1 Answer

What would be the best amp to push 2 kicker 15 L7s


find the ohms on each subwoofer and how much it can handle. If you have two 4 ohm subs get a powerful MONO AMP and hook it up in parallal. If you have two 2 ohm subs get a (1 ohm stable) Powerful MONO AMP and hook it up in parallel or a powerful 2 CHANNEL AMP but the wiring can be a little complicated cause you've got to connect the subs in series and bridge it on the positive of 1 channel and the negative of 2nd channel for maximium benefit without burning out the 2 channel amp. If you got two 500 Watt subs then you got to find an amp that can put out 1000Watts anything less wont sound good and may burn out the subs because of too much distortion cause of lack of power.

Apr 06, 2010 | Phoenix Digital PD-397 Car Amp

1 Answer

Hooked up subs in my 07 tahoe radio plays but truck wont start


when you turn off the radio and subs does the car start?

do other things work in the car like headlights indicators brake lights

i sugest you turn off the radio and start car or unplug the subs from the battery and try


Dec 31, 2009 | 2007 Chevrolet Tahoe

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Subs will not work right.


the subs coils are melted and shorting out so the amp shuts off

Apr 22, 2009 | AudioBahn AW1206T Car Subwoofer

1 Answer

Car amp has power but will not push subs


output blown on power supply - repair by tech required.

Jan 12, 2009 | Sony XM-SD22X Car Audio Amplifier

1 Answer

Troubleshooting in car cd player


that is very strange but it could be that when you put the cd in the radio it maybe sending out a quick shot of amplified power I would try disconecting the subs put in a cd let it play a little then plug the subs in while the cd is playing and see if they work if this works you may to get a new radio or put in a switch to turn the subs off or some type of momentary circuit breaker I'm just trying to help I never saw anything like that before good luck........

Nov 06, 2008 | Sony Xplod CD Player w/MP3 Playback...

1 Answer

Subwoofer Output Not Working...


first check that the subwoofer function on the actual head unit is turned up,second check that the gain on the amp is at bout half way then check that it is on a lp (low pass setting)
then check that the boost on the amp is turned up.
please leave feedback.
cheers

Jul 02, 2008 | Eclipse CD5405

1 Answer

Subwoofer Output Not Working...


The first thing to try is disconnecting ONE of the two subs. See if you get more bass with a single sub than with both. If you do, re-connect the second subwoofer, but reverse the (+) and (-) wires.

Jun 19, 2007 | Panasonic MXE CQ-C7401U CD Player

Not finding what you are looking for?
Lanzar (Pair) MAXP104D Max Pro Series 1200W 10" Subwoofers Car Speaker Logo

Related Topics:

116 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

Chris Ward

Level 2 Expert

158 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...