Question about Jacuzzi - Bathtub - Alcove - Navona - R105917

1 Answer

Jacuzzi Bathtup pump issues

The pump to our Jacuzzi bathtub is failing to operate. When it is turned on the pump just makes buzzing sound and if left on too long the breaker for the pump kicks off. There is no access panel to the pump so there is no way of get to it without cutting a hole.

Currently the tub is full of water and we are going to let it sit with the water in it or an hour our so to see if this will loosen anything up.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Jacuzzi Master
  • 717 Answers

Buzzing sound on a motor means it has almost burned out. you will need to replace the pump.

Posted on Sep 06, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Jacuzzi tub will only turn off if tub is empty


This sounds like maybe you have a bad circuit on the control that turns the pump on/off.
Get the model number off the control box under the tub and let me know what it is and we can solve that issue for you.

Rod
US Parts Center
888-521-6183

May 03, 2014 | Jacuzzi EH0 / EH1 / EG9 Fuzion 6666 Corner...

1 Answer

The wall switch control for the Jacuzzi bathtub was left on for at least one week. Now the motor for the whirlpool bath will not operate. Could the motor have burned out? Tripping the reset switch did not...


pretty much bet on the fact that the pump has burned out. You are very lucky it did not set your house on fire. There is much friction when the pump is on and there is no water in the wet end to keep the seal cool. You will need a new pump. What model pump do you have? Find your Pump

Aug 15, 2011 | Jacuzzi Home

1 Answer

My jacuzzi bath tub makes a humming noise when I turn it on, but it will not operate. I tried again later, and still nothing, and not even the hum now.


Pump was humming, suspect air lock, pump could of burnt out, check power to pump and if it blows fuses then you will need a new pump and don't forget to bleed the pump

Jul 16, 2011 | Jacuzzi Home

1 Answer

I have a whirlpool jacuzzi tub. I wired to diagram but when tub is full and I turn on jets it trips a breaker. Not GFCI outlet but breaker panel breaker.


Sounds like you may not have a ground on the motor of the pump or a grounded outlet?
check the wiring on the motor on the cord to make sure there are no wires improperly attached inside the motor housing.

Jan 07, 2011 | Jacuzzi Amiga, Soaking Bathtub with...

1 Answer

What causes my jacuzzi hot tub to turn itself on.


sounds like you have an electronic system that operates the tub. Many times those get hit with a voltage spike and it burns up a relay on the circuit board and THAT is what make them come on at weird times.
You will most likely need a new control for your tub.

Jan 04, 2011 | Whirlpool 5' Jacuzzi Tub Bathtub Cetra...

1 Answer

My jacuzzi bath making a beeping sound and not working why would this be?


this sounds like a low water issue. Check the low water sensor on the bathtub and make sure it is attached and working.

Jan 02, 2011 | Jacuzzi Home

1 Answer

Jacuzzi whirlpool bath not working when i turn it on i get a buzzing sound


buzzing sounds tend to be a motor problem. You may need to change the pump. When you turn it on it just buzzes? that indicates a bad motor.

Dec 20, 2010 | Whirlpool 5' Jacuzzi Tub Bathtub Cetra...

1 Answer

We have a new Jacuzzi tub and went to turn it on


check to make sure the pumps on and that its wired correctly and that all valves are open.

Feb 22, 2010 | Whirlpool 5' Jacuzzi Tub Bathtub Cetra...

2 Answers

Heater pump does not turn on Jacuzzi hot tub 325


You should be getting error messages like flo or FLO2. check the voltage to the pump from the board if power is there the pump is bad and needs replacing

Jun 12, 2009 | Jacuzzi Amiga, Soaking Bathtub with...

1 Answer

Rapid Heater for Jacuzzi


The light is supposed to be on when the tub is full of water and the pump comes on. Make sure the heater is plugged into a seperate breaker, it cannot be on the same line as the pump.
Look on the heater for a label. If your heater is installed on the discharge side of the pump it should say "pressure heater" on it. If it is installed in front of the pump it should say "Vacuum Heater" on it.
Once installed, fill the tub with water and turn the pump on. If it is installed in the correct position the light will come on when the pump turns on.

Feb 22, 2009 | Jacuzzi RapidHeat In-Line Heater U395000 [...

Not finding what you are looking for?
Jacuzzi - Bathtub - Alcove - Navona - R105917 Logo

201 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jacuzzi Home Experts

Mike

Level 3 Expert

4340 Answers

john h

Level 3 Expert

12173 Answers

Donni Steen

Level 3 Expert

659 Answers

Are you a Jacuzzi Home Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...