Question about NAD C370 2-Channel Amplifier

1 Answer

No power at all

Checked the plug socket fuse thats ok. think it could be the internal fuse but i can not locate it

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 311 Answers

Im guessing you have opened up the case of the amplifer

look in the area where the ac plug plugs into the box.

you may have to remove some of the boards to get to it

the main internal fuse should be next to the place where you attach the ac plug

also check the main wire wires that go into the main board from the power supply check for voltage

Posted on May 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Lux-32-914-idtv my tv has no power and is not the fuse what could it be?


Check the plug wires are tight in there connections, plug something else in the socket to make sure socket is ok, otherwise its a telly technician for internal fuse.

Mar 29, 2014 | Televison & Video

1 Answer

Cannot locate internal fuse in my Toshiba 32DV504B


Contact any service technician. The fuse can be located at its main power supply regulator board itself. If you wish to get some details; check the site linked here. Viewing it in "Mosaic" will make surf easy.
http://electronicshelponline.blogspot.com/

Mar 16, 2014 | Toshiba Televison & Video

3 Answers

Old uniden cb radio. i have plugged it in and i know i'm getting power through the cigarette lighter, but no power when i turn on the radio. no lights, no sound, nothing. please help. any ideas?


Hello there
There is a internal fuse on the inside of the unit that might need to be replaced and also check the fuse that is in the power cord ok?
best regards michel

Sep 14, 2009 | Uniden Radio Communications

1 Answer

Power cord is plugged in, but low battery display is on and then it shuts off.


first check and make sure the socket in the car is getting power, like trying your phone charger or something similar. if its not, locate the fuse in the car and see if its ok. if its ok check the fuse for the charger, most are in the tip that gets plugged in to the car. most can be removed by screwing the tip off. if the fuse is ok, then there is probably a problem with the gps.

Aug 29, 2009 | GPS

1 Answer

No power when i plug it up !


HI, check to make sure the wall socket is live by, plugging another device into the socket. if the socket is live, this will confirm a internal issue that concerns the power sector of the unit.

Contact pyle for this repair.

***In some model, there will be an In-Line fuse located inside the unit on the power board or transformer. replacing this fuse(if installed), may fix this issue.(uncommon)

Jun 22, 2009 | Pyle Audio Players & Recorders

1 Answer

No power


check the wall socket power(with tester), if all is ok there then check power cable (use your computer's power cable to test).

If still its cold then most likely its internal fuse has blown or some issue in its power section.
get hold of a experienced hand to quickly check the fuse first.

May 30, 2009 | Lexmark X83 All-In-One InkJet Printer

1 Answer

NO power, no lights, possibly there was a flash before it went of


The internal fuse is normally located very near the power plug socket and usually a Buss glass fuse, rated 5 amps? If you get to it, check the metal end for the rating.You have to remove the top cover to get at it...remember, the problem could be the fuse--or the power supply section has failed.--Rick

Feb 16, 2009 | Hitachi Performa CP-RS55 Multimedia...

3 Answers

Loud Bang and Projector no londger works


If the internal fuse has blown, if you connect the power lead loosely and move it about, you should not be able to hear any crackling sound of electricity. If you do then it is more likely something else other that the internal fuse. Generally, a loud bang is either the fuse or lamp.

Sep 25, 2008 | 3M MP 8749 Multimedia Projector

1 Answer

Hotpoint ultima WT9 60


the internal circuit board has come loose, switch off power take the top off and tighten the connections on the plugs inside

Feb 01, 2008 | Hotpoint Ultima WF860 Front Load Washer

Not finding what you are looking for?
NAD C370 2-Channel Amplifier Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5151 Answers

The Knight
The Knight

Level 3 Expert

74383 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...