Question about Power Acoustik TS620-2 Car Audio Amplifier

1 Answer

I have a power acoustik Ts-620 and whenever i turn on the car and the subs are wired up, it makes the subs pump back and forth. Some people said It was my ground, but ive hooked it up in 2 cars and its done the same thing. Nothing looks burnt or wrong when i took it apart. What is wrong with it?

Posted by on

  • soopsnoop May 11, 2010

    check to see if the connections at each woofer internally meaning on the woofer not the box but check box as well. what your checking for is correct polarity positve wire to positive and negative to negative.. when you have two woofers in the same box and one of the woofers is wired backwards from the other one you get the push and pull effect. this is some times good when sharing a small air space. can create more bass.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Power Acoustik Master
  • 2,226 Answers

Try running a wire from ground to the shielding of your rca's .

Posted on May 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subwoofer making static noise


first of all,do u have the strip wire in the red which is the hot side of the sub,next if that doesn't fix it u need to change ur spark plugs they will interfere when the engine is running,so call ur local auto parts dealer and ask for spark plugs that don't interfere with the radio.Hope this helps

Apr 03, 2013 | Power Acoustik Car Audio & Video

1 Answer

I have a power acoustik ibm12000d amp had it installed to weeks ago wired at one ohm to a 15inch acoustik p3 sub worked good for to weeks hit good and everything but now its cutting off when turned up I...


Sounds like an over current condition. Your sub may be the problem. Does it go into protect mode when it cuts out? remove the sub and turn up the volume and see if it cuts out when you keep increasing the volume. If not, then it may be that the sub shorts out when turned up too much, kicking the amp into protect mode. If it still cuts out, then it may be the amp. Try another sub if you have one or borrow one from a friend.

Aug 06, 2011 | Power Acoustik OVN1-2000D 1-Channel Car...

1 Answer

My 620 watt power acoustik amp is on protect mode for some reason, and it is ran to two 10" subs. i need help?


this is usually an anti theft precaution taken where if the amp is tampered or attempted to be stolen it will shut down making it useless for the thief the only way to get them unlocked is usually by the people whom installed it for you or the manufacturer

Dec 19, 2010 | Power Acoustik TS1440-2 Car Audio...

1 Answer

I have a power acoustik bamf 1600/4. not working 5 hours later


use a multimeter to see if the amp has good power wire and remote turn on voltage. then check the ground and make sure its a good strong ground. check the sub to make sure its not bad. make sure it reads whatever ohm its supposed to. anything less than 4 ohms will clip the amp if bridged. if alll that is good then the only thing left is the amp. it sounds like the power supply is bad but check everything else just to make sure. good luck.

Dec 29, 2009 | Power Acoustik BAMF1600/4 Car Amp

1 Answer

I have 2 15''s dual voice coil and i need to know how to wire them to my power acoustik bamf 4000 in a 1 ohm


most car-audio subs are rated at 4 ohms, as opposed to home audio's 6-8 ohms. If you have a pair of 4 ohm subs, wire all 4 positive terminals to the positive terminal on the amp and the sam with the negative sides. The key is to use the same length of wire on all connections.

Apr 28, 2009 | Power Acoustik BAMF4000/1D Car Amp

1 Answer

How do i wire two 15 inch subs to 2 ohms


Hello familia_gome,

Those MOFO-15's have dual 1ω voice coils. So the only way you can get 2 of them to present a 2ω load is to use 1 voice coil on each one with the two of them wired in series. Using both voice coils, you can get a 1/4ω load by wiring the voice coils in parallel and then wiring the subs themselves in parallel. You'll get a 1ω load with the voice coils in series and then parallel the subs. Or you'll get a 4ω load with both the voice coils and the subs in series.

Here's a link to Power Acoustik's PDF for the MOFO's. I recommend that you check out the wiring diagrams on page 3.

http://www.poweracoustik.com/SUPPORT/MANUALS/PA-MOFOWoofer.pdf

Hope this helps.

Apr 05, 2009 | Power Acoustik MOFO-15 Car Subwoofer

1 Answer

When i turn on my radio the amp turns red for a couple second but it never goes green the red shut off and my subs dont sound..????


That usually means that its not getting power from battery check fuse underhood and in amp. Make shure the power wire isnt pinched to . Hope this helps

Jan 12, 2009 | Power Acoustik LT-980/2 Car Audio...

1 Answer

Wiring the coils together


For each sub, tie the DVCs in parallel ("+"s together, then "-"s together). This will make the subs look like 2 ohms to the amp. Then, put one sub on each channel of the amp. That will put about 280W rms onto each sub, the max for the amp.

Mar 15, 2008 | Power Acoustik Power-Acoustik FUBAR-12W...

1 Answer

600 watt 2 channel power acoustik sterling amp


On your amp, there should be a switch (on the side probably) that has "LP", "HP", and "FULL" or "OFF". This is a switch for the low pass/high pass filter. Switch it to "LP" as this will allow only low frequencies to go to your subs, what you want. If you don't have that switch, go to an audio store or online audio supplier and get either a low pass filter, band pass filter, or a cross-over, and follow the wiring diagram that comes with it to filter out the high frequencies before they get to your subs.

Oct 09, 2007 | Power Acoustik TS1440-2 Car Audio...

Not finding what you are looking for?
Power Acoustik TS620-2 Car Audio Amplifier Logo

Related Topics:

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...