Question about Jl Audio 12W7 Car Subwoofer

1 Answer

I have two jl audio 12 w6v2 running with a jl audio 1000/1 and at high volume they make a poping noise does any one know y

Posted by Anonymous on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Could be a power serge in your remote wire try different power sourse could be alot of things id try this 1 1st

Posted on May 14, 2010

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 417 Answers

SOURCE: i have two jl audio 12 w6v2 running with a jl

That popping noise is your speaker telling you to turn it down, and that your amp is too powerful for your setup. The speaker cone is moving beyond its limits of excursion and on it's way to malfunction/blown. Basically the voice coil will fry.

Posted on Apr 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1000/1 amp running two W6s in my truck along with a 300/ going strictly to my highs, i also have a capacitor for 1000 that only runs for the 1000/ amp and a JL audio 100 amp fuse for all of it....


You need to get another capacitor and wire it in series with the fist cap when you crank the volume your system is not getting enough power from the alternator this is called surge current. In modern electrical systems we use capacitors to compensate for these surges.

Mar 05, 2011 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

One sub not working


Try this....the speaker that is not working, gently work the cone up and down with you fingers. Be careful not to go right thru the cone. One hand underneath(near webbing) and one hand on top over the dust cover. If you hear any kind of scratching, or noise, or it's not "breathing" freely, then the voice coil of that speaker may have overheated, or the speaker has extended above and beyond its range of movement (called excursion). And may as well be blown/dead/fried..however you want to say. I hope this is not the case for you.

Apr 26, 2010 | Jl Audio 10W6v2 Car Subwoofer

1 Answer

I have two jl audio 12 w6v2 running with a jl audio 1000/1 and at high volume they make a poping noise does any one know y


That popping noise is your speaker telling you to turn it down, and that your amp is too powerful for your setup. The speaker cone is moving beyond its limits of excursion and on it's way to malfunction/blown. Basically the voice coil will fry.

Mar 16, 2010 | Jl Audio 12W7 Car Subwoofer

1 Answer

What would be a better amp for my jl audio 12in w6v2


its not the amps my dude ur ohm loading is wrong if u have a 4 ohm stabled amp n ur speakers r 2 ohms naw thats not gonna fly caus it cant put out what ur asking 4 so u need 2 reload ur subs try this link http://www.bcae1.com/spkrmlti.htm this should help u out n save u money

Jun 17, 2009 | Jl Audio 12W6v2 Car Subwoofer

1 Answer

Jl audio 1000/1 low voltage -keeps shutting off at high volume


You should definitely upgrade the power wire to the sub amp to 4 gauge -absolutely your choking your amp its starving for current-poor thing is starving !!!!!!!

Apr 16, 2009 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

ALPINE PDX 1.1000


well you would have to look into the ohms of the amp compared to the ohms of the speaker. If the ohms are different you would have to hook them up in a different way. check the RMS on the speaker as well as the amp, this can also be sufficed by wiring it different if ohms match up properly! Hope this helps you out and if this is not the case let me know.

Feb 28, 2009 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

Jl audio 500/1 amp low ohm light at high volume


I would try running the subs in parallel. Pos to Pos Dual Voice, Neg to Neg Dual Voice. Then Run + to + stereo - to - stereo on both channels.
So you have + and - running to one channel and + and - running to the other channel.
Also your LPF filter could be set too high.

Feb 07, 2009 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

Jl 1000/1 popping fuse


well you need to check to see if nt no shottage with the amp and also check if the fuse is not to low amp 20,,,, 25 if not put the amp in a separet 12 volt battery

Dec 10, 2008 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Amp problem


you either have a bad ground or your power line is too small, the farther you go from the battery the larger wire you need.

Dec 18, 2007 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Low ohms light ! ! ! !


How are the speaker wired and what is the ihms for the speakers?

Dec 06, 2007 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 12W7 Car Subwoofer Logo

Related Topics:

218 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...