Question about Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

I just got a sony xplod 1000 watt amp i got everything hooked up and when i turned the key the power light chaned from green to red. i check over the amp again and again, i cant find any thing wrong..... any ideas?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

  • Expert
  • 155 Answers

Try disconecting all speakers from the amp, turn it on after and if it stays on red it sounds like it had kicked the bucket. if it stays green start from their and check all of your wires for shorts (speaker wires) again. hope this helps...

Posted on May 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Audio & Video

1 Answer

Sony xplod 1000 watt amp not working


you need a amp kit your battery or alltinator isn't powerful enough to handle the wattage you need a juice can it gives yur battery more power

Jun 30, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony Xplod


If your still getting a green light, it at least sounds like the amplifier portion may still be funcitonal. Perhaps your inputs are blown. If your comfortable with electronics, pop the cover, and try patching a signal directly to the amplifier stage. and of course check your source.

Jun 20, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Blown amp possibly?


i have the same amp with the same problem.....your best bet is to do what i did get a better amp(audio pipe,spx,kicker,punch,etc) do not get pioneer amp or sony anything

Jun 20, 2009 | Kenwood KAC-X501F Car Audio Amplifier

2 Answers

I have 1000 watt sony XPLOD amp and i just installed it today. with new monster cable&ground. the green light turns on& thumping goes for a little. i try to raise up just a little bit& after 2...


it isnt getting enough power and its tripping the internal switch on the amp and putting it in safe mode. either your wire isnt a high enough gauge. you might need a capacitor or you need bigger wire.

Jun 13, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

3 Answers

Power protector light on sony xplode 1000 watt amp


a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Sony xplode 1000 watt amp


Make sure you don't have a short circuit somewhere. Make sure the wiring is all intact.

Also look at this link:

http://www.fixya.com/support/t132850-sony_xplod_1000_watt_car_amp_quit

Mike

Nov 07, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

1000 watt amp sony xplod


how do you have your system hooked? What speakers do you have? There is a lot more too it then just wattage.

Jan 23, 2007 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

240 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4869 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...