Question about Car Audio & Video

Open Question

Soundstream rubicon 1600 d car audio amplifier protection light on and kiciking on and off at a rapid pace

Posted by on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 13 Answers

SOURCE: don't know to conneect my amplifier connecting firdt a soundstream ecualizer

What are you running in to your amp? If it's a CD player or radio, find the wires from them, disconnect them from the amp and connect them to the equalizer, then connect the equalizer to the amp.

Posted on Jul 12, 2009

  • 269 Answers

SOURCE: i have a brand new soundstream xxx 6500d amplifier

You need to plug in the RCA and speakers you could blow the amp. The amp is sensing no Input and No output. I would unplug the amp wait around 30 seconds then install the rca and speakers THEN install amp to battery + cable. You should be ok.

Posted on Jan 29, 2010

SPL Freak
  • 63 Answers

SOURCE: legacy audio LA590 car audio amp protecet mode

Is that on all the time or are you saying the light is on? If that light is always on that just means it's protecting your amp. If it's off and not playing bass then your in trouble

Posted on Mar 06, 2010

  • 208 Answers

SOURCE: Xplod XM-554ZR Car Audio Amplifier: powr/protect light comes on red not green...

Hi, disconnect all speakers from unit and try again - if red light still shows then your amp has died.
If the light goes green, then start testing for shorted speaker/wiring. This includes speaker wiring to vehicle shorts - there should be an o/c reading on your meter

Posted on May 05, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I've had two soundstream rubicon 1.1600D amp's and they both worked for a while then the amp started to kick off and on. No fuses were blown, and the ground was fine. Any suggestions would be appreciated.


Sounds like a loose power connection? Check All connections, also make sure the impedance is correct 4ohm 8omh 16 ohm the speakers need to match the amplifiers output to work properly. ...

Feb 21, 2015 | Soundstream Car Audio & Video

1 Answer

Why would my 2500 soundstream Rub1 amp keep going into protection mode


Take a look inside it could possibly be a/some capacitor/s. If it is replace more than just one because they can also be going bad. This is a cheap fix they cost less than one or two dollars a piece.(if this is the problem)

Mar 30, 2014 | Soundstream RUB1.2500D 2500 Watts RMS Mono...

1 Answer

Soundstream rub1000d is not sending power to my subs


Does it have power indication, e.g. red light, green light

May 25, 2011 | Soundstream CAR AMPLIFIER, 1 CH, 1000 WTS...

1 Answer

Power to rubicon 404 no sound 4 channels of 2-way high pass


Check RCA,s at the back of the head deck, make sure sub is set to low bass frequency, make sure gain is turned up on the amp and head deck has subwoofer enabled and bass on. If you are powering speakers make sure the balance on the head deck is set to 0. Make sure it's wired up properly.

Jul 22, 2009 | Soundstream XTA240.2 Car Audio Amplifier

1 Answer

SHORT ON POWER SUPPLY


If it only goes into protect mode after the remote voltage is applied, the amp probably has shorted output transistors.

Nov 06, 2008 | Soundstream CAR AMPLIFIER, 1 CH, 1000 WTS...

1 Answer

Sounstream tra 560.2 always in 'protect'


It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Nov 01, 2008 | Soundstream Tarantula Car Audio Amplifier

1 Answer

My light on my amp is blinking at a steadty pace.


The amp appears to be in protect mode. The most common reason for an amp to go into or remain in protect mode is shorted output transistors. To eliminate other possible causes, read through the following page. Let me know if you have any other questions.

Amp in Protect Mode - Troubleshooting

Aug 06, 2008 | Alpine MRV-T420 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...