Question about Performance Teknique ICBM-779 Car Audio Amplifier

1 Answer

I'm having a problem with my amp. I just bought it this year n connected it to my memphis C3's n now every time I turn my car on it goes to diagnositic mode.

Posted by on

  • tommcrs May 10, 2010

    So can I fix that myself or do I have to send it in to get it repaired?? If so for either how do I fix it or how much will it cost me?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 57 Answers

You have bad driver sound inside your Amp. First remove all speaker, make sure no speaker cable short.For future problem, please visit my site athttp://billy-tech.blogspot.com/

Posted on May 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Memphis power preferred amp it was working this morning stoped working riding i checked it the fan is running but the pretect light is on and the power light is blinking and when it blinks the...


Try checking your ground connection. It should be as large as your +12V connection and should run directly to your battery. The chassis ground will cause lots of interference and
is not always reliable due to all of the bolted together parts which can get loose andelectrically nloisy.

Jan 27, 2015 | Memphis Car Audio & Video

1 Answer

Memphis 1500d amp


The flashing indicates that the amplifier is in 'protect' mode, which is often a sign of a ground fault, but may also indicate that one or more of your power and/or signal wires is crossed, connected incorrectly, or shorting out for some other reason.
In short: Go through all your wiring and check it thoroughly. Be patient, take your time, and I can almost guarantee you'll find the problem in a loose wire or perhaps your ground wire isn't connected to a part of the chassis that is fully grounded.
Unfortunately the Memphis 1500D is a discontinued model, so installation instructions for it are not readily available... however, the SPL 1500D is a very similar product and the wiring should be identical, so for your reference here is the installation manual for that unit:
http://www.spldynamics.fi/products/amplifiers/ICE-series/splclassDmanual1220.pdf

Hope that helps, good luck!

Dec 03, 2013 | Car Audio & Video

1 Answer

I have a 800 watt sony amp pushing 2 memphis pr's should the amp get hot


Yes the amplifier will become very warm or "hot". It is a good idea to place it in an area that will recieve plenty of ventilation and air flow. Some companies sell cooling fans for larger amps.

Jan 02, 2013 | Sony Xplod XM-554ZR Car Audio Amplifier

3 Answers

Hi, I use a 4GB memory card for my nokia C3 but from time to time my phone just gets hung over & dies. Then when I switch it back on without the memory card it works & when I try putting back the...


Hello Divinegoddes,

It seems that your phone memory card contains the virus.So scan your memory card using the anti virus installed in your machine.You can scan you memory card for antivirus using the Avira anti virus.Please download the anti virus from :

http://www.avira.com/en/free-download-avira-antivir-personal?

Download the .exe file from the above link.

Install the software in your computer. Remove the memory card from the phone and connect in your machine using the memory card reader and scan the card for viruses or malwares.

May 27, 2011 | Nokia C3 Cell Phone

2 Answers

Amp is on, but sub wont produce any bass


Make sure the subwoofer is set to low frequency, make sure subwoofer and bass are enabled on the headdeck. Make sure the gain is turned up on the amp, make sure the rcas haven't come out of the back of the head deck.

Aug 04, 2009 | JBL GTO14001 Car Amp

1 Answer

My amp turns on, power light is on, but overcurrent light also


make sure ground is good then turn gain all the way down turn on deck turn it all the way up then turn it off then back on agian its like a jump start the amp then should work and you can reset all youre levels

Apr 08, 2009 | Car Audio & Video

Not finding what you are looking for?
Performance Teknique ICBM-779 Car Audio Amplifier Logo

Related Topics:

121 people viewed this question

Ask a Question

Usually answered in minutes!

Top Performance Teknique Car Audio & Video Experts

George Nalley

Level 1 Expert

41 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

woodzowl307

Level 3 Expert

652 Answers

Are you a Performance Teknique Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...