Question about Cobra Mr F75b Marine Vhf Radio Fixed Mount 25watt

1 Answer

Lost Sound Unit Powers Up But I Have No Sound Out Of Unit??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 64 Answers

Your speaker has probably failed. I recommend taking your radio to a repair shop to replace the speaker. Should not be an expensive repair. I charge $75 for a speaker repair. They will also be able to go through the radio and check that everything else is ok. Feel free to contact me: kevin@sun-me.net if you need any help or want to send the radio to me for the repair.

Posted on Jun 14, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Unit powers up, cd and radio seem to be operating properly, but no sound is heard, unit worked fine a few days before, all wires are conected, everything seems unchanged


Well...as you said...the unit powers up...so you don't have a "dead set".I don't know if the speaker can be disconnected from the unit.As a rule of thumb...it is very rare that both channels (left and right )fail at the same time...it is usually one channel while the other speaker still operates.This is what I want you to do...In a quiet room..get really close to the unit...Switch it on and listen for any sound from the speakers...get really close...you should hear a slight hum from the woofers and a high frequency "hiss" from the tweeters....If no sound is heard..switch the unit off..You should hear a "plip" sound...If not...switch it on again...you should hear a slight "bump" sound from the woofers...If you hear no sound from the speakers at all..there is a problem with the output stages of the amplifier section.If you do hear sounds fron the speakers,,Turn up the volume and watch for an increase visually on the display (such as ascending numbers).If there is no indication of a volume increase...The "mute" may be stuck on..Try switching it off and on...please let me know what happens after you do all the tests....Looking to hear from you......PEACE!!!
ok...

Jul 11, 2011 | JVC HX-Z3 CD Shelf System

1 Answer

Zenith D60WLCD Unit powers down in one minute or less


mostlikly the deflection board is going out. and will need replaced

Dec 19, 2007 | Zenith D60WLCD 60" Rear Projection...

1 Answer

How to wire a sony cdx-gt640ui in a 1999 dodge intrepid...I get sound with the tuner, but no sound with cd, aux, and usb. I'm assuming its only an incorrect wiring setup...


instead of used the blue wire on the Sony head unit to the car wiring harness use the blue/whit wire

  • Blue - powers on only when am/fm is active
  • Blue/White - powers on when when radio is on am/fm/cd/ ect.

Jun 13, 2010 | Sony CDX-GT610Ui CD Player

1 Answer

Sony STR DE-445 unit powers up but no sound


Check the fuse, Sony is known for its random problems with sound. The one I have you must tap it on the side. Its a flicker switch inside.

Feb 13, 2010 | Sony STR-DE445 Receiver

1 Answer

MY ROCKFORD T15004. It worked fine until last year, I had the unit intstalled in the cabin of my boat and while the unit was playing the sound cut out. The Amp still powers up with the power light coming...


dampness probably is the issue , those components on the board are delicate to moisture . open cover and look in side on the amps board for any greenish white build up of corrosion on outputs , resistors ect .

Oct 28, 2009 | Rockford Fosgate T15004 Car Audio...

1 Answer

Sylvania SRT2232S Powers On, No Picture, High Frequency squeal


Hello there. I'm sorry to say that it sounds as if the element that actually energizes your screen is bad. It is most likely overheating. or quite poosible the power converter lost a resistor or 2.

Nov 27, 2008 | Sylvania SRT2232S 32" TV

1 Answer

Powers on then goes off!


yes bad solder connections on the vertical ic good luck

Nov 15, 2007 | Zenith B25A02Z TV

Not finding what you are looking for?
Cobra Mr F75b Marine Vhf Radio Fixed Mount 25watt Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cobra Boating Experts

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Bill Boyd

Level 3 Expert

42016 Answers

Are you a Cobra Boating Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...