Question about Televison & Video

1 Answer

We have power and sound but no picture , i have

Problem with techwood plasm tv 4210 , we have power and sound but no picture , i have been told i need a pcp chip ? any ideas on how to obtain one and fit please

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 160 Answers

If an authorized service repair center will sell you one. However looking at the reviews you may just want to replace the tv since even service centers have issues repairing the tv.
http://www.comparestoreprices.co.uk/plasma-screens/techwood-twp4210-reviews.asp

Posted on May 07, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to fix my 42 inch techwood 4210, as it has a black line going from top to bottom?


Hello

If the lines appear after your tv warms up then the problem is from the display board of your tv and unless this board is replaced then the lines will continue to appear.

I suggest you contact a repair person to help you replace your board.

Jun 09, 2011 | Televison & Video

1 Answer

Techwood twp 4210 media box


DEAD AV BOX NO POWER LIGHT

UNPLUG FROM THE MAINS
UNSCREW THE TOP CASE
UNPLUG THE 2 SOCKETS REF PICTURE ( TECHWOOD AV BOX RESET AND UNPLUG )

LEAVE THEM UNPLUGED AND “PLEASE BE CAREFUL AT THIS POINT” SWITCH THE MAINS BACK ON AND SWITCH THE POWER ON THE AV BOX, IF YOU GET A RED LIGHT SWITCH THE SET OFF.(PLEASE NOTE THE RED LIGHT MAY NO ALWAYS COME ON, SO DONT BE ALARMED).

PLUG BOTH THE LEADS BACK IN AND SCREW TOP CASE BACK.

CONNECT ALL BACK UP AND YOU SHOULD BE WORKING NOW
JOB DONE HARD RESET.

Let me know if you need any further help

thank you for using fixya and good luck

Apr 15, 2008 | Televison & Video

1 Answer

My techwood 1020 freeview recorder was fully working but now theres no picture or sound and when you press buttons on the remote a little red key is flashing on the box its self. help me please


hi mines is doing same from digital switchover theres a red key flashing and it wont record,although i can still use it as a freeview box.i bought from morrisons but because its just over a year old they told me to phone techwood and techwood told me they only deal with tvs even though its a techwood help number on the box!!

Mar 06, 2010 | Televison & Video

2 Answers

Techwood plasma twp 4210 broke


First make sure to hit the menu button on the TV's remote and if nothing is there then friend while the set is on turn a bright flashlight on and shine at angle into the set push the TV menu button if you can see a image then your back light is not working.
You can also check the transformers they are close to were the wires plug into the panel, make sure all transformers read the same amount of resistance if not you have found a bad one. Now you will have to check to see if the power supply is sending 24v to the backlight, if not the power supply is bad. Cost backlights around 150.00 and power supplies around 100.00. Well this should help you friend.

Dec 07, 2009 | Televison & Video

1 Answer

Techwood 42 plasms sound no picture


maybe the problem is on it's board

Oct 18, 2009 | Televison & Video

1 Answer

No picture or sound on 42" plasm TV


Try unplugging tv and then plugging tv back on if that doesn't work then you will need to replace the signal board

Jul 06, 2009 | ViewSonic VPW450HD 42 in. HD-Ready Plasma...

1 Answer

Black strip at the middle of the Screen


if this set has a transformer to power it ,try batteries instead if this cures it replace trans farr64

Apr 27, 2009 | Televison & Video

2 Answers

Buzzing sound on Vizio Plasma TV


likely supply failure or shorted pannel driver. u should be able to unplug the pannel boards from the power supply. if the buzzing stops than its the pannel boards otherwise its supply.

Dec 05, 2008 | Televison & Video

1 Answer

Techwood 4205/4210 series Plasma. Got sound but no picture. Any ideas?


probably a loose connection, any other hardware to try it on? Possibly non-functional video hardware, different monitor, does t work?

Jul 18, 2008 | Computers & Internet

1 Answer

Plasma tv techwood 4210


hi the most common fault on this tv is what you describe .i fixed mine by replacing the capacitor (1uf 630vdc) at location c19 on the power board .. cost for this component less than 90p

Oct 11, 2007 | Televison & Video

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

465 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74136 Answers

Cindy Wells

Level 3 Expert

5102 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...