Question about Mastercool 67471 Evaporative Cooler Air Conditioner

2 Answers

I have a Mastercool 2 speed 1Hp 220 volt cooler with a low voltage Mastercool CC2000B therostat. The problem is the swing time once my house reaches temperature. The swing is only 30 seconds to a minute. Besides the annoyance of the on and off noise, my motor only lasts one season...$$$$ Power bills$$$$ As far as I can tell there isn't any adjustments. My neighbors have the same problem. What can I do about the cycle time? Different brand thermostat....

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

Go manual turn switch, sounds like an overload problem. I have a Mastercool unit and going on 12 years with same motor.

Posted on May 10, 2010

  • HapTrail Jun 15, 2012

    My Master Stat Controller (CC2000A Rev 2003) was in 2 parts. The Thermostat unit in the house and the Power Control unit in the Cooler. The power Control unit was mounted on the squirrel cage fan housing so it vibrated some when running. That means the components vibrated slightly with respect to the PC board. Especially the larger components.
    My first symptom - Intermittent failure to turn the water pump on. I could see a faint crack in the solder around the pin of a relay on the PC board. Resoldering the PC pins solved that problem. Later, the second symptom was quicker than usual on-off cycling of the fan. I resoldered all the pins on the PC board and all problems subsided.
    A better mounting place for the Power Control Unit would be good, but outside of the cooler might be a thermal problem here in the hot desert south west.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

My Master Stat Controller (CC2000A Rev 2003) was in 2 parts. The Thermostat unit in the house and the Power Control unit in the Cooler. The power Control unit was mounted on the squirrel cage fan housing so it vibrated some when running. That means the components vibrated slightly with respect to the PC board. Especially the larger components. My first symptom - Intermittent failure to turn the water pump on. I could see a faint crack in the solder around the pin of a relay on the PC board. Re-soldering the PC pins solved that problem. The second symptom was quicker than usual on-off cycling of the fan. I re-soldered all the pins on the PC board and all problems subsided. A better mounting place for the Power Control Unit would be good, but outside of the cooler might be a thermal problem here in the hot desert south west.

Posted on Jun 15, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My portable generator runs great but only produces 7 volts and 20 volts on each 110 volt receptacle and 20 volts on the 220 volt receptacle. any ideas on troubleshooting steps to find the problem part?


Assuming the speed is correct check the voltage on the rotor brushes during running (Caution) It should be DC. If you have low or no DC voltage then the capacitor in the end of the generator housing is bad, or the AVR. If you do have voltage then make sure the slip rings are clean and shiny, from there you may have a rotor or stator issue that needs carefull resisitance check

Oct 13, 2013 | Buffalo Tools Sportsman GEN7000LP Portable...

1 Answer

We have just had an electrician do work around our house when we went to use the airconditioner it doesnt work. Tried to call our electrician but of course no answer. Any ideas how to start my...


Check the electrical panal and make sure the breaker is on(220 volt 2-piole breaker). Check at the air conditioning unit and make sure the disconnect is on and there are fuses in the disconnect. Some disconnects are a non-fusible type. Turn the breaker off at the electrical panal and make sure the fuses at the disconnect are good. Also check and see if the switch at the furance is on. Or check the electrical panal and make sure the breaker for the furnace is on(110 volt single pole breaker). This is only if it is a split system type air conditioner. Part insude , part outside. You need control voltaged (24 volts) from the furance to the outside contactor at the air conditioer for the system to operate.

Jan 27, 2011 | Mastercool 67680 Evaporative Cooler Air...

1 Answer

Can you please tell me the correct wiring for a Hayward 120V pool pump (not 240V) Thank you


Follow diagram on the tag. typically low voltage and high voltage volt are diagramed on the tag. Most manufactures send pumps out already for 220. the A and B terminals are for pump wires. and the lines are for the power cord. follow the diagram and you can't go wrong;

The Pool Tech

Jul 10, 2010 | Hayward 1HP Super Pump II Inground Pool...

1 Answer

High speed does not work but low speed does. Is there an easy fix, or will this require a motor replacement to get both speeds working again? The cooler is a Mastercool model MC64C


If your motor only works on low speed and not on high speed first check to see if you have the proper voltage to high speed. Check with a voltmeter or multimeter, check from common on the motor to high speed on the motor at the switch. If you have the proper voltage then you have an open winding on high speed and the motor needs replaced. If you don’t have the proper voltage or any volts, then the switch is bad and needs replaced. This also will be the same if, medium speed won’t work and low speed does.

May 29, 2010 | Mastercool 67680 Evaporative Cooler Air...

1 Answer

My motor switches from high to low over and over again


It sound like the low speed winding in the motor is bad.You will need to get a new motor.

Jul 24, 2009 | Mastercool 67680 Evaporative Cooler Air...

1 Answer

No low speed on my mobile master cooler module no mmb12c


Could be as simple as the switch, could be as complex as a pole burned out on the motor. If you reverse the connections on the speed selector switch and you end up with low speed and no high speed then you know it's just an inexpensive switch.

May 30, 2009 | Cfm 2000 Swamp Air Cooler MMB10 MasterCool...

Not finding what you are looking for?
Mastercool 67471 Evaporative Cooler Air Conditioner Logo

1,088 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mastercool Heating & Cooling Experts

Bill Long

Level 3 Expert

587 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Mastercool Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...