Question about Power Acoustik SL2-2000 Car Audio Amplifier

1 Answer

I have a power acoustik bamf 2000 class d amp and i think when i had it unhooked the positive and negative speaker wires might of touched for a few minutes and now the amp comes on no protection light just the normal green power one comes on but no sound comes out of the speakers its getting no power out of the speaker terminals on the amp no fuses blown on the amp.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Internal components are very sensitive to things like that. sounds like you shorted out some of the fets internaly .. i recomend a complete diagnostic and proceed to repairs.

Posted on May 07, 2010

  • bikerdude290 Mar 29, 2011

    did anyone ever figure out the solution to this problem... the exact same everything happened to me

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When I bridge them my amp cuts off. Why does it keep doing that . are the speakers too much power or am I doing something wrong


I suspect you have your system wired up in such a manner that the amp is seeing too low an ohmage from your speakers. Check what the minimum ohms your amp will push and wire your speakers up so the load doesn't go below that figure.

Apr 02, 2015 | AMP Music

1 Answer

Where is the factory amp located on 2000 celica gts?


I dont think there is a factory amp in your car i might be wrong but, if it is aftermarket check under seats, or behind glove box beside computer... according to the wiring schematic i have it said different ...notice were is states location of amp and trigger.
2000 Toyota Celica Car Stereo Radio Wiring Diagram
Car Radio Constant 12v+ Wire: Blue/Yellow
Car Radio Switched 12v+ Wire: Gray
Car Radio Ground Wire: Brown
Car Radio Illumination Wire: N/A
Car Stereo Dimmer Wire: N/A
Car Stereo Antenna Trigger: Black
Car Stereo Amp Trigger Wire: N/A
Car Stereo Amplifier Location: N/A
Front Speakers Size: N/A
Front Speakers Location: N/A
Left Front Speaker Positive Wire (+): Pink
Left Front Speaker Negative Wire (-): Violet
Right Front Speaker Positive Wire (+): Light Green
Right Front Speaker Negative Wire (-): Blue
Rear Speakers Size: N/A
Rear Speakers Location: N/A
Left Rear Speaker Positive Wire (+): Black
Left Rear Speaker Negative Wire (-): Yellow
Right Rear Speaker Positive Wire (+): Red
Right Rear Speaker Negative Wire (-): White

Jan 06, 2011 | 2000 Toyota Celica

1 Answer

How do you hook up two bamf 4000watt amps together with one bass knob. the subs im hooking up to are the new mofos from power acoustik.


A really "ghetto" way would be to take a splitter for a phone jack and have the two cables for the bass knobs run into it and then plug it into one of the bass knobs. There are other ways like splicing wires (time consuming and frustrating and not easy) or buying a converter which would be doing the same thing just a lot prettier. I like cheap and easy which would be to spend a few bucks on a splitter.

Aug 11, 2010 | Car Audio & Video

1 Answer

I have a power acoustik bamf 1600/4. not working 5 hours later


use a multimeter to see if the amp has good power wire and remote turn on voltage. then check the ground and make sure its a good strong ground. check the sub to make sure its not bad. make sure it reads whatever ohm its supposed to. anything less than 4 ohms will clip the amp if bridged. if alll that is good then the only thing left is the amp. it sounds like the power supply is bad but check everything else just to make sure. good luck.

Dec 29, 2009 | Power Acoustik BAMF1600/4 Car Amp

1 Answer

Speaker wire leads


i simply used my brain and hooked the copper wire to positive(red), and the silver wire to negative(black), being that the colors are similar. works fine.

Dec 13, 2009 | Power Acoustik NB-2 Car Tweeter

3 Answers

When I bridge the BAMF 2200/2 Power Acoustik amp it cuts off


Hello munchisfun,

I'd suspect that the amp is operating into too low of an impedance and going into protection.

The 2200/2 is not rated to drive a 2ohm load when bridged (most 2-channel amps aren't) and when you connect 2 4ohm subs in parallel, the load is 2ohms. I'd run one sub from each channel.

Hope this helps.

Jul 26, 2009 | Power Acoustik BAMF2200/2 Car Amp

1 Answer

Amp and subwoofer problem


try using an ipod or mp3 and hook it up directly to the amp input section-if its lit up and you get sound then youre not getting signal from your deck and youll have to track that problem down at the deck-if you still dont get any sound by connecting directly into the amp inputs then you may want to check all amp settings and be sure that your set up right and if it has external fuses make sure that they are all good and if it still wont give you any sound than take it in and get it checked out-hopefully its just not getting any signal cuz if its the amp then sorry to hear it-but good luck

May 21, 2009 | Power Acoustik BAMF2000/1D Car Amp

1 Answer

I have 2 15''s dual voice coil and i need to know how to wire them to my power acoustik bamf 4000 in a 1 ohm


most car-audio subs are rated at 4 ohms, as opposed to home audio's 6-8 ohms. If you have a pair of 4 ohm subs, wire all 4 positive terminals to the positive terminal on the amp and the sam with the negative sides. The key is to use the same length of wire on all connections.

Apr 28, 2009 | Power Acoustik BAMF4000/1D Car Amp

1 Answer

Power Acoustik TS620-2 Amplifier


Check the wiring at the speakers themselves. It's possible that while you were moving the box one of the speaker wires came loose and shorted against the other terminal. A shorted speaker wire or damaged speaker will cause the amplifier to go into protect mode. If you have a digital multimeter with a resistance feature, you can test the resistance between the positive and negative terminals for each speaker.

Feb 26, 2007 | Power Acoustik TS620-2 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

174 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...